summaryrefslogtreecommitdiffstats
path: root/source/a/kbd/kbd.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/a/kbd/kbd.SlackBuild')
-rwxr-xr-xsource/a/kbd/kbd.SlackBuild263
1 files changed, 117 insertions, 146 deletions
diff --git a/source/a/kbd/kbd.SlackBuild b/source/a/kbd/kbd.SlackBuild
index 6d394a44f..771423717 100755
--- a/source/a/kbd/kbd.SlackBuild
+++ b/source/a/kbd/kbd.SlackBuild
@@ -1,6 +1,6 @@
-#!/bin/bash
+#!/bin/sh
-# Copyright 2005-2021 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2020, 2023 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=kbd
-VERSION=1.15.3
-BUILD=${BUILD:-6}
+VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -47,174 +47,139 @@ fi
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
TMP=${TMP:-/tmp}
-PKG=$TMP/package-kbd
+PKG=$TMP/package-$PKGNAM
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
-
-# Add some extra fonts:
-( cd $PKG ; explodepkg $CWD/sources/extraf.tgz )
-
-# Extract source:
rm -rf $PKGNAM-$VERSION
-tar xvf $CWD/sources/$PKGNAM-$VERSION.tar.?z* || exit 1
+tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION || exit 1
# Make sure ownerships and permissions are sane:
chown -R root:root .
-find . -perm 666 -exec chmod 644 {} \+
-find . -perm 664 -exec chmod 644 {} \+
-find . -perm 600 -exec chmod 644 {} \+
-find . -perm 444 -exec chmod 644 {} \+
-find . -perm 400 -exec chmod 644 {} \+
-find . -perm 440 -exec chmod 644 {} \+
-find . -perm 777 -exec chmod 755 {} \+
-find . -perm 775 -exec chmod 755 {} \+
-find . -perm 511 -exec chmod 755 {} \+
-find . -perm 711 -exec chmod 755 {} \+
-find . -perm 555 -exec chmod 755 {} \+
-
-# Apply patches:
-# These are taken from Fedora's SRPM:
-zcat $CWD/sources/kbd-1.15.2-po.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/sources/kbd-1.15-keycodes-man.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/sources/kbd-1.15-unicode_start.patch.gz | patch -p1 --verbose || exit 1
-zcat $CWD/sources/kbd-1.15-resizecon-x86_64.patch.gz | patch -p1 --verbose || exit 1
-
-# This is from Mandriva's SRPM:
-zcat $CWD/sources/kbd-1.15.3-fix-es-translation.patch.gz | patch -p1 --verbose || exit 1
-
-# This is from Fedora's spec file:
-# 7-bit maps are obsolete; so are non-euro maps
-( cd data/keymaps/i386
- mv qwerty/fi.map qwerty/fi-old.map
- cp -fav qwerty/fi-latin9.map qwerty/fi.map
- cp -fav qwerty/pt-latin9.map qwerty/pt.map
- cp -fav qwerty/sv-latin1.map qwerty/se-latin1.map
- mv -fv azerty/fr.map azerty/fr-old.map
- cp -fav azerty/fr-latin9.map azerty/fr.map
- cp -fav azerty/fr-latin9.map azerty/fr-latin0.map # legacy alias
-
- # Rename conflicting keymaps
- mv -fv dvorak/no.map dvorak/no-dvorak.map
- mv -fv fgGIod/trf.map fgGIod/trf-fgGIod.map
- mv -fv olpc/es.map olpc/es-olpc.map
- mv -fv olpc/pt.map olpc/pt-olpc.map
- mv -fv qwerty/cz.map qwerty/cz-qwerty.map )
-
-# Apply a euro fix for the nl.map from alienBOB:
-zcat $CWD/sources/nl.euro.diff.gz | patch -p1 || exit 1
-
-# Configure:
-CFLAGS="-fcommon" \
-./configure \
- --prefix=/usr \
- --localedir=/usr/share/locale/ \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PKGNAM-$VERSION \
- --datadir=/usr/share/kbd \
- --enable-nls || exit 1
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \+ -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \+
+
+# Thanks, LFS
+zcat $CWD/kbd-2.6.3-backspace-1.patch.gz | patch -p1 --verbose || exit 1
-# Build:
-make $NUMJOBS || exit 1
+# Thanks, Arch
+zcat $CWD/fix-euro2.patch.gz | patch -p1 --verbose || exit 1
-# Install into package:
+# Don't include resizecons or manpage:
+# "it requires the defunct svgalib to provide the video mode files - for
+# normal use setfont sizes the console appropriately"
+# Thanks again LFS
+sed -i '/RESIZECONS_PROGS=/s/yes/no/' configure
+sed -i 's/resizecons.8 //' docs/man/man8/Makefile.in
+
+# 7-bit maps are obsolete; so are non-euro maps
+cp -fav data/keymaps/i386/qwerty/pt-latin9.map \
+ data/keymaps/i386/qwerty/pt.map
+cp -fav data/keymaps/i386/qwerty/sv-latin1.map \
+ data/keymaps/i386/qwerty/se-latin1.map
+mv -fv data/keymaps/i386/azerty/fr.map \
+ data/keymaps/i386/azerty/fr-old.map
+cp -fav data/keymaps/i386/azerty/fr-latin9.map \
+ data/keymaps/i386/azerty/fr.map
+
+# legacy alias
+cp -fav data/keymaps/i386/azerty/fr-latin9.map \
+ data/keymaps/i386/azerty/fr-latin0.map
+
+# Rename conflicting keymaps
+mv -fv data/keymaps/i386/colemak/en-latin9.map \
+ data/keymaps/i386/colemak/colemak.map
+mv -fv data/keymaps/i386/fgGIod/trf.map \
+ data/keymaps/i386/fgGIod/trf-fgGIod.map
+mv -fv data/keymaps/i386/olpc/es.map \
+ data/keymaps/i386/olpc/es-olpc.map
+mv -fv data/keymaps/i386/olpc/pt.map \
+ data/keymaps/i386/olpc/pt-olpc.map
+mv -fv data/keymaps/i386/qwerty/cz.map \
+ data/keymaps/i386/qwerty/cz-qwerty.map
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PKGNAM-$VERSION \
+ --localedir=/usr/share/locale/ \
+ --datadir=/usr/share/kbd \
+ --enable-nls \
+ --enable-optional-progs \
+ --enable-libkeymap \
+ --disable-tests \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+# Build and install:
+make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
-# This is where it's always been in Slackware, so let's move it back:
-( cd $PKG
- mkdir -vpm755 bin
- mv -fv usr/bin/loadkeys bin/
- cd usr/bin ; ln -vsf ../../bin/loadkeys . )
-# Build/install resizecons:
-( cd src
- make resizecons || exit 1
- cp resizecons $PKG/usr/bin
-) || exit 1
+# ro_win.map.gz is useless:
+rm -f $PKG/usr/share/kbd/keymaps/i386/qwerty/ro_win.map.gz
-# ro_win.map.gz is useless
-rm -fv $PKG/usr/share/kbd/keymaps/i386/qwerty/ro_win.map.gz
+# Install PAM configuration for vlock
+mkdir -p $PKG/etc/pam.d
+cat $CWD/vlock.pamd > $PKG/etc/pam.d/vlock.new
-# The rhpl keyboard layout table is indexed by kbd layout names, so we need a
-# Korean keyboard
-ln -vfs us.map.gz $PKG/usr/share/kbd/keymaps/i386/qwerty/ko.map.gz
+# Add some extra fonts:
+( cd $PKG ; explodepkg $CWD/sources/extraf.tgz )
+
+# Make sure kbdinfo manpage is installed:
+if [ ! -r $PKG/usr/man/man1/kbdinfo.1 ]; then
+ cp -a ./docs/man/man1/kbdinfo.1 $PKG/usr/man/man1
+fi
# Install the setup script that will be run from the Slackware installer:
mkdir -pm755 $PKG/var/log/setup
install -vpm755 $CWD/setup.setconsolefont $PKG/var/log/setup/
install -vpm755 $CWD/setconsolefont $PKG/usr/bin/
-# Copy docs:
-mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
-cp -a \
- COPYING* README* doc/* \
- $PKG/usr/doc/$PKGNAM-$VERSION
-rm -f $PKG/usr/doc/$PKGNAM-$VERSION/kbd.FAQ.sgml
-
-# If there's a ChangeLog, installing at least part of the recent history
-# is useful, but don't let it get totally out of control:
-if [ -r ChangeLog ]; then
- DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
- cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
- touch -r ChangeLog $DOCSDIR/ChangeLog
-fi
-
-# Additional keymaps:
-# This is the keymap for Speakup (http://linux-speakup.org) users:
-cat $CWD/sources/speakupmap.map.gz > $PKG/usr/share/kbd/keymaps/i386/qwerty/speakupmap.map.gz
-# Another keymap for Speakup from Thomas Ward, for JFW users.
-tar xvf $CWD/sources/speakup-jfw.tar.gz
-( cd speakup-jfw
- cat speakup-jfw.map | gzip -9c > $PKG/usr/share/kbd/keymaps/i386/qwerty/speakup-jfw.map.gz
- cat readme > $PKG/usr/share/kbd/keymaps/i386/qwerty/speakup-jfw.readme )
-
# Create the default run control script which will set the
# console font to the "default"... though this might not be
# the same state as if setfont were not used at all.
# For that reason, default the script to non-executable.
mkdir -pm755 $PKG/etc/rc.d
cat << EOF > $PKG/etc/rc.d/rc.font.new
-#!/bin/bash
+#!/bin/sh
#
# This selects your default screen font from among the ones in
# /usr/share/kbd/consolefonts.
#
setfont -v
EOF
-chmod 644 $PKG/etc/rc.d/rc.font.new
+chmod 0644 $PKG/etc/rc.d/rc.font.new
-# Create package post-install script:
-mkdir -p $PKG/install
-cat << EOF > $PKG/install/doinst.sh
-
-config() {
- NEW="\$1"
- OLD="\$(dirname \$NEW)/\$(basename \$NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r \$OLD ]; then
- mv \$NEW \$OLD
- elif [ "\$(cat \$OLD | md5sum)" = "\$(cat \$NEW | md5sum)" ]; then
- # toss the redundant copy
- rm \$NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-# Leave any new rc.font with the same permissions as the old one:
-# This is a kludge, but it's because there's no --reference option
-# on busybox's 'chmod':
-if [ -e etc/rc.d/rc.font ]; then
- if [ -x etc/rc.d/rc.font ]; then
- chmod 755 etc/rc.d/rc.font.new
- else
- chmod 644 etc/rc.d/rc.font.new
- fi
-fi
-# Then config() it:
-config etc/rc.d/rc.font.new
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
-EOF
+# Strip binaries:
+find $PKG | xargs file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
# Compress and link manpages, if any:
if [ -d $PKG/usr/man ]; then
@@ -225,21 +190,27 @@ if [ -d $PKG/usr/man ]; then
ln -s $( readlink $eachpage ).gz $eachpage.gz
rm $eachpage
done
- gzip -9 *.?
+ gzip -9 *.*
)
done
)
fi
-# Install package description:
-install -vpm644 $CWD/slack-desc $PKG/install/
+# Add a documentation directory:
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
+cp -a AUTHORS COPYING CREDITS NEWS README $PKG/usr/doc/$PKGNAM-$VERSION
+
+# If there's a ChangeLog, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r ChangeLog ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/*-$VERSION)
+ cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
+ touch -r ChangeLog $DOCSDIR/ChangeLog
+fi
-# Strip binaries:
-( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+mkdir -p $PKG/install
+zcat $CWD/doinst.sh.gz > $PKG/install/doinst.sh
+cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz
-