summaryrefslogtreecommitdiffstats
path: root/source/l/system-config-printer/system-config-printer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/system-config-printer/system-config-printer.SlackBuild')
-rwxr-xr-xsource/l/system-config-printer/system-config-printer.SlackBuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/source/l/system-config-printer/system-config-printer.SlackBuild b/source/l/system-config-printer/system-config-printer.SlackBuild
index 15b5a60b8..c8782bafa 100755
--- a/source/l/system-config-printer/system-config-printer.SlackBuild
+++ b/source/l/system-config-printer/system-config-printer.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2010, 2011, 2012 Eric Hameleers, Eindhoven, NL
-# Copyright 2010, 2011, 2012, 2013, 2018, 2020, 2021, 2022 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2010, 2011, 2012, 2013, 2018, 2020, 2021, 2022, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -113,6 +113,7 @@ PYTHON=/usr/bin/python3 \
--docdir=/usr/doc/$PKGNAM-$VERSION \
--localstatedir=/var/lib \
--sysconfdir=/etc \
+ --with-udevdir=/lib/udev \
--with-udev-rules \
--with-systemdsystemunitdir=no \
--program-prefix= \
@@ -134,14 +135,10 @@ python3 setup.py install --root=$PKG || exit 1
python3 -m compileall "${PKG}/usr/share/system-config-printer"
python3 -O -m compileall "${PKG}/usr/share/system-config-printer"
-# Move the udev files to the usual Slackware location:
-mkdir -p $PKG/lib
-mv $PKG/etc/udev $PKG/lib/
-
# Move the dbus configs to the system location:
mkdir -p $PKG/usr/share/dbus-1/system.d/
mv $PKG/etc/dbus-1/system.d/* $PKG/usr/share/dbus-1/system.d/
-rmdir --parents $PKG/etc/dbus-1/system.d/
+rm -rf $PKG/etc/dbus-1
if [ ! -L /lib${LIBDIRSUFFIX}/libpam.so.? ]; then
# Looks like PAM is not installed. Instead, your user must be in group 'lp'.