summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Klaatu <klaatu@member.fsf.org>2017-04-01 17:27:01 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-04-08 06:57:41 +0700
commit1b4070a6e06cf45cc9b6fe42b19071d850092081 (patch)
treeeccc855836216060f7ac67537c3d479c64e75f9d
parentd49b47f6c18cec6cf3edbb82d542da6dc086189f (diff)
downloadslackbuilds-1b4070a6e06cf45cc9b6fe42b19071d850092081.tar.gz
slackbuilds-1b4070a6e06cf45cc9b6fe42b19071d850092081.tar.xz
multimedia/mscore: Removed (renamed to MuseScore).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
-rw-r--r--multimedia/mscore/README11
-rw-r--r--multimedia/mscore/doinst.sh7
-rw-r--r--multimedia/mscore/mscore.SlackBuild77
-rw-r--r--multimedia/mscore/mscore.info10
-rw-r--r--multimedia/mscore/slack-desc19
5 files changed, 0 insertions, 124 deletions
diff --git a/multimedia/mscore/README b/multimedia/mscore/README
deleted file mode 100644
index ebee50cb2a..0000000000
--- a/multimedia/mscore/README
+++ /dev/null
@@ -1,11 +0,0 @@
-MuseScore is a free cross platform WYSIWYG music notation
-program, licenced under GNU GPL. Features:
- * WYSIWYG, notes are entered on a "virtual note sheet"
- * unlimited number of staves
- * up to four voices/staff
- * easy and fast note entry with mouse, keyboard or midi
- * integrated sequencer and FluidSynth software synthesizer
- * import and export of MusicXml and standard midifiles (SMF)
- * platform independent code for Linux, Windows and Mac
-
-portaudio is optional dependency
diff --git a/multimedia/mscore/doinst.sh b/multimedia/mscore/doinst.sh
deleted file mode 100644
index 9a8ded3c60..0000000000
--- a/multimedia/mscore/doinst.sh
+++ /dev/null
@@ -1,7 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
diff --git a/multimedia/mscore/mscore.SlackBuild b/multimedia/mscore/mscore.SlackBuild
deleted file mode 100644
index a3c27310b4..0000000000
--- a/multimedia/mscore/mscore.SlackBuild
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/sh
-# Slackware build script for mscore
-# Maintained by Klaatu at memeber.fsf dot org
-
-PRGNAM=mscore
-SRCNAM=MuseScore
-VERSION=${VERSION:-2.0.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- #must hardcode arch or it fails as 32bit
- sed -i 's|m32|m64|' ./$PRGNAM/CMakeLists.txt
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
- make release PREFIX=/usr CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" LDFLAGS="-pthread"
- make install PREFIX=/usr DESTDIR=$PKG
-
-mkdir -p $PKG/usr/man/man1
-mv $PKG/usr/share/man/* $PKG/usr/man/man1
-rm -rf $PKG/usr/share/man
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.* README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/mscore/mscore.info b/multimedia/mscore/mscore.info
deleted file mode 100644
index 2698191bf4..0000000000
--- a/multimedia/mscore/mscore.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mscore"
-VERSION="2.0.3"
-HOMEPAGE="http://www.musescore.org/"
-DOWNLOAD="https://github.com/musescore/MuseScore/archive/v2.0.3/v2.0.3.tar.gz"
-MD5SUM="9f1a870302b27c25e8be729648af1c64"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="qt5-webkit jack2 lame portaudio"
-MAINTAINER="Klaatu"
-EMAIL="klaatu@member.fsf.org"
diff --git a/multimedia/mscore/slack-desc b/multimedia/mscore/slack-desc
deleted file mode 100644
index 8bfdd8adca..0000000000
--- a/multimedia/mscore/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-mscore: mscore (WYSIWYG Music Score Typesetter)
-mscore:
-mscore: MuseScore is a free cross platform WYSIWYG music notation program,
-mscore: licenced under GNU GPL.
-mscore:
-mscore: Homepage: http://www.musescore.org/
-mscore:
-mscore:
-mscore:
-mscore:
-mscore: