summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+SBo@gmail.com>2023-06-09 03:46:42 +0100
committer bedlam <dave@slackbuilds.org>2023-06-09 03:46:42 +0100
commitf0a0fa2719d9387b2a9b40bd8b363cef7498510a (patch)
treedc599524aee38b7befc5ba00eb3e16ce47a774f5
parentb3784e0569ec411f9b523f6fdf0a7d76006ec325 (diff)
downloadslackbuilds-f0a0fa2719d9387b2a9b40bd8b363cef7498510a.tar.gz
slackbuilds-f0a0fa2719d9387b2a9b40bd8b363cef7498510a.tar.xz
python/python3-lazy_loader: Added (Load subpackages and functions)
Signed-off-by: bedlam <dave@slackbuilds.org>
-rw-r--r--python/python3-lazy_loader/README9
-rw-r--r--python/python3-lazy_loader/python3-lazy_loader.SlackBuild96
-rw-r--r--python/python3-lazy_loader/python3-lazy_loader.info10
-rw-r--r--python/python3-lazy_loader/slack-desc19
4 files changed, 134 insertions, 0 deletions
diff --git a/python/python3-lazy_loader/README b/python/python3-lazy_loader/README
new file mode 100644
index 0000000000..47ed1844fc
--- /dev/null
+++ b/python/python3-lazy_loader/README
@@ -0,0 +1,9 @@
+python3-lazy_loader (Load subpackages and functions on demand)
+
+lazy_loader makes it easy to load subpackages and functions on demand.
+
+Motivation:
+1. Allow subpackages to be made visible to users without incurring
+import costs.
+2. Allow external libraries to be imported only when used, improving
+import times.
diff --git a/python/python3-lazy_loader/python3-lazy_loader.SlackBuild b/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
new file mode 100644
index 0000000000..b6ed0b5bff
--- /dev/null
+++ b/python/python3-lazy_loader/python3-lazy_loader.SlackBuild
@@ -0,0 +1,96 @@
+#!/bin/bash
+
+# Slackware build script for python3-lazy_loader
+
+# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-lazy_loader
+VERSION=${VERSION:-0.2}
+SRCNAM=${SRCNAM:-lazy_loader}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# For no setup.py (requires wheel & python3-installer as dependencies)
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir=$PKG dist/*.whl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.md LICENSE.md README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-lazy_loader/python3-lazy_loader.info b/python/python3-lazy_loader/python3-lazy_loader.info
new file mode 100644
index 0000000000..4b7716a4d3
--- /dev/null
+++ b/python/python3-lazy_loader/python3-lazy_loader.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-lazy_loader"
+VERSION="0.2"
+HOMEPAGE="https://scientific-python.org/specs/spec-0001/"
+DOWNLOAD="https://github.com/scientific-python/lazy_loader/archive/refs/tags/v0.2/lazy_loader-0.2.tar.gz"
+MD5SUM="3d2d25465bf98a9ebc84627e96a3cef5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-build"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"
diff --git a/python/python3-lazy_loader/slack-desc b/python/python3-lazy_loader/slack-desc
new file mode 100644
index 0000000000..44e7583a81
--- /dev/null
+++ b/python/python3-lazy_loader/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-lazy_loader: python3-lazy_loader (Load subpackages and functions on demand)
+python3-lazy_loader:
+python3-lazy_loader: lazy_loader makes it easy to load subpackages and functions on demand.
+python3-lazy_loader:
+python3-lazy_loader: Motivation:
+python3-lazy_loader: 1. Allow subpackages to be made visible to users without incurring
+python3-lazy_loader: import costs.
+python3-lazy_loader: 2. Allow external libraries to be imported only when used, improving
+python3-lazy_loader: import times.
+python3-lazy_loader:
+python3-lazy_loader: HOMEPAGE: https://scientific-python.org/specs/spec-0001/