summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Fellype do Nascimento <fellype (at) gmail (dot) com>2023-07-28 20:28:24 +0900
committer Andrew Clemons <andrew.clemons@gmail.com>2023-07-28 21:02:45 +0900
commit94e5311a47d8838130d87499cf712509466d7d33 (patch)
treeeb04c6c2ff7bd7984ccfc28bd9f498daa4a9cefb
parentf3012e7ccea575ed66fe5322c1e9a40001c5fca9 (diff)
downloadslackbuilds-94e5311a47d8838130d87499cf712509466d7d33.tar.gz
slackbuilds-94e5311a47d8838130d87499cf712509466d7d33.tar.xz
libraries/labplot2: Updated for version 2.10.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com>
-rw-r--r--libraries/labplot2/README23
-rw-r--r--libraries/labplot2/doinst.sh14
-rw-r--r--libraries/labplot2/labplot2.SlackBuild130
-rw-r--r--libraries/labplot2/labplot2.info10
-rw-r--r--libraries/labplot2/slack-desc19
5 files changed, 196 insertions, 0 deletions
diff --git a/libraries/labplot2/README b/libraries/labplot2/README
new file mode 100644
index 0000000000..11b9ca7430
--- /dev/null
+++ b/libraries/labplot2/README
@@ -0,0 +1,23 @@
+labplot2 (interactive graphing and analysis of scientific data)
+
+LabPlot is a KDE-application for interactive graphing and analysis of
+scientific data.
+
+LabPlot provides an easy way to create, manage and edit plots. It
+allows you to produce plots based on data from a spreadsheet or on
+data imported from external files. Plots can be exported to several
+pixmap and vector graphic formats.
+
+LabPlot2 is a complete rewrite of LabPlot1 and lacks in the first
+release a lot of features available in the predecessor. On the other
+hand, the GUI and the usability is more superior as compared to
+LabPlot1 and there are several new features that were not available
+in LabPlot1.
+
+optional dependencies:
+
+- hdf5
+- netcdf
+- cfitsio
+- matio
+- discount
diff --git a/libraries/labplot2/doinst.sh b/libraries/labplot2/doinst.sh
new file mode 100644
index 0000000000..4f83cde390
--- /dev/null
+++ b/libraries/labplot2/doinst.sh
@@ -0,0 +1,14 @@
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/libraries/labplot2/labplot2.SlackBuild b/libraries/labplot2/labplot2.SlackBuild
new file mode 100644
index 0000000000..2749f283aa
--- /dev/null
+++ b/libraries/labplot2/labplot2.SlackBuild
@@ -0,0 +1,130 @@
+#!/bin/bash
+#
+# Slackware build script for LabPlot
+# Based on the Slackware 15.0 SlackBuild and AUR PKGBUILD for labplot
+#
+# Copyright 2014-2023, Fellype do Nascimento, Guaratingueta - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+NAME=labplot
+
+PRGNAM=labplot2
+VERSION=${VERSION:-2.10.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $NAME-$VERSION
+tar -xJf $CWD/$NAME-$VERSION.tar.xz
+cd $NAME-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+./compile
+
+( cd build/
+cmake ./ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DENABLE_READSTAT=OFF \
+ -DENABLE_TESTS=OFF \
+ -DLOCAL_DBC_PARSER=OFF \
+ -DLOCAL_VECTOR_BLF=OFF \
+ ..
+make
+make install/strip DESTDIR=$PKG
+)
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# no usr/share/doc dir
+mkdir -p $PKG/usr/doc
+mv $PKG/usr/share/doc/* $PKG/usr/doc
+rmdir $PKG/usr/share/doc
+
+# Leave only one main category in key "Categories" for the .desktop file
+sed -i "s:Qt;KDE;Education;Science;Physics;Math;:Science;:" $PKG/usr/share/applications/org.kde.labplot2.desktop
+
+# Fix permissions in .desktop file
+chmod 0644 $PKG/usr/share/applications/org.kde.labplot2.desktop
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog README.md LICENSES/* \
+$PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
+
diff --git a/libraries/labplot2/labplot2.info b/libraries/labplot2/labplot2.info
new file mode 100644
index 0000000000..fca8ba5bad
--- /dev/null
+++ b/libraries/labplot2/labplot2.info
@@ -0,0 +1,10 @@
+PRGNAM="labplot2"
+VERSION="2.10.1"
+HOMEPAGE="https://labplot.kde.org/"
+DOWNLOAD="https://download.kde.org/stable/labplot/labplot-2.10.1.tar.xz"
+MD5SUM="b3cdfe029d64fa834e0990e9b5ab446f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fellype do Nascimento"
+EMAIL="fellype (at) gmail (dot) com"
diff --git a/libraries/labplot2/slack-desc b/libraries/labplot2/slack-desc
new file mode 100644
index 0000000000..7bd9341d2e
--- /dev/null
+++ b/libraries/labplot2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+labplot2: labplot2 (interactive graphing and analysis of scientific data)
+labplot2:
+labplot2: LabPlot is a KDE-application for interactive graphing and analysis of
+labplot2: scientific data. LabPlot provides an easy way to create, manage and
+labplot2: edit plots.
+labplot2: LabPlot2 is a complete rewrite of LabPlot1 and lacks in the first
+labplot2: release a lot of features available in the predecessor. On the other
+labplot2: hand, the GUI and the usability is more superior as compared to
+labplot2: LabPlot1 and there are several new features that were not available
+labplot2: in LabPlot1.
+labplot2: