summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author fourtysixandtwo <fourtysixandtwo@sliderr.net>2024-03-23 21:25:42 -0600
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-30 09:39:47 +0700
commitc40cf8b08c711578c3be218e5a3b81b22e116988 (patch)
tree831e318c8c6d680dd919b1c1b26d2fad5bc59087
parentd4318fa4e8fd2bade88367017aeddcb0f74f39af (diff)
downloadslackbuilds-c40cf8b08c711578c3be218e5a3b81b22e116988.tar.gz
slackbuilds-c40cf8b08c711578c3be218e5a3b81b22e116988.tar.xz
python/python3-glances: Updated for version 3.4.0.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-glances/python3-glances.SlackBuild25
-rw-r--r--python/python3-glances/python3-glances.info6
2 files changed, 10 insertions, 21 deletions
diff --git a/python/python3-glances/python3-glances.SlackBuild b/python/python3-glances/python3-glances.SlackBuild
index 0a966b3d46..d211b2bebc 100644
--- a/python/python3-glances/python3-glances.SlackBuild
+++ b/python/python3-glances/python3-glances.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-glances
-# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-2024 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20240323 46and2: Updated version, change to pep517 build.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-glances
SRCNAM=${PRGNAM#python3-*}
-VERSION=${VERSION:-3.4.0.3}
+VERSION=${VERSION:-3.4.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +50,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -80,12 +68,13 @@ find -L . \
#change location to install man pages
sed -i 's|share/man|man|g' setup.py
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
#cleanup usr/share
diff --git a/python/python3-glances/python3-glances.info b/python/python3-glances/python3-glances.info
index 9af74d4aff..e373c4eb53 100644
--- a/python/python3-glances/python3-glances.info
+++ b/python/python3-glances/python3-glances.info
@@ -1,8 +1,8 @@
PRGNAM="python3-glances"
-VERSION="3.4.0.3"
+VERSION="3.4.0.5"
HOMEPAGE="https://github.com/nicolargo/glances"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/g/glances/Glances-3.4.0.3.tar.gz"
-MD5SUM="712c08830271d239a8303129d9ad4a96"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/g/glances/Glances-3.4.0.5.tar.gz"
+MD5SUM="865998839b2176d385947cfa762e8cf7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-psutil python3-defusedxml python3-ujson"