summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2023-11-29 18:15:39 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-02 07:54:23 +0700
commitc1346a027e62e62006eec87a9edefc696963a263 (patch)
tree05a1c43f467fec9db35fef7747c2235dfdc690dc
parentc2a1c7fa085e5cbc48c7ee910c358d7dde3decad (diff)
downloadslackbuilds-c1346a027e62e62006eec87a9edefc696963a263.tar.gz
slackbuilds-c1346a027e62e62006eec87a9edefc696963a263.tar.xz
network/etherpoke: Update script.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/etherpoke/etherpoke.SlackBuild13
-rw-r--r--network/etherpoke/etherpoke.info6
-rw-r--r--network/etherpoke/slack-desc2
3 files changed, 13 insertions, 8 deletions
diff --git a/network/etherpoke/etherpoke.SlackBuild b/network/etherpoke/etherpoke.SlackBuild
index f60df039a9..65e459a5f4 100644
--- a/network/etherpoke/etherpoke.SlackBuild
+++ b/network/etherpoke/etherpoke.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for etherpoke
-# Copyright 2015-2016 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2015-2023 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=etherpoke
VERSION=${VERSION:-2.5.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -70,7 +70,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -82,13 +82,18 @@ find -L . \
mkdir -p $PKG/usr/sbin
sed -i "s#/usr/local/sbin#$PKG/usr/sbin#" src/Makefile
+sed -i '1d' README.md
+sed -i '1i Homepage: http://web.archive.org/web/20160305135410/http://codeward.org/etherpoke/' \
+ README.md
+
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md Changelog AUTHORS COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md Changelog AUTHORS COPYING conf/$PRGNAM.conf.example \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/network/etherpoke/etherpoke.info b/network/etherpoke/etherpoke.info
index 02413cd6c8..2eb0ecbb2a 100644
--- a/network/etherpoke/etherpoke.info
+++ b/network/etherpoke/etherpoke.info
@@ -1,10 +1,10 @@
PRGNAM="etherpoke"
VERSION="2.5.1"
-HOMEPAGE="https://github.com/erlcash/etherpoke"
-DOWNLOAD="https://github.com/erlcash/etherpoke/archive/2.5.1.tar.gz"
+HOMEPAGE="http://web.archive.org/web/20160305135410/http://codeward.org/etherpoke/"
+DOWNLOAD="https://github.com/erlcash/etherpoke/archive/2.5.1/etherpoke-2.5.1.tar.gz"
MD5SUM="d236dc011ec265693e96d139018d8247"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libconfig"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"
diff --git a/network/etherpoke/slack-desc b/network/etherpoke/slack-desc
index b38b08a389..1a1f746ae1 100644
--- a/network/etherpoke/slack-desc
+++ b/network/etherpoke/slack-desc
@@ -12,7 +12,7 @@ etherpoke: etherpoke defines two events: SESSION_BEGIN, SESSION_END to which a
etherpoke: hook (system command) can be assigned. The event hook can be any
etherpoke: program installed in the system.
etherpoke:
-etherpoke: Homepage: https://github.com/erlcash/etherpoke
+etherpoke:
etherpoke:
etherpoke:
etherpoke: