summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Giancarlo Dessi <slack@giand.it>2024-04-19 21:52:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-19 22:06:54 +0700
commit99d2acf2820526e41298c72e36b61affffc6cd4e (patch)
treec5bb9d519b0bada7ab5761394b243c65c69fa31d
parent479192bf77cca234356059107d05536c7177f3bf (diff)
downloadslackbuilds-99d2acf2820526e41298c72e36b61affffc6cd4e.tar.gz
slackbuilds-99d2acf2820526e41298c72e36b61affffc6cd4e.tar.xz
libraries/msgpack-c-c: Updated for version 6.0.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/msgpack-c-c/README15
-rw-r--r--libraries/msgpack-c-c/msgpack-c-c.SlackBuild11
-rw-r--r--libraries/msgpack-c-c/msgpack-c-c.info6
3 files changed, 19 insertions, 13 deletions
diff --git a/libraries/msgpack-c-c/README b/libraries/msgpack-c-c/README
index 65a7513691..4219870b84 100644
--- a/libraries/msgpack-c-c/README
+++ b/libraries/msgpack-c-c/README
@@ -2,15 +2,20 @@ MessagePack is an efficient binary serialisation format that lets you
exchange data among multiple languages like JSON.
Versions later than 3.3.0 have separate C and C++ implementations.
-This slackbuild builds only the C implementation of MessagePack.
-If you need also the C++ implementation you have to build and install
-the package msgpack-c-cpp even. Both packages can coexist.
+This slackbuild builds only the C++ implementation of MessagePack as
+header-only library.
+If you need also the C implementation you have to build and install
+the package msgpack-c-c even. Both packages can coexist.
-Note: msgpack-c-c conflicts with the old msgpack-c package, that
-implements both C and C++ but is based on old outdated release of
+Note: msgpack-c-cpp conflicts with the old msgpack-c package, that
+implements both C and C++ but is based on a old outdated release of
msgpack-c. If you have msgpack-c version 3.3.0 in your system, please
remove it before installing these package.
This slackbuild is experimental because some slackbuilds that require
msgpack-c should be updated. If your installed packages work still with
the old msgpack-c for version 3.3.0, you should kept it.
+
+At the moment, this package is tested and strictly required by mmtf-cpp,
+other slackbuilds based on msgpack-c could not work with this
+installation.
diff --git a/libraries/msgpack-c-c/msgpack-c-c.SlackBuild b/libraries/msgpack-c-c/msgpack-c-c.SlackBuild
index 17468be352..6fdb6c3bc7 100644
--- a/libraries/msgpack-c-c/msgpack-c-c.SlackBuild
+++ b/libraries/msgpack-c-c/msgpack-c-c.SlackBuild
@@ -31,10 +31,11 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=msgpack-c-c
-VERSION=${VERSION:-6.0.0}
+VERSION=${VERSION:-6.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+SRCNAM=msgpack-c
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -92,9 +93,9 @@ fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -107,7 +108,7 @@ sed -i ./CMakeLists.txt -e "s/VERSION 2.8.12/VERSION 3.5/g"
mkdir -p build
cd build
cmake \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
diff --git a/libraries/msgpack-c-c/msgpack-c-c.info b/libraries/msgpack-c-c/msgpack-c-c.info
index 2ff5a763dc..74301ee2b3 100644
--- a/libraries/msgpack-c-c/msgpack-c-c.info
+++ b/libraries/msgpack-c-c/msgpack-c-c.info
@@ -1,8 +1,8 @@
PRGNAM="msgpack-c-c"
-VERSION="6.0.0"
+VERSION="6.0.1"
HOMEPAGE="https://github.com/msgpack/msgpack-c"
-DOWNLOAD="https://github.com/msgpack/msgpack-c/archive/c-6.0.0/msgpack-c-6.0.0.tar.gz"
-MD5SUM="25500d7a34944c4b3b7e7208f61fdac3"
+DOWNLOAD="https://github.com/msgpack/msgpack-c/releases/download/c-6.0.1/msgpack-c-6.0.1.tar.gz"
+MD5SUM="090df53a59b845767fcfc48221b30ee9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gtest"