summaryrefslogtreecommitdiffstats
path: root/academic/colamd/patches/autotoolize.diff
diff options
context:
space:
mode:
author Kyle Guinn <elyk03@gmail.com>2016-11-19 00:33:21 -0600
committer David Spencer <idlemoor@slackbuilds.org>2016-12-04 19:28:56 +0000
commit3116f65b5dc58d1a7384bf094e692cfd5830982d (patch)
treeb01ae1e2e8c2e629dd59f440c934b8093031cc57 /academic/colamd/patches/autotoolize.diff
parentfbccb9e8dcf1ab3c352a586688f1d1fe81cad272 (diff)
downloadslackbuilds-3116f65b5dc58d1a7384bf094e692cfd5830982d.tar.gz
slackbuilds-3116f65b5dc58d1a7384bf094e692cfd5830982d.tar.xz
academic/colamd: Updated for version 2.9.6.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to '')
-rw-r--r--academic/colamd/patches/autotoolize.diff (renamed from academic/colamd/autotoolize.diff)21
1 files changed, 10 insertions, 11 deletions
diff --git a/academic/colamd/autotoolize.diff b/academic/colamd/patches/autotoolize.diff
index 3a525cf6d6..275143b8c8 100644
--- a/academic/colamd/autotoolize.diff
+++ b/academic/colamd/patches/autotoolize.diff
@@ -43,11 +43,10 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
-@@ -0,0 +1,5 @@
+@@ -0,0 +1,4 @@
+SUBDIRS = Include Source Demo
-+EXTRA_DIST = README.txt Doc/ChangeLog Doc/lesser.txt
++EXTRA_DIST = README.txt Doc/ChangeLog Doc/License.txt Doc/lesser.txt
+
-+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = colamd.pc
diff --git a/Source/Makefile.am b/Source/Makefile.am
new file mode 100644
@@ -99,25 +98,23 @@ new file mode 100644
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
-+AC_INIT([COLAMD],[2.9.1],[DrTimothyAldenDavis@gmail.com],[colamd],[http://www.suitesparse.com/])
++AC_INIT([COLAMD],[2.9.6],[DrTimothyAldenDavis@gmail.com],[colamd],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([Source/colamd.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
+LT_INIT
+
+# Checks for programs.
++PKG_PROG_PKG_CONFIG
+AC_PROG_INSTALL
+AC_PROG_CC
+
-+LIBS_SAVED=$LIBS
++AS_VAR_SET([LIBS_SAVED], [$LIBS])
+
+# Checks for libraries.
+AC_CHECK_LIB([m], [sqrt])
+
-+PKG_PROG_PKG_CONFIG
-+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
-+ [],
-+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++PKG_CHECK_MODULES([SUITESPARSECONFIG], [suitesparseconfig])
+
+# Checks for header files.
+AC_CHECK_HEADERS([limits.h stdlib.h])
@@ -128,12 +125,14 @@ new file mode 100644
+# Checks for library functions.
+AC_CHECK_FUNCS([sqrt])
+
-+LIBS=$LIBS_SAVED
++AS_VAR_SET([LIBS], [$LIBS_SAVED])
+
++PKG_INSTALLDIR
+AC_CONFIG_FILES([
+ colamd.pc
+ Makefile
+ Demo/Makefile
+ Include/Makefile
-+ Source/Makefile])
++ Source/Makefile
++])
+AC_OUTPUT