summaryrefslogtreecommitdiffstats
path: root/academic/treeview/treeview.SlackBuild
diff options
context:
space:
mode:
author Petar Petrov <ppetrov@paju.oulu.fi>2011-12-23 01:24:06 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-23 14:05:43 -0200
commit054cb56659bd7a21df5d702ab745a005eb20ddbb (patch)
treeff1b493e68672141a8baa6b4331f1e1c8cef6c74 /academic/treeview/treeview.SlackBuild
parent68e74dd70bddc5a85bd112e91b10ec1a9a822f94 (diff)
downloadslackbuilds-054cb56659bd7a21df5d702ab745a005eb20ddbb.tar.gz
slackbuilds-054cb56659bd7a21df5d702ab745a005eb20ddbb.tar.xz
academic/treeview: Upgraded to version 0.5.
Yes, the previous version was 0.5.1, and YES, somehow 0.5 is newer. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic/treeview/treeview.SlackBuild')
-rw-r--r--academic/treeview/treeview.SlackBuild46
1 files changed, 23 insertions, 23 deletions
diff --git a/academic/treeview/treeview.SlackBuild b/academic/treeview/treeview.SlackBuild
index 2823c52761..3cef689478 100644
--- a/academic/treeview/treeview.SlackBuild
+++ b/academic/treeview/treeview.SlackBuild
@@ -1,20 +1,29 @@
#!/bin/sh
# Slackware build script for treeview
-# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
-# hereby submitted to the public domain
-# Based on the treeview PKGBUILD from Archlinux AUR
-# (http://aur.archlinux.org/packages.php?ID=19489).
-# PKGBUILD submitter is abhidg and PKGBUILD maintainer
-# is Stunts. Thank you!
-
-# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
-# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
-# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
+# Copyright 2011 Petar Petrov, ppetrov@paju.oulu.fi
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=treeview
-VERSION=${VERSION:-0.5.1}
+VERSION=${VERSION:-0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,13 +71,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# The patch is from Archlinux AUR, as mentioned above.
-# For AUR it has been taken from Debian. Thank you both!
-patch -p1 < $CWD/treeviewx_0.5.1-7.diff
-for i in ./debian/patches/*.diff; do
-patch -p1 < $i
-done
-
# Disable SVG support. If you want it, you should build
# wxGTK or wxPython including svg from contrib/src/svg
# Then, of course comment the next line.
@@ -91,13 +93,11 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/share/{applications,pixmaps}
-cp $CWD/tv.desktop $PKG/usr/share/applications
-cp $CWD/tv.png $PKG/usr/share/pixmaps
+cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
+cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING INSTALL \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild