summaryrefslogtreecommitdiffstats
path: root/academic/xfoil/Makefile_patches
diff options
context:
space:
mode:
author Daniel Prosser <dpross1100@msn.com>2016-12-29 13:03:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-12-31 08:22:15 +0700
commit2d8dca281f67481bac79e58d2a8b394f8559fafd (patch)
tree38c424e4479232012174b0f985def9c52a88ca5a /academic/xfoil/Makefile_patches
parent30be0fc06647205979987ab5e1f0dc310d40a359 (diff)
downloadslackbuilds-2d8dca281f67481bac79e58d2a8b394f8559fafd.tar.gz
slackbuilds-2d8dca281f67481bac79e58d2a8b394f8559fafd.tar.xz
academic/xfoil: Added (program for design and analysis of airfoils).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/xfoil/Makefile_patches')
-rw-r--r--academic/xfoil/Makefile_patches/Makefile.orrs.patch30
-rw-r--r--academic/xfoil/Makefile_patches/Makefile.xfoil.patch149
-rw-r--r--academic/xfoil/Makefile_patches/config.make.plotlib.patch25
3 files changed, 204 insertions, 0 deletions
diff --git a/academic/xfoil/Makefile_patches/Makefile.orrs.patch b/academic/xfoil/Makefile_patches/Makefile.orrs.patch
new file mode 100644
index 0000000000..32be02f168
--- /dev/null
+++ b/academic/xfoil/Makefile_patches/Makefile.orrs.patch
@@ -0,0 +1,30 @@
+--- orrs/bin/Makefile 2011-04-03 12:27:46.000000000 -0400
++++ orrs/bin/Makefile.orrs 2016-09-12 20:36:36.000000000 -0400
+@@ -1,25 +1,12 @@
+
+ SRC = ../src
+-PLTOBJ = /home/codes/Xplot/libPlt.a
+
+ #========================================
+ # Default compiler flags
+-FC = f77
+-FLG = -O
++FC = gfortran
++FLG = -O2 -fdefault-real-8
+ PLTLIB = -lX11
+ FTNLIB =
+-
+-#========================================
+-# Uncomment for Intel Fortran Compiler
+-FC = ifort
+-FLG = -O -fpe0 -CB
+-PLTLIB = -L/usr/X11R6/lib -lX11
+-FTNLIB =
+-
+-# Additional IFC stuff needed on MIT's Athena system
+-#FC = ifc
+-#FTNLIB = -Vaxlib /usr/lib/C-ctype.o /usr/lib/C_name.o /usr/lib/ctype-info.o
+-
+ #========================================
+
+
diff --git a/academic/xfoil/Makefile_patches/Makefile.xfoil.patch b/academic/xfoil/Makefile_patches/Makefile.xfoil.patch
new file mode 100644
index 0000000000..e8e0b413e3
--- /dev/null
+++ b/academic/xfoil/Makefile_patches/Makefile.xfoil.patch
@@ -0,0 +1,149 @@
+--- bin/Makefile 2013-11-19 00:23:37.000000000 -0500
++++ bin/Makefile.xfoil 2016-09-12 22:42:05.000000000 -0400
+@@ -4,10 +4,7 @@
+ # M.Drela
+ #*********************************************************
+
+-
+-SHELL = sh
+-BINDIR = /home/codes/bin/
+-#BINDIR = .
++BINDIR = $(DESTDIR)/usr/bin
+
+ PROGS = xfoil pplot pxplot
+
+@@ -33,104 +30,39 @@
+ OSOBJ = frplot.o ntcalc.o osmap.o getosfile.o
+
+ ##----------------------------------------------------
+-PLTOBJ = ../plotlib/libPlt.a
++PLTOBJ = ../plotlib/libPlt_gDP.a
+
+ # Use this if you have a copy of the plotlib as a system library
+ #PLTOBJ = -lPlt
+
+ # The extra location arg here is for Linux which places X libs in /usr/X11R6
+-PLTLIB = -L/usr/X11R6/lib -lX11
++PLTLIB = -lX11
+
+ ###================================================
+ ### Default compilers and flags
+ ### FFLOPT used for xsolve.f
+-FC = f77
+-FFLAGS = -O
+-FFLOPT = -O
+-INSTALLCMD = install -s
+-
+-CC = cc
+-CFLAGS = -O -DUNDERSCORE
+-
+-##--------------------------
+
+-# Uncomment flags for desired machine...
++CC = gcc
++CFLAGS = -O2 -DUNDERSCORE
+
+ ##--------------------------
+-### DEC Alpha with OSF and DEC f77/f90 compiler
+-#FC = f77
+-#FFLAGS = -fast -O4 -tune host
+-#FFLOPT = -fast -O4 -tune host
+-#FFLOPT = -fast -O5 -tune host -unroll 3
+-# Debug flags
+-#FFLAGS = -O0 -g
+-#FFLOPT = -fast -O4 -tune host
+-##--------------------------
+-### SGI setup
+-#FC = f77
+-#FFLAGS = -O2 -static
+-#FFLOPT = -O2 -static
+-##--------------------------
+-## Uncomment for RS/6000
+-#FFLAGS = -O -qextname
+-#FFLOPT = -O -qextname
+-##--------------------------
+-## Uncomment for HP-9000
+-#FFLAGS = -O +ppu
+-#FFLOPT = -O +ppu
+-#FTNLIB = -U77
+-##--------------------------
+-### Absoft Linux f77
+-#FC = f77
+-#FFLAGS = -O -f -s -W -B108 -N34
+-#FFLOPT = -O -f -s -W -B108 -N34
+-##--------------------------
+-### f2c/gcc compiler driver
+-#FC = fort77
+-#FFLAGS = -O2 -fomit-frame-pointer
+-#FFLOPT = -O2 -fomit-frame-pointer
+-##--------------------------
+-### GNU g77
+-#FC = g77
+-#FFLAGS = -O3 -fomit-frame-pointer
+-#FFLOPT = -O3 -fomit-frame-pointer
+-# Debug flags (symbols, array bounds)
+-#FC = g77
+-#FFLAGS = -g -O0 -C
+-##--------------------------
+-### GNU gfortran
+-#FC = gfortran
+-#FFLAGS = -O3 -fomit-frame-pointer
+-#FFLOPT = -O3 -fomit-frame-pointer
+-# Debug flags (symbols, array bounds)
+-#FFLAGS = -g -O0 -fbounds-check
+-#FFLOPT = -g -O0 -fbounds-check
+-#
+-### Double precision option
+-#FFLAGS = -O3 -fdefault-real-8
+-#FFLOPT = -O3 -fdefault-real-8
+-#FFLAGS = -O3 -fdefault-real-8 -fbounds-check
+-#FFLOPT = -O3 -fdefault-real-8 -fbounds-check
+-# Debug flags (symbols, array bounds)
+-#FFLAGS = -g -O0 -C
+-##--------------------------
+ ### Gfortran
+ FC = gfortran
+ CHK =
+-CHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero
++#CHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
+ DBL = -fdefault-real-8
+-FFLAGS = -O $(CHK) $(DBL)
+-FFLOPT = -O $(CHK) $(DBL)
++FFLAGS = -O2 $(CHK) $(DBL)
++FFLOPT = -O2 $(CHK) $(DBL)
+ FTNLIB =
+
+ PLTOBJ = ../plotlib/libPlt_gDP.a
+
+
+-
+ all: $(PROGS)
+
+ install:
+- $(INSTALLCMD) $(PROGS) $(BINDIR)
++ install -d -m 0755 $(BINDIR)
++ install -m 0755 $(PROGS) $(BINDIR)
+
+ clean:
+ -/bin/rm $(PROGS)
+@@ -141,20 +73,15 @@
+
+ xfoil: $(XFOILOBJ) $(XUTILOBJ) $(OSOBJ)
+ $(FC) -o xfoil $(XFOILOBJ) $(XUTILOBJ) $(OSOBJ) $(PLTOBJ) $(PLTLIB) $(FTNLIB)
+- $(INSTALLCMD) xfoil $(BINDIR)
+
+ pxplot: $(PXPLOTOBJ) $(XUTILOBJ)
+ $(FC) -o pxplot $(PXPLOTOBJ) $(XUTILOBJ) $(PLTOBJ) $(PLTLIB) $(FTNLIB)
+- $(INSTALLCMD) pxplot $(BINDIR)
+
+ pplot: $(PPLOTOBJ) $(XUTILOBJ)
+ $(FC) -o pplot $(PPLOTOBJ) $(XUTILOBJ) $(PLTOBJ) $(PLTLIB) $(FTNLIB)
+- $(INSTALLCMD) pplot $(BINDIR)
+
+ blu: blu.o profil.o
+ $(FC) -o blu blu.o profil.o
+- $(INSTALLCMD) blu $(BINDIR)
+-
+
+ blu.o: $(SRC)/blu.f
+ $(FC) -c $(FFLAGS) $(SRC)/blu.f
diff --git a/academic/xfoil/Makefile_patches/config.make.plotlib.patch b/academic/xfoil/Makefile_patches/config.make.plotlib.patch
new file mode 100644
index 0000000000..991c2f0b3e
--- /dev/null
+++ b/academic/xfoil/Makefile_patches/config.make.plotlib.patch
@@ -0,0 +1,25 @@
+--- plotlib/config.make 2013-10-06 19:32:13.000000000 -0400
++++ plotlib/config.make.plotlib 2016-09-11 21:45:12.000000000 -0400
+@@ -7,7 +7,7 @@
+
+
+ # Set library name
+-PLTLIB = libPlt_gSP.a
++PLTLIB = libPlt_gDP.a
+
+ # Some fortrans need trailing underscores in C interface symbols (see Xwin.c)
+ # This should work for most of the "unix" fortran compilers
+@@ -15,10 +15,10 @@
+
+ FC = gfortran
+ CC = gcc
+-#DP = -fdefault-real-8
++DP = -fdefault-real-8
+
+-FFLAGS = -m64 -O2 $(DP)
+-CFLAGS = -m64 -O2 $(DEFINE) -I/usr/X11/include
++FFLAGS = -O2 $(DP)
++CFLAGS = -O2 $(DEFINE) -I/usr/X11/include
+ AR = ar r
+ RANLIB = ranlib
+ LINKLIB = -L/usr/X11R6/lib -lX11