summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-31 23:38:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-04-01 06:50:34 +0700
commit4c5d3d4be2c8be4ddec068092e8873487ff1544b (patch)
tree836b10ca8e691cc14dfd20f73ee03e509ef5d5e2 /academic
parent12e9a2aa7a1a3ee062858d318318f633f2e3ad69 (diff)
downloadslackbuilds-4c5d3d4be2c8be4ddec068092e8873487ff1544b.tar.gz
slackbuilds-4c5d3d4be2c8be4ddec068092e8873487ff1544b.tar.xz
academic/pyfits: Removed (deprecated).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/pyfits/README3
-rw-r--r--academic/pyfits/pyfits.SlackBuild66
-rw-r--r--academic/pyfits/pyfits.info10
-rw-r--r--academic/pyfits/slack-desc19
4 files changed, 0 insertions, 98 deletions
diff --git a/academic/pyfits/README b/academic/pyfits/README
deleted file mode 100644
index 89eac1e478..0000000000
--- a/academic/pyfits/README
+++ /dev/null
@@ -1,3 +0,0 @@
-PyFITS provides an interface to FITS formatted files in the Python
-scripting language. PyFITS is a development project of the Science
-Software Branch at the Space Telescope Science Institute.
diff --git a/academic/pyfits/pyfits.SlackBuild b/academic/pyfits/pyfits.SlackBuild
deleted file mode 100644
index 3aea317957..0000000000
--- a/academic/pyfits/pyfits.SlackBuild
+++ /dev/null
@@ -1,66 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for PyFITS.
-
-# Written by Nicky Chorley <nick.chorley@gmail.com>, but heavily
-# based on the NumPy SlackBuild by Aleksandar Samardzic.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=pyfits
-VERSION=${VERSION:-3.1.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root $PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES.txt LICENSE.txt README.txt\
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/pyfits/pyfits.info b/academic/pyfits/pyfits.info
deleted file mode 100644
index c506b200ac..0000000000
--- a/academic/pyfits/pyfits.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pyfits"
-VERSION="3.1.2"
-HOMEPAGE="https://github.com/spacetelescope/PyFITS"
-DOWNLOAD="https://pypi.python.org/packages/source/p/pyfits/pyfits-3.1.2.tar.gz"
-MD5SUM="d0f1dce1719170b0c9777bbb15bbd8b3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-stsci.distutils python2-numpy"
-MAINTAINER="Nicky Chorley"
-EMAIL="nick.chorley@gmail.com"
diff --git a/academic/pyfits/slack-desc b/academic/pyfits/slack-desc
deleted file mode 100644
index 5ff2aaec0b..0000000000
--- a/academic/pyfits/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pyfits: pyfits (a Python extension for working with FITS files)
-pyfits:
-pyfits: PyFITS provides an interface to FITS formatted files in the Python
-pyfits: scripting language. PyFITS was a development project of the Science
-pyfits: Software Branch at the Space Telescope Science Institute.
-pyfits:
-pyfits: Homepage: https://github.com/spacetelescope/PyFITS
-pyfits:
-pyfits:
-pyfits:
-pyfits: