summaryrefslogtreecommitdiffstats
path: root/desktop/arandr
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-02 14:33:43 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-02 14:33:43 -0400
commitc75cf4867822a31e411a8cfd5aee260c76dd94af (patch)
treeb312cc6574d5009a94bfefcdbcd688ee0887dfc0 /desktop/arandr
parentff6442f84b329242af0a40434600f7b488eb3daa (diff)
downloadslackbuilds-c75cf4867822a31e411a8cfd5aee260c76dd94af.tar.gz
slackbuilds-c75cf4867822a31e411a8cfd5aee260c76dd94af.tar.xz
desktop/arandr: Add doinst.sh to support .desktop file.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'desktop/arandr')
-rw-r--r--desktop/arandr/arandr.SlackBuild13
-rw-r--r--desktop/arandr/doinst.sh3
2 files changed, 10 insertions, 6 deletions
diff --git a/desktop/arandr/arandr.SlackBuild b/desktop/arandr/arandr.SlackBuild
index d967f91551..1bc8e87e5d 100644
--- a/desktop/arandr/arandr.SlackBuild
+++ b/desktop/arandr/arandr.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220402 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - add doinst.sh, required because we have a .desktop file.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=arandr
VERSION=${VERSION:-0.1.10}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +75,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
@@ -95,6 +95,7 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/arandr/doinst.sh b/desktop/arandr/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/arandr/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi