summaryrefslogtreecommitdiffstats
path: root/desktop/icewm/patches
diff options
context:
space:
mode:
author Robby Workman <rworkman@slackbuilds.org>2016-01-03 17:14:14 -0600
committer Robby Workman <rworkman@slackbuilds.org>2016-01-10 21:36:31 -0600
commite3cee0ccd7e3341c9e5464d740fe2afeff39d8f4 (patch)
tree11a6fc3aa3e2c0f7a129218f9e85ee16d4f42145 /desktop/icewm/patches
parentde47a0f89562601b6b7fc4b6c110c58af606ebb8 (diff)
downloadslackbuilds-e3cee0ccd7e3341c9e5464d740fe2afeff39d8f4.tar.gz
slackbuilds-e3cee0ccd7e3341c9e5464d740fe2afeff39d8f4.tar.xz
desktop/icewm: Updated for version 1.3.12 (new upstream)
Thanks to _gin on LQ for the heads-up on this. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'desktop/icewm/patches')
-rw-r--r--desktop/icewm/patches/aapm_power.patch31
-rw-r--r--desktop/icewm/patches/acpustatus_read_cpuinfo_cur_freq.patch11
-rw-r--r--desktop/icewm/patches/explicitly-link-fontconfig.diff12
-rw-r--r--desktop/icewm/patches/icewm-1.3.7-menuiconsize.patch73
-rw-r--r--desktop/icewm/patches/icewm-1.3.7-thermal.patch41
-rw-r--r--desktop/icewm/patches/icewm-1.3.x-fix_html_docdir.diff24
-rw-r--r--desktop/icewm/patches/icewm-1.3.x-fix_htmldir.diff12
-rw-r--r--desktop/icewm/patches/icewm-keys.patch51
-rw-r--r--desktop/icewm/patches/no_proc_acpi.patch17
-rw-r--r--desktop/icewm/patches/use_ICEWM_deprecated.patch21
-rw-r--r--desktop/icewm/patches/wmclient.patch25
11 files changed, 23 insertions, 295 deletions
diff --git a/desktop/icewm/patches/aapm_power.patch b/desktop/icewm/patches/aapm_power.patch
deleted file mode 100644
index 292cdf4b8f..0000000000
--- a/desktop/icewm/patches/aapm_power.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- b/icewm-1.3.7/src/aapm.cc 2010-10-31 17:09:36.000000000 +0300
-+++ icewm-1.3.7/src/aapm.cc 2013-06-02 14:24:04.778299294 +0400
-@@ -614,6 +614,10 @@
- }
- strcat3(buf, "/sys/class/power_supply/", BATname, "/current_now", sizeof(buf));
- fd = fopen(buf, "r");
-+ if (fd == NULL) {
-+ strcat3(buf, "/sys/class/power_supply/", BATname, "/power_now", sizeof(buf));
-+ fd = fopen(buf, "r");
-+ }
- if (fd != NULL && fgets(buf, sizeof(buf), fd)) {
- //In case it contains non-numeric value
- if (sscanf(buf,"%d", &BATrate) <= 0) {
-@@ -706,7 +710,7 @@
- //did we parse the needed values successfully?
- BATcapacity_full >= 0 && BATcapacity_remain >= 0 && BATrate > 0) {
- BATtime_remain = (int) (60 * (double)(BATcapacity_remain) / BATrate);
-- sprintf(bat_info, "%d:%02d", BATtime_remain / 60, BATtime_remain % 60);
-+ sprintf(bat_info, "%d:%02d %.1fW", BATtime_remain / 60, BATtime_remain % 60, (double) BATrate / 1000000);
- }
- else if (BATpresent == BAT_PRESENT &&
- //did we parse the needed values successfully?
-@@ -1075,7 +1079,7 @@
- if ((mode == ACPI || mode == SYSFS) && acpiBatteries[i]->present == BAT_ABSENT)
- continue;
- if (taskBarShowApmTime)
-- strcat(buf, "0:00");
-+ strcat(buf, "0:00 0.0W");
- else
- strcat(buf, "100%");
- strcat(buf, "C");
diff --git a/desktop/icewm/patches/acpustatus_read_cpuinfo_cur_freq.patch b/desktop/icewm/patches/acpustatus_read_cpuinfo_cur_freq.patch
deleted file mode 100644
index 580a64d58f..0000000000
--- a/desktop/icewm/patches/acpustatus_read_cpuinfo_cur_freq.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/acpustatus.cc.orig 2010-10-31 17:09:36.000000000 +0300
-+++ src/acpustatus.cc 2013-08-26 00:38:16.868170497 +0400
-@@ -323,7 +323,7 @@
- int fd;
- float cpufreq = 0;
-
-- sprintf(namebuf, "/sys/devices/system/cpu/cpu%d/cpufreq/scaling_cur_freq", cpu);
-+ sprintf(namebuf, "/sys/devices/system/cpu/cpu%d/cpufreq/cpuinfo_cur_freq", cpu);
- fd = open(namebuf, O_RDONLY);
- if (fd != -1) {
- int len = read(fd, buf, sizeof(buf) - 1);
diff --git a/desktop/icewm/patches/explicitly-link-fontconfig.diff b/desktop/icewm/patches/explicitly-link-fontconfig.diff
deleted file mode 100644
index 36dab59d32..0000000000
--- a/desktop/icewm/patches/explicitly-link-fontconfig.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur icewm-1.3.7.orig/src/Makefile.in icewm-1.3.7/src/Makefile.in
---- icewm-1.3.7.orig/src/Makefile.in 2010-10-31 09:09:36.000000000 -0500
-+++ icewm-1.3.7/src/Makefile.in 2012-05-11 10:29:55.356344991 -0500
-@@ -37,7 +37,7 @@
- CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
- @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
- LFLAGS = @LDFLAGS@
--LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs`
-+LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 fontconfig --libs`
-
- CORE_LIBS = @CORE_LIBS@ # `fc-config --libs`
- IMAGE_LIBS = @IMAGE_LIBS@
diff --git a/desktop/icewm/patches/icewm-1.3.7-menuiconsize.patch b/desktop/icewm/patches/icewm-1.3.7-menuiconsize.patch
deleted file mode 100644
index d051d5bc5f..0000000000
--- a/desktop/icewm/patches/icewm-1.3.7-menuiconsize.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -Naur icewm-1.3.7.bak/src/yicon.cc icewm-1.3.7/src/yicon.cc
---- icewm-1.3.7.bak/src/yicon.cc 2010-10-31 15:09:36.000000000 +0100
-+++ icewm-1.3.7/src/yicon.cc 2011-11-07 19:41:52.841910531 +0100
-@@ -270,6 +270,10 @@
- iconCache.getItem(0)->removeFromCache();
- }
-
-+int YIcon::menuSize() {
-+ return menuIconSize;
-+}
-+
- int YIcon::smallSize() {
- return smallIconSize;
- }
-diff -Naur icewm-1.3.7.bak/src/yicon.h icewm-1.3.7/src/yicon.h
---- icewm-1.3.7.bak/src/yicon.h 2010-10-31 15:09:36.000000000 +0100
-+++ icewm-1.3.7/src/yicon.h 2011-11-07 19:41:28.555296033 +0100
-@@ -25,6 +25,7 @@
- bool isCached() { return fCached; }
- void setCached(bool cached) { fCached = cached; }
-
-+ static int menuSize();
- static int smallSize();
- static int largeSize();
- static int hugeSize();
-diff -Naur icewm-1.3.7.bak/src/ymenu.cc icewm-1.3.7/src/ymenu.cc
---- icewm-1.3.7.bak/src/ymenu.cc 2010-10-31 15:09:36.000000000 +0100
-+++ icewm-1.3.7/src/ymenu.cc 2011-11-07 19:42:40.498474049 +0100
-@@ -153,8 +153,8 @@
-
- #ifndef LITE
- if (getItem(selItem)->getIcon() != null &&
-- YIcon::smallSize() > h)
-- h = YIcon::smallSize();
-+ YIcon::menuSize() > h)
-+ h = YIcon::menuSize();
- #endif
-
- if (x <= int(width() - h - 4))
-@@ -1023,8 +1023,8 @@
- mitem->getIcon()->draw(g,
- l + 1 + delta, t + delta + top + pad +
- (eh - top - pad * 2 - bottom -
-- YIcon::smallSize()) / 2,
-- YIcon::smallSize());
-+ YIcon::menuSize()) / 2,
-+ YIcon::menuSize());
- #endif
- }
-
-diff -Naur icewm-1.3.7.bak/src/ymenuitem.cc icewm-1.3.7/src/ymenuitem.cc
---- icewm-1.3.7.bak/src/ymenuitem.cc 2010-10-31 15:09:36.000000000 +0100
-+++ icewm-1.3.7/src/ymenuitem.cc 2011-11-07 19:50:04.458316916 +0100
-@@ -86,8 +86,8 @@
- int ih = fontHeight;
-
- #ifndef LITE
-- if (YIcon::smallSize() > ih)
-- ih = YIcon::smallSize();
-+ if (YIcon::menuSize() > ih)
-+ ih = YIcon::menuSize();
- #endif
-
- if (wmLook == lookWarp4 || wmLook == lookWin95) {
-@@ -123,7 +123,7 @@
- return 0;
- #else
- ref<YIcon> icon = getIcon();
-- return icon != null ? YIcon::smallSize(): 0;
-+ return icon != null ? YIcon::menuSize(): 0;
- #endif
- }
-
diff --git a/desktop/icewm/patches/icewm-1.3.7-thermal.patch b/desktop/icewm/patches/icewm-1.3.7-thermal.patch
deleted file mode 100644
index f6b2cf71f0..0000000000
--- a/desktop/icewm/patches/icewm-1.3.7-thermal.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -uprN a/src/acpustatus.cc b/src/acpustatus.cc
---- a/src/acpustatus.cc 2010-10-31 15:09:36.000000000 +0100
-+++ b/src/acpustatus.cc 2013-01-17 21:12:19.085715083 +0100
-@@ -315,6 +315,37 @@ int CPUStatus::getAcpiTemp(char *tempbuf
- }
- closedir(dir);
- }
-+ else if ((dir = opendir("/sys/class/thermal")) != NULL) {
-+ struct dirent *de;
-+
-+ while ((de = readdir(dir)) != NULL) {
-+
-+ int fd, seglen;
-+
-+ if (strcmp(de->d_name, ".") == 0 || strcmp(de->d_name, "..") == 0)
-+ continue;
-+
-+ sprintf(namebuf, "/sys/class/thermal/%s/temp", de->d_name);
-+ fd = open(namebuf, O_RDONLY);
-+ if (fd != -1) {
-+ int len = read(fd, buf, sizeof(buf) - 1);
-+ buf[len - 4] = '\0';
-+ seglen = strlen(buf) + 4;
-+ if (retbuflen + seglen >= buflen) {
-+ retbuflen = -retbuflen;
-+ close(fd);
-+ closedir(dir);
-+ break;
-+ }
-+ retbuflen += seglen;
-+ strcat(tempbuf, " ");
-+ strncat(tempbuf, buf, seglen);
-+ strcat(tempbuf, " C");
-+ close(fd);
-+ }
-+ }
-+ closedir(dir);
-+ }
- return retbuflen;
- }
-
diff --git a/desktop/icewm/patches/icewm-1.3.x-fix_html_docdir.diff b/desktop/icewm/patches/icewm-1.3.x-fix_html_docdir.diff
deleted file mode 100644
index b3818625fe..0000000000
--- a/desktop/icewm/patches/icewm-1.3.x-fix_html_docdir.diff
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Nur icewm-1.3.7.orig/src/Makefile icewm-1.3.7/src/Makefile
---- icewm-1.3.7.orig/src/Makefile 2010-10-31 09:09:49.000000000 -0500
-+++ icewm-1.3.7/src/Makefile 2011-09-04 21:59:06.658236001 -0500
-@@ -32,7 +32,7 @@
- -DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
- -DICESMEXE='"icewm-session$(EXEEXT)"' \
- -DICEHELPEXE='"icehelp$(EXEEXT)"' \
-- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
-+ -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/html/icewm.html"'
-
- CXXFLAGS = -fpermissive -Wall -Wpointer-arith -Wwrite-strings -Woverloaded-virtual -W -fno-exceptions -fno-rtti -g -O2 $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
- -I/usr/include/freetype2 -pthread -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include # `fc-config --cflags`
-diff -Nur icewm-1.3.7.orig/src/Makefile.in icewm-1.3.7/src/Makefile.in
---- icewm-1.3.7.orig/src/Makefile.in 2010-10-31 09:09:36.000000000 -0500
-+++ icewm-1.3.7/src/Makefile.in 2011-09-04 21:59:06.659235991 -0500
-@@ -32,7 +32,7 @@
- -DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
- -DICESMEXE='"icewm-session$(EXEEXT)"' \
- -DICEHELPEXE='"icehelp$(EXEEXT)"' \
-- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
-+ -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/html/icewm.html"'
-
- CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
- @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
diff --git a/desktop/icewm/patches/icewm-1.3.x-fix_htmldir.diff b/desktop/icewm/patches/icewm-1.3.x-fix_htmldir.diff
new file mode 100644
index 0000000000..ee0cb69be9
--- /dev/null
+++ b/desktop/icewm/patches/icewm-1.3.x-fix_htmldir.diff
@@ -0,0 +1,12 @@
+diff -Nur icewm-1.3.12.orig/configure icewm-1.3.12/configure
+--- icewm-1.3.12.orig/configure 2015-12-16 19:10:37.000000000 -0600
++++ icewm-1.3.12/configure 2016-01-03 16:51:39.034717138 -0600
+@@ -24013,7 +24013,7 @@
+
+
+ cat >>confdefs.h <<_ACEOF
+-#define ICEHELPIDX "${DOCDIR}/icewm.html"
++#define ICEHELPIDX "${DOCDIR}/html/icewm.html"
+ _ACEOF
+
+
diff --git a/desktop/icewm/patches/icewm-keys.patch b/desktop/icewm/patches/icewm-keys.patch
index 7e136bb932..c9ad1584f7 100644
--- a/desktop/icewm/patches/icewm-keys.patch
+++ b/desktop/icewm/patches/icewm-keys.patch
@@ -1,43 +1,14 @@
---- icewm-1.2.30/lib/keys.in.old 2007-01-18 13:55:20.000000000 +0200
-+++ icewm-1.2.30/lib/keys.in 2007-01-18 16:07:07.000000000 +0200
-@@ -9,28 +9,21 @@
- # You'll have to omit XK_ prefixs and to replace XF86XK_ prefixes by
- # XF86. Valid modifiers are Alt, Ctrl, Shift, Meta, Super and Hyper.
- #
--key "Alt+Ctrl+t" xterm
--key "Alt+Ctrl+f" fte
--key "Alt+Ctrl+e" nedit
--key "Alt+Ctrl+g" gimp
--key "Alt+Ctrl+n" netscape -noraise -remote openBrowser
--key "Alt+Ctrl+b" netscape -noraise -remote openBookmarks
--key "Alt+Ctrl+m" netscape -noraise -remote openURL(mailto:,new-window)
-+key "Alt+Ctrl+t" xterm
-+key "Alt+Ctrl+b" xdg-open about:blank
-+key "Alt+Ctrl+s" xdg-open http://www.google.com
-
--key "Alt+Ctrl+KP_Divide" aumix -v -5 # lower volume
--key "Alt+Ctrl+KP_Multiply" aumix -v +5 # raise volume
-+key "Super+KP_Subtract" amixer sset PCM 5%-
-+key "Super+KP_Add" amixer sset PCM 5%+
-
- # "Multimedia key" bindings for XFree86. Gather the keycodes of your
+diff -Nur icewm-1.3.12.orig/lib/keys.in icewm-1.3.12/lib/keys.in
+--- icewm-1.3.12.orig/lib/keys.in 2015-09-13 16:29:28.000000000 -0500
++++ icewm-1.3.12/lib/keys.in 2016-01-03 16:28:55.332001195 -0600
+@@ -20,8 +20,8 @@
# advanced function keys by watching the output of the xev command whilest
# pressing those keys and map those symbols by using xmodmap.
--key "XF86Standby" killall -QUIT icewm
--key "XF86AudioLowerVolume" aumix -v -5
--key "XF86AudioRaiseVolume" aumix -v +5
--key "XF86AudioMute" aumix -v 0
--key "XF86AudioPlay" cdplay play 1
--key "XF86AudioStop" cdplay stop
--key "XF86HomePage" netscape -noraise -remote openHomepage
--key "XF86Mail" netscape -noraise -remote openURL(mailto:,new-window)
--key "XF86Search" netscape -noraise -remote openURL(http://www.google.com/)
--key "XF86Eject" eject
-+key "XF86Standby" killall -QUIT icewm
-+key "XF86AudioLowerVolume" amixer sset PCM 5%-
-+key "XF86AudioRaiseVolume" amixer sset PCM 5%+
-+key "XF86AudioMute" amixer sset PCM 0%
-+key "XF86HomePage" xdg-open about:blank
-+key "XF86Search" xdg-open http://www.google.com
-+key "XF86Eject" eject
+-key "XF86Standby" /bin/sh -c "{ test -e /run/systemd/system && systemctl suspend; } ||:"
+-key "XF86Sleep" /bin/sh -c "{ test -e /run/systemd/system && systemctl suspend; } ||:"
++key "XF86Standby" /bin/sh -c "{ pm-suspend; } ||:"
++key "XF86Sleep" /bin/sh -c "{ pm-suspend; } ||:"
+ key "XF86AudioLowerVolume" amixer sset PCM 5%-
+ key "XF86AudioRaiseVolume" amixer sset PCM 5%+
+ key "XF86AudioMute" amixer sset PCM 0%
diff --git a/desktop/icewm/patches/no_proc_acpi.patch b/desktop/icewm/patches/no_proc_acpi.patch
deleted file mode 100644
index 4cd92360ca..0000000000
--- a/desktop/icewm/patches/no_proc_acpi.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: Check for sysfs' acpi file, procfs may not contain acpi data with recent kernels
-Author: Andrey Danin <danindrey@mail.ru>, Eduard Bloch <blade@debian.org>
-Bug: http://sourceforge.net/mailarchive/forum.php?thread_name=E1SHwYx-00029t-1N.danindrey-mail-ru%40f232.mail.ru&forum_name=icewm-devel
-Forwarded: Yes
-
-Index: icewm-1.3.7/src/wmtaskbar.cc
-===================================================================
---- icewm-1.3.7.orig/src/wmtaskbar.cc 2010-10-31 15:09:36.000000000 +0100
-+++ icewm-1.3.7/src/wmtaskbar.cc 2012-04-11 23:22:23.466564372 +0200
-@@ -467,6 +467,7 @@
- #endif
- #ifdef CONFIG_APPLET_APM
- if (taskBarShowApm && (access(APMDEV, 0) == 0 ||
-+ access("/sys/class/power_supply", 0) == 0 ||
- access("/proc/acpi", 0) == 0 ||
- access("/dev/acpi", 0) == 0 ||
- access("/proc/pmu", R_OK|X_OK) == 0))
diff --git a/desktop/icewm/patches/use_ICEWM_deprecated.patch b/desktop/icewm/patches/use_ICEWM_deprecated.patch
deleted file mode 100644
index 3533d31e34..0000000000
--- a/desktop/icewm/patches/use_ICEWM_deprecated.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Description: Don't use "deprecated" as identifier, will FTBFS if another
- library defines functions as deprecated.
-Author: Andreas Moog <amoog@ubuntu.com>
-Bug: https://sourceforge.net/tracker/?func=detail&aid=3494034&group_id=31&atid=100031
-Bug-Ubuntu: https://bugs.launchpad.net/bugs/935179
-Forwarded: Yes
-
---- icewm-1.3.7.orig/src/base.h
-+++ icewm-1.3.7/src/base.h
-@@ -2,9 +2,9 @@
- #define __BASE_H
-
- #if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
--#define deprecated __attribute__((deprecated))
-+#define ICEWM_deprecated __attribute__((deprecated))
- #else
--#define deprecated
-+#define ICEWM_deprecated
- #endif
-
- /*** Atomar Data Types ********************************************************/
diff --git a/desktop/icewm/patches/wmclient.patch b/desktop/icewm/patches/wmclient.patch
deleted file mode 100644
index 95f00614de..0000000000
--- a/desktop/icewm/patches/wmclient.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -uNr icewm-1.3.7.orig/src/wmclient.cc icewm-1.3.7/src/wmclient.cc
---- icewm-1.3.7.orig/src/wmclient.cc 2012-05-27 11:54:25.663101746 +0200
-+++ icewm-1.3.7/src/wmclient.cc 2012-05-27 12:17:40.236339580 +0200
-@@ -1044,20 +1044,11 @@
- while (XGetWindowProperty(display, handle,
- propAtom, (itemCount * itemSize) / 32, 1024*32, False, AnyPropertyType,
- &r_type, &r_format, &nitems, &bytes_remain,
-- &prop) == Success && prop && bytes_remain == 0)
-+ &prop) == Success && prop)
- {
- if (r_format == itemSize1 && nitems > 0) {
- data = realloc(data, (itemCount + nitems) * itemSize / 8);
-
-- // access to memory beyound 256MiB causes crashes! But anyhow, size
-- // >>2MiB looks suspicious. Detect this case ASAP. However, if
-- // the usable icon is somewhere in the beginning, it's okay to
-- // return truncated data.
-- if (itemCount * itemSize / 8 >= 2097152) {
-- XFree(prop);
-- break;
-- }
--
- memcpy((char *)data + itemCount * itemSize / 8, prop, nitems * itemSize / 8);
- itemCount += nitems;
- XFree(prop);