summaryrefslogtreecommitdiffstats
path: root/development/dao/dao_x64.patch
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-04-03 19:57:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-07 14:43:52 +0700
commit68d4a9b6cf257bafa66b99bed3af81941d4a6a88 (patch)
treeaa1620fc6599402cb8b5e2fe0126ad8bc51a58a4 /development/dao/dao_x64.patch
parenteb6d03d83f68fbaf4d4800eb435a5b3fdff92bf5 (diff)
downloadslackbuilds-68d4a9b6cf257bafa66b99bed3af81941d4a6a88.tar.gz
slackbuilds-68d4a9b6cf257bafa66b99bed3af81941d4a6a88.tar.xz
development/dao: Added (The Dao Programming Language).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/dao/dao_x64.patch')
-rw-r--r--development/dao/dao_x64.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/development/dao/dao_x64.patch b/development/dao/dao_x64.patch
new file mode 100644
index 0000000000..12d0a41cc8
--- /dev/null
+++ b/development/dao/dao_x64.patch
@@ -0,0 +1,40 @@
+--- dao-2.0-devel-2014-01-19/CMakeLists.original.txt 2014-04-03 12:51:50.845397447 +0300
++++ dao-2.0-devel-2014-01-19/CMakeLists.txt 2014-04-03 12:59:56.966320100 +0300
+@@ -89,12 +89,12 @@
+ endif(DAO_HAS_FENV)
+
+ # Check whether the system has readline.h or not.
+-find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
+-if(DAO_HAS_READLINE)
+- include_directories("${DAO_HAS_READLINE}")
+- add_definitions(-DDAO_USE_READLINE)
+- list(APPEND DAO_SYSTEM_LIBS "readline")
+-endif(DAO_HAS_READLINE)
++# find_path(DAO_HAS_READLINE NAMES "readline/readline.h" "readline/history.h")
++# if(DAO_HAS_READLINE)
++# include_directories("${DAO_HAS_READLINE}")
++# add_definitions(-DDAO_USE_READLINE)
++# list(APPEND DAO_SYSTEM_LIBS "readline")
++# endif(DAO_HAS_READLINE)
+
+ # Setup for Minix:
+ if( "${CMAKE_SYSTEM_NAME}" STREQUAL "Minix" )
+@@ -194,13 +194,13 @@
+ set_target_properties(daoexe PROPERTIES OUTPUT_NAME ${DAO_EXE_NAME})
+
+ # Installation rules for the interpreter and dao libs
+-set(DAO_MODULES_INSTALL_DIR "lib/dao/modules")
++set(DAO_MODULES_INSTALL_DIR "lib64/dao/modules")
+ install(TARGETS daoexe daolib daolibs
+ RUNTIME DESTINATION "bin"
+- LIBRARY DESTINATION "lib"
+- ARCHIVE DESTINATION "lib"
+- PRIVATE_HEADER DESTINATION "include"
+- PUBLIC_HEADER DESTINATION "include"
++ LIBRARY DESTINATION "lib64"
++ ARCHIVE DESTINATION "lib64"
++ PRIVATE_HEADER DESTINATION "include/dao"
++ PUBLIC_HEADER DESTINATION "include/dao"
+ )
+ #autobind.dao is obsolete:
+ #install(FILES "${PROJECT_SOURCE_DIR}/tools/autobind.dao" DESTINATION "bin")