summaryrefslogtreecommitdiffstats
path: root/development/gnuradio/gnuradio.SlackBuild
diff options
context:
space:
mode:
author Panagiotis Nikolaou <hostmaster@slackonly.com>2017-02-06 09:11:03 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2017-02-10 07:06:06 +0700
commit8ef441a7fe2ba6ddb9f327df61d09e2f44ca96c9 (patch)
treed1f381e23fa234572c68e6264cc7a939268251fc /development/gnuradio/gnuradio.SlackBuild
parent58eb849f96ab5285c0b4d0473deeca3fa324629b (diff)
downloadslackbuilds-8ef441a7fe2ba6ddb9f327df61d09e2f44ca96c9.tar.gz
slackbuilds-8ef441a7fe2ba6ddb9f327df61d09e2f44ca96c9.tar.xz
development/gnuradio: Updated for version 3.7.10.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/gnuradio/gnuradio.SlackBuild')
-rw-r--r--development/gnuradio/gnuradio.SlackBuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/development/gnuradio/gnuradio.SlackBuild b/development/gnuradio/gnuradio.SlackBuild
index 18ac2569c8..94adb84e26 100644
--- a/development/gnuradio/gnuradio.SlackBuild
+++ b/development/gnuradio/gnuradio.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for gnuradio
# Copyright 2013 Georgi Kolev, Bulgaria
-# Copyright 2015 Panagiotis Nikolaou, Karlovasi Samos, Gr
+# Copyright 2015, 2016, 2017 Panagiotis Nikolaou, Culver City, CA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,13 +24,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=gnuradio
-VERSION=${VERSION:-3.7.8.1}
+VERSION=${VERSION:-3.7.10.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +41,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -73,9 +73,9 @@ find -L . \
# install docs in the right place
sed -i "s|\${GR_DATA_DIR}/doc|doc|" CMakeLists.txt
-# Fix build with cmake-3.5
-# https://github.com/gnuradio/volk/pull/65
-patch -d volk -p1 < $CWD/9aa0f07693053d44aaaad8e54dd5250909705c02.patch
+# Fix build with boost
+# https://github.com/gnuradio/volk/commit/e5fec2aaacc8a130bcff84f1f3bbd9718250f029
+patch -p1 < $CWD/cxx_abi.patch
mkdir -p build
cd build