summaryrefslogtreecommitdiffstats
path: root/development/sphinx_rtd_theme
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-18 10:42:46 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-02-18 10:42:46 +0700
commitda372b1693fced0abd61eca5e508fd855c1520ab (patch)
tree9ac194b5408fb6f0596bbd24d51d4cda277088aa /development/sphinx_rtd_theme
parentebb314add860d66a8080dbadb115fbcbc74731e6 (diff)
downloadslackbuilds-da372b1693fced0abd61eca5e508fd855c1520ab.tar.gz
slackbuilds-da372b1693fced0abd61eca5e508fd855c1520ab.tar.xz
development/sphinx_rtd_theme: Removed (use sphinx-rtd-theme).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/sphinx_rtd_theme')
-rw-r--r--development/sphinx_rtd_theme/README3
-rw-r--r--development/sphinx_rtd_theme/slack-desc19
-rw-r--r--development/sphinx_rtd_theme/sphinx_rtd_theme.SlackBuild97
-rw-r--r--development/sphinx_rtd_theme/sphinx_rtd_theme.info10
4 files changed, 0 insertions, 129 deletions
diff --git a/development/sphinx_rtd_theme/README b/development/sphinx_rtd_theme/README
deleted file mode 100644
index c84a1a5a96..0000000000
--- a/development/sphinx_rtd_theme/README
+++ /dev/null
@@ -1,3 +0,0 @@
-The sphinx_rtd_theme is a sphinx theme designed to look modern and
-be mobile-friendly. This theme is primary focused to be used on
-readthedocs.org but can work with your own sphinx projects.
diff --git a/development/sphinx_rtd_theme/slack-desc b/development/sphinx_rtd_theme/slack-desc
deleted file mode 100644
index 5b316eb641..0000000000
--- a/development/sphinx_rtd_theme/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-sphinx_rtd_theme: sphinx_rtd_theme (sphinx theme for readthedocs.org)
-sphinx_rtd_theme:
-sphinx_rtd_theme: The sphinx_rtd_theme is a sphinx theme designed to look modern and
-sphinx_rtd_theme: be mobile-friendly. This theme is primary focused to be used on
-sphinx_rtd_theme: readthedocs.org but can work with your own sphinx projects.
-sphinx_rtd_theme:
-sphinx_rtd_theme: Homepage: https://github.com/rtfd/sphinx_rtd_theme
-sphinx_rtd_theme:
-sphinx_rtd_theme:
-sphinx_rtd_theme:
-sphinx_rtd_theme:
diff --git a/development/sphinx_rtd_theme/sphinx_rtd_theme.SlackBuild b/development/sphinx_rtd_theme/sphinx_rtd_theme.SlackBuild
deleted file mode 100644
index f7f8be1d50..0000000000
--- a/development/sphinx_rtd_theme/sphinx_rtd_theme.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for sphinx_rtd_theme
-
-# Copyright 2018 Andrzej Telszewski, Szczecin
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=sphinx_rtd_theme
-VERSION=${VERSION:-0.4.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-if [ -x /usr/bin/python3 ]; then
- python3 setup.py install --root=$PKG
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a Apache-License-2.0.txt LICENSE OFL-License.txt README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/sphinx_rtd_theme/sphinx_rtd_theme.info b/development/sphinx_rtd_theme/sphinx_rtd_theme.info
deleted file mode 100644
index 7275c4e44d..0000000000
--- a/development/sphinx_rtd_theme/sphinx_rtd_theme.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="sphinx_rtd_theme"
-VERSION="0.4.2"
-HOMEPAGE="https://github.com/rtfd/sphinx_rtd_theme"
-DOWNLOAD="https://github.com/rtfd/sphinx_rtd_theme/archive/0.4.2/sphinx_rtd_theme-0.4.2.tar.gz"
-MD5SUM="6f18f674d10fa41de8907c86decfe8db"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Andrzej Telszewski"
-EMAIL="atelszewski@gmail.com"