summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2011-12-14 16:30:41 -0600
committer Niels Horn <niels.horn@slackbuilds.org>2011-12-18 00:07:50 -0200
commit66f8ada4ceb4c8bbe4053201864c28e6e1e1a57f (patch)
treea398e35ae19e1b0f02e2d3656b43e8b287659379 /development
parentbd13c3c6503f92cf355ec795e3afa2fd5b84621c (diff)
downloadslackbuilds-66f8ada4ceb4c8bbe4053201864c28e6e1e1a57f.tar.gz
slackbuilds-66f8ada4ceb4c8bbe4053201864c28e6e1e1a57f.tar.xz
development/pydblite: Removed (moved to Python category)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/pydblite/README8
-rw-r--r--development/pydblite/pydblite.SlackBuild75
-rw-r--r--development/pydblite/pydblite.info10
-rw-r--r--development/pydblite/slack-desc19
4 files changed, 0 insertions, 112 deletions
diff --git a/development/pydblite/README b/development/pydblite/README
deleted file mode 100644
index 3224e2de38..0000000000
--- a/development/pydblite/README
+++ /dev/null
@@ -1,8 +0,0 @@
-PyDbLite (small footprint untyped database engine in python)
-
-PyDbLite is a pure-Python in-memory database engine, using Python list
-comprehensions as query language instead of SQL, which stores data in a
-cPickled file.
-
-You can also use PyDbLite with MySQL and SQLite, as backends. In order to
-use MySQL's adapter you will need MySQL-python (available on SlackBuilds.org).
diff --git a/development/pydblite/pydblite.SlackBuild b/development/pydblite/pydblite.SlackBuild
deleted file mode 100644
index 2f30b8e61a..0000000000
--- a/development/pydblite/pydblite.SlackBuild
+++ /dev/null
@@ -1,75 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pydblite
-
-# Copyright 2007-2010 LukenShiro <lukenshiro@ngi.it>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pydblite
-VERSION=${VERSION:-2.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-SRC_PRGNAM=PyDbLite
-DOCFILES="PKG-INFO README.txt LICENCE.txt doc/*"
-
-# SLKCFLAGS are not used
-
-set -e # Exit on most errors
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRC_PRGNAM-$VERSION
-unzip $CWD/$SRC_PRGNAM-$VERSION.zip
-cd $SRC_PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Install .py source files
-python setup.py build install --root=$PKG
-
-# Copy documentation files
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pydblite/pydblite.info b/development/pydblite/pydblite.info
deleted file mode 100644
index 5a4d0e06d8..0000000000
--- a/development/pydblite/pydblite.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pydblite"
-VERSION="2.5"
-HOMEPAGE="http://pydblite.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/pydblite/PyDbLite-2.5.zip"
-MD5SUM="eb201ffc22ae08fa60e41d23334a279a"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="LukenShiro"
-EMAIL="lukenshiro@ngi.it"
-APPROVED="dsomero"
diff --git a/development/pydblite/slack-desc b/development/pydblite/slack-desc
deleted file mode 100644
index 5a2e5392ae..0000000000
--- a/development/pydblite/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-pydblite: PyDbLite (small footprint untyped database engine in python)
-pydblite:
-pydblite: PyDbLite is a pure-Python in-memory database engine, using
-pydblite: Python list comprehensions as query language instead of SQL,
-pydblite: which stores data in a cPickled file.
-pydblite:
-pydblite: It is written by Pierre Quentel and released under BSD license.
-pydblite:
-pydblite: Homepage: http://pydblite.sourceforge.net
-pydblite:
-pydblite: