summaryrefslogtreecommitdiffstats
path: root/games/dolphin-emu
diff options
context:
space:
mode:
author Steven Voges <svoges.sbo@gmail.com>2023-09-01 21:44:35 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-02 18:02:34 +0700
commitd9203a732f8ba8eaddde8bc818522f384ed8b4c8 (patch)
treea5b236a7e7b3fa09e113e867ff5e68967a655c73 /games/dolphin-emu
parentc20e23013d66ff516f27c3ae2006ff30e19bc864 (diff)
downloadslackbuilds-d9203a732f8ba8eaddde8bc818522f384ed8b4c8.tar.gz
slackbuilds-d9203a732f8ba8eaddde8bc818522f384ed8b4c8.tar.xz
games/dolphin-emu: Updated for version 5.0.20059.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/dolphin-emu')
-rw-r--r--games/dolphin-emu/README8
-rw-r--r--games/dolphin-emu/dolphin-emu.SlackBuild23
-rw-r--r--games/dolphin-emu/dolphin-emu.info22
3 files changed, 31 insertions, 22 deletions
diff --git a/games/dolphin-emu/README b/games/dolphin-emu/README
index e3e767f8a3..362efdb681 100644
--- a/games/dolphin-emu/README
+++ b/games/dolphin-emu/README
@@ -4,8 +4,9 @@ two consoles in full HD (1080p) with several enhancements:
compatibility with all PC controllers, turbo speed, networked
multiplayer, and even more!
-Optional dependencies: SFML, cubeb, fmt, gtest, hidapi, jack, mgba,
-mbedtls, miniupnpc, pugixml, qt6
+Dolphin will optionally build against internal system packages if
+present, these include: SFML, enet, fmt, hidapi, mbedtls, libminizip,
+libspng, mgba, miniupnpc, pugixml, and zstd-cmake.
Analytic data collection is enabled by default, however, users are
prompted about this on first launch. To disable analytics without being
@@ -19,6 +20,3 @@ USEMGBA=OFF to the build script. This will remove the mgba dependecy.
If you have installed mgba <= 0.10.0, this build will fail, please
install 0.10.0+ or 'removepkg mgba' prior to running this script.
-
-qt6 is an optional dependency and will be built against it if present
-at build time. Otherwise, qt5 will be used.
diff --git a/games/dolphin-emu/dolphin-emu.SlackBuild b/games/dolphin-emu/dolphin-emu.SlackBuild
index 079b437d22..95732087f6 100644
--- a/games/dolphin-emu/dolphin-emu.SlackBuild
+++ b/games/dolphin-emu/dolphin-emu.SlackBuild
@@ -27,14 +27,15 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=dolphin-emu
SRCNAM=dolphin
-VERSION=${VERSION:-5.0.19115}
+VERSION=${VERSION:-5.0.20059}
COMMIT=$(echo $VERSION | cut -c 5-)
-SRCVER=${SRCVER:-806ea59d77809aa7c6c17a4b61ae304b0f19e284}
-IMPLOT=${IMPLOT:-d87512353495e7760e7fda7566a05beef7627d8f}
+SRCVER=${SRCVER:-5e5887a378db28324a8fc8825f21539525412e12}
+IMPLOT=${IMPLOT:-cc5e1daa5c7f2335a9460ae79c829011dc5cef2d}
LIBSPNG=${LIBSPNG:-dc5b1032c08efac68ad30170f7ccbf0aa8dd55c9}
-MGBA=${MGBA:-89f8873df366a99dfdf40347f72e68763fb50bd9}
+MGBA=${MGBA:-8739b22fbc90fdf0b4f6612ef9c0520f0ba44a51}
+RCHEEVOS=${RCHEEVOS:-d9e990e6d13527532b7e2bb23164a1f3b7f33bb5}
SPIRVCROSS=${SPIRVCROSS:-50b4d5389b6a06f86fb63a2848e1a7da6d9755ca}
-VULKANMEMORYALLOCATOR=${VULKANMEMORYALLOCATOR:-c351692490513cdb0e5a2c925aaf7ea4a9b672f4}
+VULKANMEMORYALLOCATOR=${VULKANMEMORYALLOCATOR:-498e20dfd1343d99b9115201034bb0219801cdec}
ZLIBNG=${ZLIBNG:-ce01b1e41da298334f8214389cc9369540a7560f}
ANALYTICS=${ANALYTICS:-ON}
DISCORD=${DISCORD:-OFF}
@@ -96,10 +97,12 @@ if [ ${USEMGBA} = "ON" ]; then
tar xvf $CWD/mgba-$MGBA.tar.gz -C \
$DEPS/mGBA/mgba --strip-components 1
fi
+tar xvf $CWD/rcheevos-$RCHEEVOS.tar.gz -C \
+ $DEPS/rcheevos/rcheevos --strip-components 1
tar xvf $CWD/zlib-ng-$ZLIBNG.tar.gz -C \
$DEPS/zlib-ng/zlib-ng --strip-components 1
-sed -i "s/ (no further info)/-$COMMIT/g" CMakeLists.txt
+sed -i "s/ (no further info)/-$COMMIT/g" CMake/ScmRevGen.cmake
chown -R root:root .
find -L . \
@@ -108,6 +111,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# LTO currently breaks JIT and will crash dolphin on game load.
+# fmt10 is not supported by dolphin yet, force bundled fmt9.
+# mgba 0.10.2 changed functions that break compilation, force bundled mgba.
mkdir -p build
cd build
cmake \
@@ -118,11 +124,14 @@ cd build
-Dmandir=/usr/man \
-DDISTRIBUTOR=SlackBuilds.org \
-DENABLE_ANALYTICS=$ANALYTICS \
- -DENABLE_LTO=ON \
+ -DENABLE_LTO=OFF \
-DENABLE_SDL=ON \
-DENABLE_TESTS=OFF \
-DUSE_DISCORD_PRESENCE=$DISCORD \
-DUSE_MGBA=$USEMGBA \
+ -DUSE_SYSTEM_CUBEB=ON \
+ -DUSE_SYSTEM_FMT=OFF \
+ -DUSE_SYSTEM_LIBMGBA=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
make install/strip DESTDIR=$PKG
diff --git a/games/dolphin-emu/dolphin-emu.info b/games/dolphin-emu/dolphin-emu.info
index 035732a609..4ede3dd7ef 100644
--- a/games/dolphin-emu/dolphin-emu.info
+++ b/games/dolphin-emu/dolphin-emu.info
@@ -1,22 +1,24 @@
PRGNAM="dolphin-emu"
-VERSION="5.0.19115"
+VERSION="5.0.20059"
HOMEPAGE="https://dolphin-emu.org"
DOWNLOAD="UNSUPPORTED"
MD5SUM=""
-DOWNLOAD_x86_64="https://github.com/dolphin-emu/dolphin/archive/806ea59d77809aa7c6c17a4b61ae304b0f19e284/dolphin-806ea59d77809aa7c6c17a4b61ae304b0f19e284.tar.gz \
+DOWNLOAD_x86_64="https://github.com/dolphin-emu/dolphin/archive/5e5887a378db28324a8fc8825f21539525412e12/dolphin-5e5887a378db28324a8fc8825f21539525412e12.tar.gz \
https://github.com/KhronosGroup/SPIRV-Cross/archive/50b4d5389b6a06f86fb63a2848e1a7da6d9755ca/SPIRV-Cross-50b4d5389b6a06f86fb63a2848e1a7da6d9755ca.tar.gz \
- https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator/archive/c351692490513cdb0e5a2c925aaf7ea4a9b672f4/VulkanMemoryAllocator-c351692490513cdb0e5a2c925aaf7ea4a9b672f4.tar.gz \
- https://github.com/epezent/implot/archive/d87512353495e7760e7fda7566a05beef7627d8f/implot-d87512353495e7760e7fda7566a05beef7627d8f.tar.gz \
+ https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator/archive/498e20dfd1343d99b9115201034bb0219801cdec/VulkanMemoryAllocator-498e20dfd1343d99b9115201034bb0219801cdec.tar.gz \
+ https://github.com/epezent/implot/archive/cc5e1daa5c7f2335a9460ae79c829011dc5cef2d/implot-cc5e1daa5c7f2335a9460ae79c829011dc5cef2d.tar.gz \
https://github.com/randy408/libspng/archive/dc5b1032c08efac68ad30170f7ccbf0aa8dd55c9/libspng-dc5b1032c08efac68ad30170f7ccbf0aa8dd55c9.tar.gz \
- https://github.com/mgba-emu/mgba/archive/89f8873df366a99dfdf40347f72e68763fb50bd9/mgba-89f8873df366a99dfdf40347f72e68763fb50bd9.tar.gz \
+ https://github.com/mgba-emu/mgba/archive/8739b22fbc90fdf0b4f6612ef9c0520f0ba44a51/mgba-8739b22fbc90fdf0b4f6612ef9c0520f0ba44a51.tar.gz \
+ https://github.com/RetroAchievements/rcheevos/archive/d9e990e6d13527532b7e2bb23164a1f3b7f33bb5/rcheevos-d9e990e6d13527532b7e2bb23164a1f3b7f33bb5.tar.gz \
https://github.com/zlib-ng/zlib-ng/archive/ce01b1e41da298334f8214389cc9369540a7560f/zlib-ng-ce01b1e41da298334f8214389cc9369540a7560f.tar.gz"
-MD5SUM_x86_64="35a870c23a714e94978c5c8b541b2507 \
+MD5SUM_x86_64="cda88a526bbe63c76d4cecdb79913922 \
ccbd4691aa98e09c48ca52938780f485 \
- 9eb7af01d2b36d8d5964696ecd257011 \
- 47bc6ef34b7c577c7a0835f686f90107 \
+ ea3949092d01da0ea473705e625a3614 \
+ 00be8f97e4927afcde33fe5e9799b56e \
5c563b774605b0bad9f6ed244bd9e14d \
- 1dba2ed39f63a90f52c0016a76d8bd35 \
+ c871e87ede68b9c5d5ccc6b6a8173b3a \
+ 1288381ecdbe222e5759119ec730a6fd \
59bc34854f5bb7492810e30f20b844eb"
-REQUIRES="cubeb"
+REQUIRES="cubeb qt6"
MAINTAINER="Steven Voges"
EMAIL="svoges.sbo@gmail.com"