summaryrefslogtreecommitdiffstats
path: root/games/ppsspp/ppsspp.SlackBuild
diff options
context:
space:
mode:
author Ruoh-Shoei LIN <lin.ruohshoei+sbo at gmail.com>2022-04-18 13:20:13 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-04-24 01:47:15 +0700
commit659060efd9ae819a5dbdc55fa13525fb6e401370 (patch)
treead6f2331036d6c829d253580f353cae42d664dd4 /games/ppsspp/ppsspp.SlackBuild
parent509e44aaafeab04575e73093aa59a55bedc51f9c (diff)
downloadslackbuilds-659060efd9ae819a5dbdc55fa13525fb6e401370.tar.gz
slackbuilds-659060efd9ae819a5dbdc55fa13525fb6e401370.tar.xz
games/ppsspp: Updated for version 1.12.3.
- update archives of submodule, thanks for fourtysixandtwo. - remove ppsspp-lang - add SYSTEM_FFMPEG(default off) option - default build with: headless, sdl Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games/ppsspp/ppsspp.SlackBuild')
-rw-r--r--games/ppsspp/ppsspp.SlackBuild64
1 files changed, 32 insertions, 32 deletions
diff --git a/games/ppsspp/ppsspp.SlackBuild b/games/ppsspp/ppsspp.SlackBuild
index 6381eadcf4..1c6126a2b1 100644
--- a/games/ppsspp/ppsspp.SlackBuild
+++ b/games/ppsspp/ppsspp.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for ppsspp
# Copyright 2016 Hunter Sezen California, USA
-# Copyright 2019-2020 Ruoh-Shoei LIN
+# Copyright 2019-2022 Ruoh-Shoei LIN
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,16 +23,10 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# 20210218 bkw: modified by SlackBuilds.org. Use correct filenames
-# in the github URLs for the 'submodules'. This is needed because
-# we don't get to decide what user-agent the user downloads files
-# with. If the Content-Disposition header is honored (e.g. files
-# downloaded with a web browser), this build failed.
-
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ppsspp
-VERSION=${VERSION:-1.10.3}
+VERSION=${VERSION:-1.12.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,20 +76,26 @@ cd $PRGNAM-$VERSION
# The submodules are in a separate archive. This is equivalent to
# git submodule update --init --recursive
-tar -xvf $CWD/glslang-d0850f8*.tar.gz \
+tar -xvf $CWD/zstd-a488ba1*.tar.gz \
+ -C ext/zstd --strip-components=1
+tar -xvf $CWD/miniupnp-3a87be3*.tar.gz \
+ -C ext/miniupnp --strip-components=1
+tar -xvf $CWD/glslang-dc11add*.tar.gz \
-C ext/glslang --strip-components=1
-tar -xvf $CWD/ppsspp-lang-1c64b8f*.tar.gz \
- -C assets/lang --strip-components=1
-tar -xvf $CWD/SPIRV-Cross-a1f7c8d*.tar.gz \
+tar -xvf $CWD/SPIRV-Cross-9acb9ec*.tar.gz \
-C ext/SPIRV-Cross --strip-components=1
tar -xvf $CWD/armips-7885552*.tar.gz \
-C ext/armips --strip-components=1
-tar -xvf $CWD/ppsspp-ffmpeg-55147e5*.tar.gz \
+
+SYSTEM_FFMPEG=${SYSTEM_FFMPEG:-off}
+if [ "$SYSTEM_FFMPEG" = "off" ]; then
+ tar -xvf $CWD/ppsspp-ffmpeg-a5baf97*.tar.gz \
--exclude '*/Windows*' --exclude '*/android' \
--exclude '*/ios' --exclude '*/blackberry'\
--exclude '*/macosx' --exclude '*/wiiu' \
--exclude '*/symbian' \
-C ffmpeg --strip-components=1
+fi
chown -R root:root .
find -L . \
@@ -104,9 +104,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# This does build with Slackware 14.2's CMake.
-sed -i 's/VERSION 3.6/VERSION 3.5.2/' CMakeLists.txt
-
# Don't force explicit ccache invocation.
sed -i -e '/include(ccache)/d' CMakeLists.txt
@@ -117,21 +114,22 @@ mkdir -p build-qt build-sdl
QT=${QT:-off}
if [ "$QT" = "on" ]; then
- cd build-qt
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_SKIP_RPATH=TRUE \
- -Wno-dev \
- -DUSING_QT_UI=ON \
- -DUSE_SYSTEM_LIBZIP=ON \
- -DUSE_DISCORD=OFF \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- cd ..
- install -Dm755 build-qt/PPSSPPQt $PKG/usr/games/ppsspp-qt
- install -Dm644 $CWD/ppsspp-qt.desktop $PKG/usr/share/applications/ppsspp-qt.desktop
+ cd build-qt
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_SKIP_RPATH=TRUE \
+ -Wno-dev \
+ -DUSING_QT_UI=ON \
+ -DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_FFMPEG=$SYSTEM_FFMPEG \
+ -DUSE_DISCORD=OFF \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ cd ..
+ install -Dm755 build-qt/PPSSPPQt $PKG/usr/games/ppsspp-qt
+ install -Dm644 $CWD/ppsspp-qt.desktop $PKG/usr/share/applications/ppsspp-qt.desktop
fi
cd build-sdl
@@ -144,6 +142,7 @@ cmake \
-DUSING_QT_UI=OFF \
-DHEADLESS='ON' \
-DUSE_SYSTEM_LIBZIP=ON \
+ -DUSE_SYSTEM_FFMPEG=$SYSTEM_FFMPEG \
-DUSE_DISCORD=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
@@ -161,7 +160,8 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -v LICENSE.TXT README.md history.md headless/headless.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.TXT README.md history.md headless/headless.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install