summaryrefslogtreecommitdiffstats
path: root/games/wesnoth
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackware-id.org>2013-10-25 23:10:43 -0500
committer Robby Workman <rworkman@slackbuilds.org>2013-10-27 23:38:50 -0500
commitd22eaf98c11ba85eb355c9936d0bdc9cef25a54a (patch)
tree732b7a092ee209be1a4c29d6e45dab368ea0e6f6 /games/wesnoth
parent0e9f452fe74418818ea7d1e6d87430321211caa3 (diff)
downloadslackbuilds-d22eaf98c11ba85eb355c9936d0bdc9cef25a54a.tar.gz
slackbuilds-d22eaf98c11ba85eb355c9936d0bdc9cef25a54a.tar.xz
games/wesnoth: Updated for version 1.10.7.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/fix-segfault.patch43
-rw-r--r--games/wesnoth/wesnoth.SlackBuild10
-rw-r--r--games/wesnoth/wesnoth.info6
3 files changed, 5 insertions, 54 deletions
diff --git a/games/wesnoth/fix-segfault.patch b/games/wesnoth/fix-segfault.patch
deleted file mode 100644
index 882231d99e..0000000000
--- a/games/wesnoth/fix-segfault.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From bbd7f62a426e321034c7bdf9054152fc159e517a Mon Sep 17 00:00:00 2001
-From: "J. Tyne" <jt_coding@verizon.net>
-Date: Thu, 13 Dec 2012 14:22:35 +0000
-Subject: [PATCH] Change some implicit conversions to return const references
- to objects...
-
-...instead of temporary objects.
-
-Fixes bug #20360.
----
- src/shared_object.hpp | 2 +-
- src/tstring.hpp | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/shared_object.hpp b/src/shared_object.hpp
-index 89be3b8..a6099a8 100644
---- a/src/shared_object.hpp
-+++ b/src/shared_object.hpp
-@@ -51,7 +51,7 @@ class shared_object {
- val_->count++;
- }
-
-- operator T() const {
-+ operator const T &() const {
- assert(valid());
- return val_->val;
- }
-diff --git a/src/tstring.hpp b/src/tstring.hpp
-index a391d58..f4664f5 100644
---- a/src/tstring.hpp
-+++ b/src/tstring.hpp
-@@ -145,7 +145,7 @@ class t_string :
- static t_string from_serialized(const std::string& string) { return t_string(base::from_serialized(string)); }
- std::string to_serialized() const { return get().to_serialized(); }
-
-- operator t_string_base() const { return get(); }
-+ operator const t_string_base &() const { return get(); }
-
- t_string operator+(const t_string& o) const { return get() + o.get(); }
- t_string operator+(const std::string& o) const { return get() + o; }
---
-1.8.1.6
-
diff --git a/games/wesnoth/wesnoth.SlackBuild b/games/wesnoth/wesnoth.SlackBuild
index f5acbe9dba..93ec7fd6d3 100644
--- a/games/wesnoth/wesnoth.SlackBuild
+++ b/games/wesnoth/wesnoth.SlackBuild
@@ -26,8 +26,8 @@
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=wesnoth
-VERSION=${VERSION:-1.10.6}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.10.7}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -91,12 +91,6 @@ CXXFLAGS="$SLKCFLAGS" \
# Fix build problem on future GCC 4.8.0
sed -i 's/-Werror//' CMakeLists.txt
-# Fix segfault
-# Upstream bug report and patch
-# https://gna.org/bugs/index.php?20742
-# https://github.com/wesnoth/wesnoth-old/commit/bbd7f6.patch
-patch -p1 < $CWD/fix-segfault.patch
-
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
diff --git a/games/wesnoth/wesnoth.info b/games/wesnoth/wesnoth.info
index 9603323c7b..75f472e07f 100644
--- a/games/wesnoth/wesnoth.info
+++ b/games/wesnoth/wesnoth.info
@@ -1,8 +1,8 @@
PRGNAM="wesnoth"
-VERSION="1.10.6"
+VERSION="1.10.7"
HOMEPAGE="http://www.wesnoth.org"
-DOWNLOAD="http://downloads.sourceforge.net/wesnoth/wesnoth-1.10.6.tar.bz2"
-MD5SUM="547e3489bbfa778912b11dbee612c380"
+DOWNLOAD="http://sourceforge.net/projects/wesnoth/files/wesnoth-1.10/wesnoth-1.10.7/wesnoth-1.10.7.tar.bz2/download"
+MD5SUM="3f460a494530d32aa5d5d0f19c95efbd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="lua"