summaryrefslogtreecommitdiffstats
path: root/gis/python3-shapely
diff options
context:
space:
mode:
author ArTourter <artourter@gmail.com>2023-06-24 14:46:29 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-02 23:21:13 +0700
commit0c23bdb4ca298209661f33662cdf3a377705de45 (patch)
treefa37b0caade25643411cc2e1dbaf0475db45b7f8 /gis/python3-shapely
parent5751eb4adff7c0f87e0088883cc8f632b28b23ff (diff)
downloadslackbuilds-0c23bdb4ca298209661f33662cdf3a377705de45.tar.gz
slackbuilds-0c23bdb4ca298209661f33662cdf3a377705de45.tar.xz
gis/python3-shapely: Updated for version 2.0.1.
- Add dep python3-setuptools-opt - patch for oldest-supported-numpy requirement Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/python3-shapely')
-rw-r--r--gis/python3-shapely/python3-shapely.SlackBuild32
-rw-r--r--gis/python3-shapely/python3-shapely.info8
2 files changed, 17 insertions, 23 deletions
diff --git a/gis/python3-shapely/python3-shapely.SlackBuild b/gis/python3-shapely/python3-shapely.SlackBuild
index b86efae4b6..32b62acf2f 100644
--- a/gis/python3-shapely/python3-shapely.SlackBuild
+++ b/gis/python3-shapely/python3-shapely.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Shapely
# Copyright 2013-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# Copyright 2021-2023 Gregory J. L. Tourte <artourter@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-shapely
-VERSION=${VERSION:-1.8.5.post1}
+VERSION=${VERSION:-2.0.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -53,20 +53,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,10 +68,18 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# remove unnecessary .pxi file
-sed -i '/include_package_data=/s/True/False/' setup.py
+# Fixing numpy dependency check in pyproject.toml:
+# oldest-supported-numpy has a strict check and doesn't support newer version
+# so we replace it. The alternative is to add --skip-dependency-check to tbe
+# build line but this is not deemed optimal.
+sed -i 's/oldest-supported-numpy/numpy>=1.19.3/' pyproject.toml
+
+# Requires newer version of setuptools than available in -stable. Has not
+# effect on -current
+export PYTHONPATH=/opt/python3.9/site-packages
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/gis/python3-shapely/python3-shapely.info b/gis/python3-shapely/python3-shapely.info
index a5d84a0da2..3c096bf8ef 100644
--- a/gis/python3-shapely/python3-shapely.info
+++ b/gis/python3-shapely/python3-shapely.info
@@ -1,10 +1,10 @@
PRGNAM="python3-shapely"
-VERSION="1.8.5.post1"
+VERSION="2.0.1"
HOMEPAGE="https://github.com/shapely/shapely"
-DOWNLOAD="https://github.com/shapely/shapely/archive/1.8.5.post1/shapely-1.8.5.post1.tar.gz"
-MD5SUM="fb5f713780c4798efa34caaa6939a55d"
+DOWNLOAD="https://github.com/shapely/shapely/archive/2.0.1/shapely-2.0.1.tar.gz"
+MD5SUM="68c60ba003dacee4a3c0fbaad8a4c685"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="geos"
+REQUIRES="python3-setuptools-opt python3-numpy geos"
MAINTAINER="ArTourter"
EMAIL="artourter@gmail.com"