summaryrefslogtreecommitdiffstats
path: root/gis/python3-shapely
diff options
context:
space:
mode:
author ArTourter <artourter@gmail.com>2022-03-09 13:32:24 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 21:29:30 +0700
commit99f45e7a11c5c5ec6af7d473fc2933cd2bc8bb91 (patch)
treef54320c052bc92a33655ff22967f6020b3067835 /gis/python3-shapely
parent3bfe6747efb3cf7596aa99b88d7eb09ac21f471b (diff)
downloadslackbuilds-99f45e7a11c5c5ec6af7d473fc2933cd2bc8bb91.tar.gz
slackbuilds-99f45e7a11c5c5ec6af7d473fc2933cd2bc8bb91.tar.xz
gis/python3-shapely: renamed from gis/Shapely, updated for version 1.8.1.post1
Signed-off-by: ArTourter <artourter@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis/python3-shapely')
-rw-r--r--gis/python3-shapely/README5
-rw-r--r--gis/python3-shapely/python3-shapely.SlackBuild103
-rw-r--r--gis/python3-shapely/python3-shapely.info10
-rw-r--r--gis/python3-shapely/slack-desc19
4 files changed, 137 insertions, 0 deletions
diff --git a/gis/python3-shapely/README b/gis/python3-shapely/README
new file mode 100644
index 0000000000..99de18871f
--- /dev/null
+++ b/gis/python3-shapely/README
@@ -0,0 +1,5 @@
+Shapely is a BSD-licensed Python package for manipulation and analysis
+of planar geometric objects. It is based on the widely deployed GEOS
+(the engine of PostGIS) and JTS (from which GEOS is ported) libraries.
+Shapely is not concerned with data formats or coordinate systems, but
+can be readily integrated with packages that are.
diff --git a/gis/python3-shapely/python3-shapely.SlackBuild b/gis/python3-shapely/python3-shapely.SlackBuild
new file mode 100644
index 0000000000..cc167a771f
--- /dev/null
+++ b/gis/python3-shapely/python3-shapely.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/bash
+
+# Slackware build script for Shapely
+
+# Copyright 2013-2020 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2021-2022 Gregory J. L. Tourte <artourter@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-shapely
+VERSION=${VERSION:-1.8.1.post1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=shapely
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# remove unnecessary .pxi file
+sed -i '/include_package_data=/s/True/False/' setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES.txt CREDITS.txt LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/gis/python3-shapely/python3-shapely.info b/gis/python3-shapely/python3-shapely.info
new file mode 100644
index 0000000000..322d6ed001
--- /dev/null
+++ b/gis/python3-shapely/python3-shapely.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-shapely"
+VERSION="1.8.1.post1"
+HOMEPAGE="https://github.com/shapely/shapely"
+DOWNLOAD="https://github.com/shapely/shapely/archive/1.8.1.post1/shapely-1.8.1.post1.tar.gz"
+MD5SUM="f87b8ecb362b9d019137be52e8f5a03f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="geos"
+MAINTAINER="ArTourter"
+EMAIL="artourter@gmail.com"
diff --git a/gis/python3-shapely/slack-desc b/gis/python3-shapely/slack-desc
new file mode 100644
index 0000000000..4a761f5b87
--- /dev/null
+++ b/gis/python3-shapely/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-shapely: Shapely (geometric objects, predicates, and operations in Python)
+python3-shapely:
+python3-shapely: Shapely is a BSD-licensed Python package for manipulation and analysis
+python3-shapely: of planar geometric objects. It is based on the widely deployed GEOS
+python3-shapely: (the engine of PostGIS) and JTS (from which GEOS is ported) libraries.
+python3-shapely: Shapely is not concerned with data formats or coordinate systems, but
+python3-shapely: can be readily integrated with packages that are.
+python3-shapely:
+python3-shapely: Homepage: https://github.com/shapely/shapely
+python3-shapely:
+python3-shapely: