summaryrefslogtreecommitdiffstats
path: root/graphics/mirage
diff options
context:
space:
mode:
author nobody <nobody@nowhere>2010-05-12 17:40:00 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-12 17:40:00 +0200
commit416534e6087b0f89ff7c7f5c060534aa0cc90d8c (patch)
tree86f7c6ae5ddd64e8567b242b380e71e65918562b /graphics/mirage
parent357e0acdaf4df60a8cccdf0724a45cc1fa00bd19 (diff)
downloadslackbuilds-416534e6087b0f89ff7c7f5c060534aa0cc90d8c.tar.gz
slackbuilds-416534e6087b0f89ff7c7f5c060534aa0cc90d8c.tar.xz
graphics/mirage: Updated for version 0.9.3
Diffstat (limited to 'graphics/mirage')
-rw-r--r--graphics/mirage/README7
-rw-r--r--graphics/mirage/doinst.sh3
-rw-r--r--graphics/mirage/mirage.SlackBuild26
-rw-r--r--graphics/mirage/mirage.info6
-rw-r--r--graphics/mirage/slack-desc16
5 files changed, 29 insertions, 29 deletions
diff --git a/graphics/mirage/README b/graphics/mirage/README
index 431c22cf25..a482673827 100644
--- a/graphics/mirage/README
+++ b/graphics/mirage/README
@@ -1,4 +1,3 @@
-Mirage is a fast and simple GTK+ image viewer. Because
-it depends only on PyGTK, Mirage is ideal for users who
-wish to keep their computers lean while still having a
-clean image viewer.
+Mirage is a fast and simple GTK+ image viewer. Because it depends only
+on PyGTK, Mirage is ideal for users who wish to keep their computers
+lean while still having a clean image viewer.
diff --git a/graphics/mirage/doinst.sh b/graphics/mirage/doinst.sh
index 854e20633d..392c12adb9 100644
--- a/graphics/mirage/doinst.sh
+++ b/graphics/mirage/doinst.sh
@@ -1,3 +1,4 @@
if [ -x /usr/bin/update-desktop-database ]; then
- ./usr/bin/update-desktop-database -q usr/share/applications
+ /usr/bin/update-desktop-database -q usr/share/applications
fi
+
diff --git a/graphics/mirage/mirage.SlackBuild b/graphics/mirage/mirage.SlackBuild
index fb391bf1c3..aa6bee9463 100644
--- a/graphics/mirage/mirage.SlackBuild
+++ b/graphics/mirage/mirage.SlackBuild
@@ -23,9 +23,9 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mirage
-VERSION=0.9.3
+VERSION=${VERSION:-0.9.3}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -33,8 +33,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="CHANGELOG COPYING README TODO TRANSLATORS"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
@@ -43,13 +41,14 @@ elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
-cd $PRGNAM-$VERSION || exit 1
-
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -59,8 +58,8 @@ find . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
-python setup.py build || exit 1
-python setup.py install --root $PKG || exit 1
+
+python setup.py install --root $PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
@@ -68,13 +67,14 @@ python setup.py install --root $PKG || exit 1
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+for i in CHANGELOG COPYING README TODO TRANSLATORS ; do
+ ln -s /usr/share/mirage/$i $PKG/usr/doc/$PRGNAM-$VERSION/$i ;
+done
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
mkdir -p $PKG/install
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/graphics/mirage/mirage.info b/graphics/mirage/mirage.info
index 5fb6e94073..e03630e28d 100644
--- a/graphics/mirage/mirage.info
+++ b/graphics/mirage/mirage.info
@@ -3,6 +3,6 @@ VERSION="0.9.3"
HOMEPAGE="http://mirageiv.berlios.de/"
DOWNLOAD="http://download.berlios.de/mirageiv/mirage-0.9.3.tar.bz2"
MD5SUM="87bd8b8de578f34f4028073ecfa43474"
-MAINTAINER="Frank Caraballo"
-EMAIL="fecaraballo{at}gmail{dot}com"
-APPROVED="David Somero" \ No newline at end of file
+MAINTAINER="nobody"
+EMAIL="nobody@nowhere"
+APPROVED="rworkman"
diff --git a/graphics/mirage/slack-desc b/graphics/mirage/slack-desc
index f9da729cfe..0ed149c011 100644
--- a/graphics/mirage/slack-desc
+++ b/graphics/mirage/slack-desc
@@ -1,19 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
mirage: Mirage (GTK+ Image Viewer)
mirage:
-mirage: Mirage is a fast and simple GTK+ image viewer. Because
-mirage: it depends only on PyGTK, Mirage is ideal for users who
-mirage: wish to keep their computers lean while still having a
-mirage: clean image viewer.
+mirage: Mirage is a fast and simple GTK+ image viewer. Because it depends only
+mirage: on PyGTK, Mirage is ideal for users who wish to keep their computers
+mirage: lean while still having a clean image viewer.
mirage:
mirage: Homepage: http://mirageiv.berlios.de/
mirage:
mirage:
mirage:
+mirage: