summaryrefslogtreecommitdiffstats
path: root/libraries/Impacket
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2022-04-22 12:22:29 -0400
committer B. Watson <yalhcru@gmail.com>2022-04-22 12:22:29 -0400
commit21b40e8b02628c7faef9493c120e312e885c3907 (patch)
tree1cee9e759aa00fbfecf2bb8e64acab91e0038157 /libraries/Impacket
parent295d56969dd1a5829218f70799c964487cabc69c (diff)
downloadslackbuilds-21b40e8b02628c7faef9493c120e312e885c3907.tar.gz
slackbuilds-21b40e8b02628c7faef9493c120e312e885c3907.tar.xz
libraries/Impacket: Fix docs.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries/Impacket')
-rw-r--r--libraries/Impacket/Impacket.SlackBuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/libraries/Impacket/Impacket.SlackBuild b/libraries/Impacket/Impacket.SlackBuild
index f20a15e8c1..5880ca0ac8 100644
--- a/libraries/Impacket/Impacket.SlackBuild
+++ b/libraries/Impacket/Impacket.SlackBuild
@@ -23,12 +23,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220422 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - remove /usr/share/doc.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=Impacket
SRCNAM=impacket
VERSION=${VERSION:-0.9.21}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +43,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,9 +79,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Python3 support
if $(python3 -c 'import sys' 2>/dev/null); then
@@ -93,6 +93,9 @@ python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220422 bkw: nothing in share except redundant doc.
+rm -rf $PKG/usr/share
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild