summaryrefslogtreecommitdiffstats
path: root/libraries/VTK
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2020-12-17 18:05:09 +0100
committer Robby Workman <rworkman@slackbuilds.org>2021-04-17 23:04:01 -0500
commita8e11156531e64f0622390128eb73594f54f30d8 (patch)
treed771de61c17933a5b33d80105a9b3912c9087b07 /libraries/VTK
parent0f7e69edc1015c38efb118f43f8ff4e1cb91f039 (diff)
downloadslackbuilds-a8e11156531e64f0622390128eb73594f54f30d8.tar.gz
slackbuilds-a8e11156531e64f0622390128eb73594f54f30d8.tar.xz
libraries/VTK: Patch for gcc >= 10.x.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/VTK')
-rw-r--r--libraries/VTK/VTK.SlackBuild5
-rw-r--r--libraries/VTK/patch-gcc10.diff40
2 files changed, 45 insertions, 0 deletions
diff --git a/libraries/VTK/VTK.SlackBuild b/libraries/VTK/VTK.SlackBuild
index ae29a67c07..be7a516a3a 100644
--- a/libraries/VTK/VTK.SlackBuild
+++ b/libraries/VTK/VTK.SlackBuild
@@ -105,6 +105,11 @@ else
proj=""
fi
+# https://github.com/archlinux/svntogit-community/blob/packages/vtk/trunk/PKGBUILD
+( cd ThirdParty/exodusII/vtkexodusII
+ patch -p1 < $CWD/patch-gcc10.diff )
+sed -i 's|REGEX MATCH \"\[3-9\]|REGEX MATCH \"[1-9][0-9]|' CMake/VTKGenerateExportHeader.cmake
+
mkdir -p build
cd build
cmake \
diff --git a/libraries/VTK/patch-gcc10.diff b/libraries/VTK/patch-gcc10.diff
new file mode 100644
index 0000000000..507c8a7a64
--- /dev/null
+++ b/libraries/VTK/patch-gcc10.diff
@@ -0,0 +1,40 @@
+From a9079bdccbb2165583d6773a5ed848427e2a38a8 Mon Sep 17 00:00:00 2001
+From: Seacas Upstream <kwrobot@kitware.com>
+Date: Tue, 28 Jan 2020 09:13:38 -0500
+Subject: [PATCH] exodusII 2020-01-28 (d97eb08d)
+
+Code extracted from:
+
+ https://gitlab.kitware.com/third-party/seacas.git
+
+at commit d97eb08d79e87c82facfae39bc75deb60c0a2d83 (for/vtk-20200128-7.24f-v2019-12-18).
+---
+ src/ex_create_par.c | 2 +-
+ src/ex_open_par.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/ex_create_par.c b/src/ex_create_par.c
+index 8d5d6734f0..ef439618da 100644
+--- a/src/ex_create_par.c
++++ b/src/ex_create_par.c
+@@ -216,5 +216,5 @@ int ex_create_par_int(const char *path, int cmode, int *comp_ws, int *io_ws, MPI
+ * Prevent warning in some versions of ranlib(1) because the object
+ * file has no symbols.
+ */
+-const char exodus_unused_symbol_dummy_1;
++const char exodus_unused_symbol_dummy_ex_create_par;
+ #endif
+diff --git a/src/ex_open_par.c b/src/ex_open_par.c
+index b2faa22c29..9df4818767 100644
+--- a/src/ex_open_par.c
++++ b/src/ex_open_par.c
+@@ -459,5 +459,5 @@ int ex_open_par_int(const char *path, int mode, int *comp_ws, int *io_ws, float
+ * Prevent warning in some versions of ranlib(1) because the object
+ * file has no symbols.
+ */
+-const char exodus_unused_symbol_dummy_1;
++const char exodus_unused_symbol_dummy_ex_open_par;
+ #endif
+--
+GitLab
+