summaryrefslogtreecommitdiffstats
path: root/libraries/coeurl
diff options
context:
space:
mode:
author Lockywolf <for_coeurl.2023-10-18@lockywolf.net>2023-10-19 13:03:33 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-19 13:45:48 +0700
commit2405f66d9e0bf81ae8aa3d92a7ce5ecc60d8ae41 (patch)
tree3ca1156852bedd1d50f78da1d93f958ea614166d /libraries/coeurl
parent595a42c067442c726f16b2a3c4865fa2faaa5fa6 (diff)
downloadslackbuilds-2405f66d9e0bf81ae8aa3d92a7ce5ecc60d8ae41.tar.gz
slackbuilds-2405f66d9e0bf81ae8aa3d92a7ce5ecc60d8ae41.tar.xz
libraries/coeurl: Added (curl wrapper for C++).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/coeurl')
-rw-r--r--libraries/coeurl/README3
-rw-r--r--libraries/coeurl/coeurl.SlackBuild119
-rw-r--r--libraries/coeurl/coeurl.info10
-rw-r--r--libraries/coeurl/slack-desc19
4 files changed, 151 insertions, 0 deletions
diff --git a/libraries/coeurl/README b/libraries/coeurl/README
new file mode 100644
index 0000000000..b970f30ab6
--- /dev/null
+++ b/libraries/coeurl/README
@@ -0,0 +1,3 @@
+coeurl is an asynchronous C++ wrapper for libcurl
+
+It is one of the nheko dependencies.
diff --git a/libraries/coeurl/coeurl.SlackBuild b/libraries/coeurl/coeurl.SlackBuild
new file mode 100644
index 0000000000..add9a98f58
--- /dev/null
+++ b/libraries/coeurl/coeurl.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/bash
+
+# Slackware build script for coeurl
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=coeurl
+VERSION=${VERSION:-0.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-v$VERSION
+tar xvf $CWD/$PRGNAM-v$VERSION.tar.gz
+cd $PRGNAM-v$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.md LICENSE docs \
+CMakeLists.txt README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/coeurl/coeurl.info b/libraries/coeurl/coeurl.info
new file mode 100644
index 0000000000..f15d4ca41b
--- /dev/null
+++ b/libraries/coeurl/coeurl.info
@@ -0,0 +1,10 @@
+PRGNAM="coeurl"
+VERSION="0.3.0"
+HOMEPAGE="https://nheko.im/Nheko-Reborn/coeurl/"
+DOWNLOAD="https://nheko.im/nheko-reborn/coeurl/-/archive/v0.3.0/coeurl-v0.3.0.tar.gz"
+MD5SUM="4b36d70d0f21d8bf8ae89db60784502e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="spdlog"
+MAINTAINER="Lockywolf"
+EMAIL="for_coeurl.2023-10-18@lockywolf.net"
diff --git a/libraries/coeurl/slack-desc b/libraries/coeurl/slack-desc
new file mode 100644
index 0000000000..6368e28c45
--- /dev/null
+++ b/libraries/coeurl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+coeurl: coeurl (curl wrappers for C++)
+coeurl:
+coeurl: Simple library to do http requests asynchronously via CURL in C++.
+coeurl: (Eventually as coroutines, once all the compilers I need to support
+coeurl: support them.) This is based on the CURL-libevent example.
+coeurl:
+coeurl:
+coeurl:
+coeurl:
+coeurl:
+coeurl: