summaryrefslogtreecommitdiffstats
path: root/libraries/hptt
diff options
context:
space:
mode:
author William PC <w_calandrini[at]hotmail[dot]com>2022-11-28 12:13:07 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-11-28 12:13:07 +0700
commitb14de6a5e0ec9b0ec47fe520dcd3b0937ecf3165 (patch)
treead83bcdf07f789338d2703414aac4363f5a8b7a0 /libraries/hptt
parent88a94a37ebb012688cc5b09b4b8b32045525740f (diff)
downloadslackbuilds-b14de6a5e0ec9b0ec47fe520dcd3b0937ecf3165.tar.gz
slackbuilds-b14de6a5e0ec9b0ec47fe520dcd3b0937ecf3165.tar.xz
libraries/hptt: Added (C++ Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/hptt')
-rw-r--r--libraries/hptt/README19
-rw-r--r--libraries/hptt/hptt.SlackBuild134
-rw-r--r--libraries/hptt/hptt.info10
-rw-r--r--libraries/hptt/slack-desc19
4 files changed, 182 insertions, 0 deletions
diff --git a/libraries/hptt/README b/libraries/hptt/README
new file mode 100644
index 0000000000..73d27e3b2e
--- /dev/null
+++ b/libraries/hptt/README
@@ -0,0 +1,19 @@
+ HPTT is a high-performance C++ library for out-of-place tensor
+transpositions.
+
+ Key features:
+
+ - Multi-threading support
+ - Explicit vectorization
+ - Auto-tuning (akin to FFTW)
+ - Loop order
+ - Parallelization
+ - Multi architecture support
+ - Explicitly vectorized kernels for (AVX and ARM)
+ - Supports float, double, complex and double complex data types
+ - Supports both column-major and row-major data layouts
+
+
+ By default it builds a scalar version, if you want to change it.
+Set the environment variable to AVX=yes or ARM=yes (arm only).
+ If you want to install the Python API set PYTHON=yes.
diff --git a/libraries/hptt/hptt.SlackBuild b/libraries/hptt/hptt.SlackBuild
new file mode 100644
index 0000000000..9429570227
--- /dev/null
+++ b/libraries/hptt/hptt.SlackBuild
@@ -0,0 +1,134 @@
+#!/bin/bash
+
+# Slackware build script for hptt
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=hptt
+VERSION=${VERSION:-1.0.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ ${AVX:-no} == "yes" ]; then
+ OPT="avx"
+fi
+
+if [ ${ARM:-no} == "yes" ]; then
+ OPT="arm"
+fi
+
+# fix using declared flags
+sed -i '1s#=#?=#' Makefile
+
+# fix deprecated mcpu flag
+sed -i 's/-mcpu=native//' Makefile
+
+# disable static lib
+sed -i '16s#lib/libhptt.a##' Makefile
+
+CFLAGS="$SLKCFLAGS" \
+CXX_FLAGS="$SLKCFLAGS" \
+make $OPT
+make doc; cd doc/latex; make; cd -
+
+if [ ${PYTHON:-no} == "yes" ]; then
+ cd pythonAPI
+ python2 setup.py install --root=$PKG
+ cd -
+fi
+
+install -d $PKG/usr/lib${LIBDIRSUFFIX}
+install -m 0755 lib/libhptt.so $PKG/usr/lib${LIBDIRSUFFIX}
+
+install -d $PKG/usr/include/$PRGNAM
+install -m 0644 include/* $PKG/usr/include/$PRGNAM
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt README.md doc/html doc/latex/refman.pdf \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/hptt/hptt.info b/libraries/hptt/hptt.info
new file mode 100644
index 0000000000..fbdf01c4be
--- /dev/null
+++ b/libraries/hptt/hptt.info
@@ -0,0 +1,10 @@
+PRGNAM="hptt"
+VERSION="1.0.5"
+HOMEPAGE="https://github.com/springer13/hptt"
+DOWNLOAD="https://github.com/springer13/hptt/archive/v1.0.5/hptt-1.0.5.tar.gz"
+MD5SUM="39395950bef9cc4cba90a6ebd8bc46dc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/libraries/hptt/slack-desc b/libraries/hptt/slack-desc
new file mode 100644
index 0000000000..3f29208f05
--- /dev/null
+++ b/libraries/hptt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hptt: hptt (C++ library for out-of-place-tensor transpositions)
+hptt:
+hptt:
+hptt:
+hptt: HPTT is a high-performance C++ library for out-of-place tensor
+hptt: transpositions.
+hptt:
+hptt:
+hptt:
+hptt:
+hptt: