summaryrefslogtreecommitdiffstats
path: root/libraries/lunasvg
diff options
context:
space:
mode:
author William PC <w_calandrini[at]hotmail[dot]com>2022-10-18 20:53:53 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-18 20:53:53 +0700
commit6add1e3cf427dd5b6caaf4693a0b759dd05e7fe9 (patch)
treecd7f3f5c2a7a97e882d0229bcf4a210457265567 /libraries/lunasvg
parent086f66bbdb96fa1dc3c7081358b439b7889763d5 (diff)
downloadslackbuilds-6add1e3cf427dd5b6caaf4693a0b759dd05e7fe9.tar.gz
slackbuilds-6add1e3cf427dd5b6caaf4693a0b759dd05e7fe9.tar.xz
libraries/lunasvg: Added (SVG rendering library in C++).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/lunasvg')
-rw-r--r--libraries/lunasvg/README1
-rw-r--r--libraries/lunasvg/lunasvg.SlackBuild125
-rw-r--r--libraries/lunasvg/lunasvg.info10
-rw-r--r--libraries/lunasvg/slack-desc19
4 files changed, 155 insertions, 0 deletions
diff --git a/libraries/lunasvg/README b/libraries/lunasvg/README
new file mode 100644
index 0000000000..aa06aa3995
--- /dev/null
+++ b/libraries/lunasvg/README
@@ -0,0 +1 @@
+ LunaSVG - SVG rendering library in C++
diff --git a/libraries/lunasvg/lunasvg.SlackBuild b/libraries/lunasvg/lunasvg.SlackBuild
new file mode 100644
index 0000000000..f456285c9a
--- /dev/null
+++ b/libraries/lunasvg/lunasvg.SlackBuild
@@ -0,0 +1,125 @@
+#!/bin/bash
+
+# Slackware build script for lunasvg
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=lunasvg
+VERSION=${VERSION:-2.3.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+if [ "${ARM:-no}" == "yes" ]; then
+ GEM5_CONFIG="ARM"
+fi
+
+# fix lib installation path
+sed -i 's#${CMAKE_INSTALL_PREFIX}/lib#&'${LIBDIRSUFFIX}'#' CMakeLists.txt
+
+rm -fr build
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLUNASVG_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ -DBUILD_SHARED_LIBS=ON \
+ $OPT_BUILD \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+# install example
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -a example $PKG/usr/share/$PRGNAM-$VERSION
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE luna.png \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/lunasvg/lunasvg.info b/libraries/lunasvg/lunasvg.info
new file mode 100644
index 0000000000..acba142935
--- /dev/null
+++ b/libraries/lunasvg/lunasvg.info
@@ -0,0 +1,10 @@
+PRGNAM="lunasvg"
+VERSION="2.3.4"
+HOMEPAGE="https://github.com/sammycage/lunasvg"
+DOWNLOAD="https://github.com/sammycage/lunasvg/archive/v2.3.4/lunasvg-2.3.4.tar.gz"
+MD5SUM="45c670235f9b520e5b9bad57024005a4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/libraries/lunasvg/slack-desc b/libraries/lunasvg/slack-desc
new file mode 100644
index 0000000000..dac439945f
--- /dev/null
+++ b/libraries/lunasvg/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lunasvg: lunasvg (LunaSVG - SVG rendering library in C++)
+lunasvg:
+lunasvg:
+lunasvg:
+lunasvg:
+lunasvg: LunaSVG - SVG rendering library in C++
+lunasvg:
+lunasvg:
+lunasvg:
+lunasvg:
+lunasvg: