summaryrefslogtreecommitdiffstats
path: root/libraries/msgpack-c/msgpack-c.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2016-06-25 17:27:16 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-06-27 07:54:38 +0700
commitd03a0469285ab992385b5ae92366cc2cf7488fbe (patch)
treea215ef54a029f288512d0420462987abd33dfd0b /libraries/msgpack-c/msgpack-c.SlackBuild
parent112a3b31cbf694a575a9a435dbaa871901cac62a (diff)
downloadslackbuilds-d03a0469285ab992385b5ae92366cc2cf7488fbe.tar.gz
slackbuilds-d03a0469285ab992385b5ae92366cc2cf7488fbe.tar.xz
libraries/msgpack-c: Updated for version 2.0.0.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'libraries/msgpack-c/msgpack-c.SlackBuild')
-rw-r--r--libraries/msgpack-c/msgpack-c.SlackBuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/libraries/msgpack-c/msgpack-c.SlackBuild b/libraries/msgpack-c/msgpack-c.SlackBuild
index 7fa63bd68d..c655e84b3d 100644
--- a/libraries/msgpack-c/msgpack-c.SlackBuild
+++ b/libraries/msgpack-c/msgpack-c.SlackBuild
@@ -24,7 +24,7 @@
SRCNAM=msgpack
PRGNAM=$SRCNAM-c
-VERSION=${VERSION:-1.4.2}
+VERSION=${VERSION:-2.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,13 +70,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --enable-static=no \
- --build=$ARCH-slackware-linux
+# this fixes install and msgpack.pc
+sed -i "s/\/lib/\/lib${LIBDIRSUFFIX}/" CMakeLists.txt
+
+cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} .
make
make install DESTDIR=$PKG