summaryrefslogtreecommitdiffstats
path: root/libraries/portsmf
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2022-10-19 08:32:28 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-10-20 23:32:11 +0700
commitf14514794e910a2b38c684da5400fa29a59b03e8 (patch)
tree3a90bbfe5a8ac6ca6a8bef8fe3da0479038632f1 /libraries/portsmf
parent8a0b6ede2b8b799506cd288e1bdb4973870dc43d (diff)
downloadslackbuilds-f14514794e910a2b38c684da5400fa29a59b03e8.tar.gz
slackbuilds-f14514794e910a2b38c684da5400fa29a59b03e8.tar.xz
libraries/portsmf: Added (lib to read/write Standard MIDI Files)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/portsmf')
-rw-r--r--libraries/portsmf/README8
-rw-r--r--libraries/portsmf/portsmf.SlackBuild119
-rw-r--r--libraries/portsmf/portsmf.info10
-rw-r--r--libraries/portsmf/portsmf_sharedlib.patch35
-rw-r--r--libraries/portsmf/slack-desc19
5 files changed, 191 insertions, 0 deletions
diff --git a/libraries/portsmf/README b/libraries/portsmf/README
new file mode 100644
index 0000000000..b712fe59e1
--- /dev/null
+++ b/libraries/portsmf/README
@@ -0,0 +1,8 @@
+Portsmf is Port Standard MIDI File, a cross-platform, C++ library for
+reading and writing Standard MIDI Files.
+
+Features:
+- input and output of Standard MIDI Files
+- input and output of a text-based representation: Allegro files
+- extensive editing operations on sequences and tracks
+- conversion to/from binary buffers for archiving, undo/redo, etc.
diff --git a/libraries/portsmf/portsmf.SlackBuild b/libraries/portsmf/portsmf.SlackBuild
new file mode 100644
index 0000000000..154911f675
--- /dev/null
+++ b/libraries/portsmf/portsmf.SlackBuild
@@ -0,0 +1,119 @@
+#!/bin/bash
+
+# Slackware build script for portsmf
+
+# Copyright 2022 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Many thanks to Alien BOB for all the hints!
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=portsmf
+VERSION=${VERSION:-234} # audacity needs this specific version!
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="README.txt changelog.txt license.txt"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/portsmf_sharedlib.patch
+
+autoreconf -vif
+chmod 755 configure
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+make
+make DESTDIR=$PKG includedir=/usr/include/$PRGNAM install
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig
+echo "prefix=/usr" > $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/portSMF.pc
+cat portSMF.pc >> $PKG/usr/lib$LIBDIRSUFFIX/pkgconfig/portSMF.pc
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/portsmf/portsmf.info b/libraries/portsmf/portsmf.info
new file mode 100644
index 0000000000..1e623321ce
--- /dev/null
+++ b/libraries/portsmf/portsmf.info
@@ -0,0 +1,10 @@
+PRGNAM="portsmf"
+VERSION="234"
+HOMEPAGE="https://github.com/tenacityteam/portsmf"
+DOWNLOAD="https://ponce.cc/slackware/sources/repo/portsmf-234.tar.gz"
+MD5SUM="e29156983e62ed27a459855eb91f47e8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/libraries/portsmf/portsmf_sharedlib.patch b/libraries/portsmf/portsmf_sharedlib.patch
new file mode 100644
index 0000000000..90815a4efb
--- /dev/null
+++ b/libraries/portsmf/portsmf_sharedlib.patch
@@ -0,0 +1,35 @@
+--- portsmf/configure.ac.orig 2013-06-22 20:54:59.000000000 +0200
++++ portsmf/configure.ac 2013-06-22 21:52:25.212040115 +0200
+@@ -23,7 +23,7 @@
+ dnl keep autools files in a subdirectory
+ AC_CONFIG_AUX_DIR(autotools)
+ # which also contains a subdir containing macros
+-AC_CONFIG_MACRO_DIR([autotools/m4])
++dnl AC_CONFIG_MACRO_DIR([autotools/m4])
+ dnl set up automake
+ AM_INIT_AUTOMAKE([-Wall foreign])
+ dnl Audacity policy: don't enable automatic rebuild of configure et al if
+@@ -49,7 +49,7 @@
+ dnl we will need an "install" program to be available
+ AC_PROG_INSTALL
+ dnl and ranlib for static libraries
+-AC_PROG_RANLIB
++AC_PROG_LIBTOOL
+
+ dnl Make the install prefix available to the program so that the pkg-config file
+ dnl can be created correctly
+--- portsmf/Makefile.am.orig 2013-06-22 20:55:00.000000000 +0200
++++ portsmf/Makefile.am 2013-06-22 21:52:52.898705781 +0200
+@@ -6,10 +6,10 @@
+ ACLOCAL_AMFLAGS = -I autotools/m4
+
+ # define the output library (link with -lportSMF)
+-lib_LIBRARIES = libportSMF.a
++lib_LTLIBRARIES = libportSMF.la
+
+ # define the source files to use
+-libportSMF_a_SOURCES = allegro.cpp \
++libportSMF_la_SOURCES = allegro.cpp \
+ allegrosmfwr.cpp \
+ allegrord.cpp \
+ allegrowr.cpp \
diff --git a/libraries/portsmf/slack-desc b/libraries/portsmf/slack-desc
new file mode 100644
index 0000000000..9b292edcee
--- /dev/null
+++ b/libraries/portsmf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+portsmf: portsmf (library for reading and writing Standard MIDI Files)
+portsmf:
+portsmf: Portsmf is Port Standard MIDI File, a cross-platform, C++ library for
+portsmf: reading and writing Standard MIDI Files.
+portsmf: Features:
+portsmf: - input and output of Standard MIDI Files
+portsmf: - input and output of a text-based representation: Allegro files
+portsmf: - extensive editing operations on sequences and tracks
+portsmf: - conversion to/from binary buffers for archiving, undo/redo, etc.
+portsmf:
+portsmf: Homepage: https://github.com/tenacityteam/portsmf