summaryrefslogtreecommitdiffstats
path: root/libraries/pyqode.core
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-03-09 00:52:38 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-03-12 12:42:48 -0500
commit83ccd986576a8f8dc10cf5494b7fe54509126aed (patch)
treee46572b79345d2204ad56ae88311c5928bf59ee4 /libraries/pyqode.core
parentfc796e86756f089859b8568020a6c13e964cb570 (diff)
downloadslackbuilds-83ccd986576a8f8dc10cf5494b7fe54509126aed.tar.gz
slackbuilds-83ccd986576a8f8dc10cf5494b7fe54509126aed.tar.xz
libraries/pyqode.core: Added (Python/Qt Code Editor widget).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/pyqode.core')
-rw-r--r--libraries/pyqode.core/README3
-rw-r--r--libraries/pyqode.core/pyqode.core.SlackBuild85
-rw-r--r--libraries/pyqode.core/pyqode.core.info10
-rw-r--r--libraries/pyqode.core/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/libraries/pyqode.core/README b/libraries/pyqode.core/README
new file mode 100644
index 0000000000..1d3bc7a82b
--- /dev/null
+++ b/libraries/pyqode.core/README
@@ -0,0 +1,3 @@
+pyQode is a flexible source code editor widget for
+Python Qt applications. pyQode is a library/widget,
+not an IDE.
diff --git a/libraries/pyqode.core/pyqode.core.SlackBuild b/libraries/pyqode.core/pyqode.core.SlackBuild
new file mode 100644
index 0000000000..9a1ef686ca
--- /dev/null
+++ b/libraries/pyqode.core/pyqode.core.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for pyqode.core
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pyqode.core
+VERSION=${VERSION:-1.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pyqode.core/pyqode.core.info b/libraries/pyqode.core/pyqode.core.info
new file mode 100644
index 0000000000..fb0860b5cc
--- /dev/null
+++ b/libraries/pyqode.core/pyqode.core.info
@@ -0,0 +1,10 @@
+PRGNAM="pyqode.core"
+VERSION="1.3.0"
+HOMEPAGE="https://github.com/pyQode/pyqode.core"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pyqode.core/pyqode.core-1.3.0.tar.gz"
+MD5SUM="65be60d7ff553f44a7105fdee2a07e69"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools Pygments"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/pyqode.core/slack-desc b/libraries/pyqode.core/slack-desc
new file mode 100644
index 0000000000..2c6c03ad2e
--- /dev/null
+++ b/libraries/pyqode.core/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pyqode.core: pyqode.core (Python/Qt Code Editor widget)
+pyqode.core:
+pyqode.core: pyQode is a flexible source code editor widget for
+pyqode.core: Python Qt applications. pyQode is a library/widget,
+pyqode.core: not an IDE.
+pyqode.core:
+pyqode.core: Homepage: https://github.com/pyQode/pyqode.core
+pyqode.core:
+pyqode.core:
+pyqode.core:
+pyqode.core: