summaryrefslogtreecommitdiffstats
path: root/libraries/stk
diff options
context:
space:
mode:
author Gabriel Magno <gabrielmagno1@gmail.com>2013-10-27 15:27:16 +0100
committer Matteo Bernardini <ponce@slackbuilds.org>2013-10-27 20:54:01 +0100
commit14e780f2a84f5ec752161585ccd780fd4b72e5a4 (patch)
tree614e339096f1c41e6d1dc1433f9d6d1d194cdfb1 /libraries/stk
parent05d26f558bc584df634ace8e80e3b8fa17500b2a (diff)
downloadslackbuilds-14e780f2a84f5ec752161585ccd780fd4b72e5a4.tar.gz
slackbuilds-14e780f2a84f5ec752161585ccd780fd4b72e5a4.tar.xz
libraries/stk: Added (audio processing library).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/stk')
-rw-r--r--libraries/stk/README22
-rw-r--r--libraries/stk/slack-desc19
-rw-r--r--libraries/stk/stk.SlackBuild122
-rw-r--r--libraries/stk/stk.info10
4 files changed, 173 insertions, 0 deletions
diff --git a/libraries/stk/README b/libraries/stk/README
new file mode 100644
index 0000000000..0bc1bf34a6
--- /dev/null
+++ b/libraries/stk/README
@@ -0,0 +1,22 @@
+The Synthesis ToolKit in C++ (STK) is a set of open source audio
+signal processing and algorithmic synthesis classes written in the
+C++ programming language. STK was designed to facilitate rapid
+development of music synthesis and audio processing software, with
+an emphasis on cross-platform functionality, realtime control,
+ease of use, and educational example code.
+
+Optional dependencies:
+* oss, for OSS audio API support
+* jack-audio-connection-kit, for JACK audio API support
+
+Build Options:
+
+STK has 3 audio APIs to choose from, that you can control
+passing the AUDIOAPI variable value to the slackbuild.
+
+AUDIOAPI=alsa (default, choose native ALSA API support)
+
+AUDIOAPI=oss (choose native OSS API support, requires oss)
+
+AUDIOAPI=jack (choose native JACK server API support,
+ requires jack-audio-connection-kit)
diff --git a/libraries/stk/slack-desc b/libraries/stk/slack-desc
new file mode 100644
index 0000000000..e83705f199
--- /dev/null
+++ b/libraries/stk/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+stk: STK (The Synthesis ToolKit in C++)
+stk:
+stk: The Synthesis ToolKit in C++ (STK) is a set of open source audio
+stk: signal processing and algorithmic synthesis classes written in the
+stk: C++ programming language. STK was designed to facilitate rapid
+stk: development of music synthesis and audio processing software, with
+stk: an emphasis on cross-platform functionality, realtime control,
+stk: ease of use, and educational example code.
+stk:
+stk: https://ccrma.stanford.edu/software/stk/
+stk:
diff --git a/libraries/stk/stk.SlackBuild b/libraries/stk/stk.SlackBuild
new file mode 100644
index 0000000000..040da301df
--- /dev/null
+++ b/libraries/stk/stk.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/sh
+
+# Slackware build script for STK
+
+# Copyright 2013 Gabriel Magno, Belo Horizonte, MG, Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=stk
+VERSION=${VERSION:-4.4.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Determine which audio API to use.
+# Possible values for PROFILE: alsa, oss, jack.
+AUDIOAPI=${AUDIOAPI:-alsa}
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --with-${AUDIOAPI} \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+# Compile only the library files (both static and dynamic)
+# Seems our flags are ignored
+sed -i "s|-O3|$SLKCFLAGS|" src/Makefile
+cd src
+make libstk.a
+make libstk.so
+
+# The Makefile does not provide an install option, so we have to manually copy files
+mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
+mkdir -p $PKG/usr/include/$PRGNAM
+mkdir -p $PKG/usr/share/$PRGNAM/tools
+cp -a libstk.* $PKG/usr/lib${LIBDIRSUFFIX}/
+cp -a ../include/* $PKG/usr/include/$PRGNAM/
+cp -a ../rawwaves $PKG/usr/share/$PRGNAM
+cp -a ../bin/treesed $PKG/usr/share/$PRGNAM/tools/
+cd -
+
+# Add a missing link
+( cd $PKG/usr/lib${LIBDIRSUFFIX} ; ln -s libstk.so.4.4.4 libstk.so.4 )
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ INSTALL README doc/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+find $PKG/usr/doc/$PRGNAM-$VERSION -iname "README-*.txt" -not -iname "*Linux*" -exec rm -f {} \;
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/stk/stk.info b/libraries/stk/stk.info
new file mode 100644
index 0000000000..7958245244
--- /dev/null
+++ b/libraries/stk/stk.info
@@ -0,0 +1,10 @@
+PRGNAM="stk"
+VERSION="4.4.4"
+HOMEPAGE="https://ccrma.stanford.edu/software/stk/"
+DOWNLOAD="http://ccrma.stanford.edu/software/stk/release/stk-4.4.4.tar.gz"
+MD5SUM="66646cb1117eee2d767c4571cc51a8c3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Gabriel Magno"
+EMAIL="gabrielmagno1@gmail.com"