summaryrefslogtreecommitdiffstats
path: root/multimedia/gaupol
diff options
context:
space:
mode:
author Andre Barboza <bmg.andre@gmail.com>2010-05-13 00:59:39 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:59:39 +0200
commit205e20254b6f55c3adfdbfb6a449bdc66ae93405 (patch)
tree145c7d3dfc1c748ddd4f287534ad6e3ab03fc990 /multimedia/gaupol
parentcc40d6c1874f288866d0a905f9817761df751704 (diff)
downloadslackbuilds-205e20254b6f55c3adfdbfb6a449bdc66ae93405.tar.gz
slackbuilds-205e20254b6f55c3adfdbfb6a449bdc66ae93405.tar.xz
multimedia/gaupol: Added to 13.0 repository
Diffstat (limited to 'multimedia/gaupol')
-rw-r--r--multimedia/gaupol/README28
-rw-r--r--multimedia/gaupol/doinst.sh15
-rw-r--r--multimedia/gaupol/gaupol.SlackBuild54
-rw-r--r--multimedia/gaupol/gaupol.info10
-rw-r--r--multimedia/gaupol/slack-desc19
5 files changed, 126 insertions, 0 deletions
diff --git a/multimedia/gaupol/README b/multimedia/gaupol/README
new file mode 100644
index 0000000000..da4b20a7dd
--- /dev/null
+++ b/multimedia/gaupol/README
@@ -0,0 +1,28 @@
+Gaupol is an editor for text-based subtitle files. It supports multiple
+subtitle file formats and provides means of correcting texts and timing
+subtitles to match video. The user interface is designed with attention
+to batch processing of multiple documents and convenience of translating.
+
+Gaupol should run on all Unix-like (GNU/Linux, *BSD, etc.) operating systems
+and on Windows. Technically, it should run on Mac as well, but that has not
+been tested nor made convenient. Gaupol's user interface is based on the
+GTK+ toolkit and has been designed to best fit the GNOME desktop environment.
+
+Dependencies
+
+- Gaupol requires Python 2.5.1 or greater and PyGTK 2.12 or greater.
+
+Other dependencies (not required)
+
+- PyEnchant 1.1.3 or greater is required for spell-checking.
+ Additionally, spell-checking requires a dictionary, any of Aspell/Pspell,
+ Ispell, MySpell, Uspell, Hspell or AppleSpell.
+
+- iso-codes, if available, will be used to translate script, language and
+ country names.
+
+- Universal Encoding Detector is required for character encoding
+ auto-detection. (chardet)
+
+- MPlayer or VLC is recommended for preview.
+
diff --git a/multimedia/gaupol/doinst.sh b/multimedia/gaupol/doinst.sh
new file mode 100644
index 0000000000..af1140d7d8
--- /dev/null
+++ b/multimedia/gaupol/doinst.sh
@@ -0,0 +1,15 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
+
diff --git a/multimedia/gaupol/gaupol.SlackBuild b/multimedia/gaupol/gaupol.SlackBuild
new file mode 100644
index 0000000000..a8ba0ab52a
--- /dev/null
+++ b/multimedia/gaupol/gaupol.SlackBuild
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+# Slackware build script for gaupol
+
+# Written by Andre Barboza <bmg.andre@gmail.com>
+
+PRGNAM=gaupol
+VERSION=${VERSION:-0.15}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+mkdir -p $PKG/usr
+python setup.py clean install --prefix=/usr --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING CREDITS INSTALL NEWS PKG-INFO README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+
diff --git a/multimedia/gaupol/gaupol.info b/multimedia/gaupol/gaupol.info
new file mode 100644
index 0000000000..1c75b863a7
--- /dev/null
+++ b/multimedia/gaupol/gaupol.info
@@ -0,0 +1,10 @@
+PRGNAM="gaupol"
+VERSION="0.15"
+HOMEPAGE="http://home.gna.org/gaupol/"
+DOWNLOAD="http://download.gna.org/gaupol/0.15/gaupol-0.15.tar.gz"
+MD5SUM="af9c6d248e5ba8e4c0459243eccea4c3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Andre Barboza"
+EMAIL="bmg.andre@gmail.com"
+APPROVED="dsomero"
diff --git a/multimedia/gaupol/slack-desc b/multimedia/gaupol/slack-desc
new file mode 100644
index 0000000000..29c26b4768
--- /dev/null
+++ b/multimedia/gaupol/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+gaupol: gaupol (Subtitle Editor)
+gaupol:
+gaupol: Gaupol is an editor for text-based subtitle files. It supports
+gaupol: multiple subtitle file formats and provides means of correcting
+gaupol: texts and timing subtitles to match video. The user interface is
+gaupol: designed with attention to batch processing of multiple documents
+gaupol: and convenience of translating.
+gaupol:
+gaupol:
+gaupol: Homepage: http://home.gna.org/gaupol/
+gaupol: