summaryrefslogtreecommitdiffstats
path: root/multimedia/vobcopy/vobcopy.SlackBuild
diff options
context:
space:
mode:
author Nishant Limbachia <nishant@mnspace.net>2010-05-13 00:35:17 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-13 00:35:17 +0200
commit3cacf179daafbf0eaaa0bbd88952419e222545e6 (patch)
treed08c6bd2489e515062f10da4d4dfaebf2d13f9a8 /multimedia/vobcopy/vobcopy.SlackBuild
parent91dc3878c866156989fe69017e164d8a32b938d5 (diff)
downloadslackbuilds-3cacf179daafbf0eaaa0bbd88952419e222545e6.tar.gz
slackbuilds-3cacf179daafbf0eaaa0bbd88952419e222545e6.tar.xz
multimedia/vobcopy: Updated for version 1.2.0
Diffstat (limited to 'multimedia/vobcopy/vobcopy.SlackBuild')
-rw-r--r--multimedia/vobcopy/vobcopy.SlackBuild61
1 files changed, 34 insertions, 27 deletions
diff --git a/multimedia/vobcopy/vobcopy.SlackBuild b/multimedia/vobcopy/vobcopy.SlackBuild
index c4534d39e9..6dbc5f4b68 100644
--- a/multimedia/vobcopy/vobcopy.SlackBuild
+++ b/multimedia/vobcopy/vobcopy.SlackBuild
@@ -1,17 +1,17 @@
#!/bin/sh
# Slackware Package Build Script for vobcopy
-# Home Page http://vobcopy.org
+# Home Page http://vobcopy.org/
-# Copyright (c) 2007, Nishant Limbachia (nishant@mnspace.net)
+# Copyright (c) 2007-2009, Nishant Limbachia, Hoffman Est, IL, USA (nishant@mnspace.net)
# All rights reserved.
-#
+
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
-#
+
# 1. Redistributions of script must retain the above copyright notice,
# this list of conditions and the following disclaimer.
-#
+
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
@@ -25,7 +25,7 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=vobcopy
-VERSION=1.1.2
+VERSION=1.2.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -35,52 +35,59 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
CWD=$(pwd)
+set -e
+
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
-set -e
-
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $TMP/$PRGNAM-$VERSION
chown -R root.root .
find . \
- \( -perm 664 -o -perm 666 -o -perm 600 -o -perm 440 -o -perm 444 -o -perm 400 \) \
- -exec chmod 644 {} \;
-find . \
- \( -perm 777 -o -perm 755 -o -perm 711 -o -perm 700 -o -perm 555 -o -perm 511 -o -perm 500 \) \
- -exec chmod 755 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+### patch makefile
+patch -p0 < $CWD/Makefile.patch
-CFLAGS="$SLKCFLAGS" make
-mkdir -p $PKG/usr/{bin,include,man/man1}
+### update Makefile
+sed -i "s|@VERSION@|$VERSION|" Makefile
+sed -i "s|@LIBDIRSUFFIX@|$LIBDIRSUFFIX|" Makefile
-install --strip -m 0755 vobcopy $PKG/usr/bin
-install -m 0644 vobcopy.1 $PKG/usr/man/man1
-install -m 0644 vobcopy.h dvd.h $PKG/usr/include
+### make and install
+CFLAGS=${SLKCFLAGS} make
+make install DESTDIR=$PKG
+### strip binary
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING Changelog README Release-Notes TODO alternative_programs.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-
-( cd $PKG/usr/man || exit 1
+( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}