summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Diniz Bortolotto <diniz.bortolotto@gmail.com>2024-03-16 02:41:03 -0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-16 18:25:34 +0700
commit07ea4d14f043874a97de0d011b50240ace62737d (patch)
tree1aecb9f4fb462d5777bf09404aca1b423b6517d3 /multimedia
parentf2fd02d810ccafdcb54cd1ce380341a85bbefd77 (diff)
downloadslackbuilds-07ea4d14f043874a97de0d011b50240ace62737d.tar.gz
slackbuilds-07ea4d14f043874a97de0d011b50240ace62737d.tar.xz
multimedia/podcastparser: move to libraries.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/podcastparser/README3
-rw-r--r--multimedia/podcastparser/podcastparser.SlackBuild82
-rw-r--r--multimedia/podcastparser/podcastparser.info10
-rw-r--r--multimedia/podcastparser/slack-desc19
4 files changed, 0 insertions, 114 deletions
diff --git a/multimedia/podcastparser/README b/multimedia/podcastparser/README
deleted file mode 100644
index fd76078450..0000000000
--- a/multimedia/podcastparser/README
+++ /dev/null
@@ -1,3 +0,0 @@
-The podcast parser project is a library from the gPodder
-project to provide an easy and reliable way of parsing
-RSS- and Atom-based podcast feeds in Python.
diff --git a/multimedia/podcastparser/podcastparser.SlackBuild b/multimedia/podcastparser/podcastparser.SlackBuild
deleted file mode 100644
index 0bb9681688..0000000000
--- a/multimedia/podcastparser/podcastparser.SlackBuild
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for podcastparser
-
-# Copyright 2024 Diniz Bortolotto <diniz.bortolotto@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=podcastparser
-VERSION=${VERSION:-0.6.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-sed -i 's/distutils.core/setuptools/' setup.py
-python3 setup.py build
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS LICENSE README.md doc/index.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/multimedia/podcastparser/podcastparser.info b/multimedia/podcastparser/podcastparser.info
deleted file mode 100644
index 0ef0cf8e09..0000000000
--- a/multimedia/podcastparser/podcastparser.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="podcastparser"
-VERSION="0.6.10"
-HOMEPAGE="https://github.com/gpodder/podcastparser"
-DOWNLOAD="https://github.com/gpodder/podcastparser/archive/0.6.10/podcastparser-0.6.10.tar.gz"
-MD5SUM="57093c181a1c7198ffcb8bcd8fb558a5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Diniz Bortolotto"
-EMAIL="diniz.bortolotto@gmail.com"
diff --git a/multimedia/podcastparser/slack-desc b/multimedia/podcastparser/slack-desc
deleted file mode 100644
index 41cef377c0..0000000000
--- a/multimedia/podcastparser/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-podcastparser: podcastparser (Python RSS and Atom feed parser)
-podcastparser:
-podcastparser: The podcast parser project is a library from the gPodder project
-podcastparser: to provide an easy and reliable way of parsing RSS- and Atom-based
-podcastparser: podcast feeds in Python.
-podcastparser:
-podcastparser:
-podcastparser: Homepage: https://github.com/gpodder/podcastparser
-podcastparser:
-podcastparser:
-podcastparser: