summaryrefslogtreecommitdiffstats
path: root/network/chromium/chromium.SlackBuild
diff options
context:
space:
mode:
author Francisco Ambrozio <francisco.ambrozio@gmail.com>2012-05-29 17:38:11 -0400
committer Erik Hanson <erik@slackbuilds.org>2012-06-03 15:21:09 -0500
commit7da788d25d962215ba039a861433e2d2a9efe66d (patch)
tree88eb4263e6dfaa9e105fc0f7fc85f86dd3c62ae9 /network/chromium/chromium.SlackBuild
parent5f13cf75a8f2f695ee6d1a28115d0a6f14f690ea (diff)
downloadslackbuilds-7da788d25d962215ba039a861433e2d2a9efe66d.tar.gz
slackbuilds-7da788d25d962215ba039a861433e2d2a9efe66d.tar.xz
network/chromium: Updated for version 19.0.1084.52.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'network/chromium/chromium.SlackBuild')
-rw-r--r--network/chromium/chromium.SlackBuild60
1 files changed, 23 insertions, 37 deletions
diff --git a/network/chromium/chromium.SlackBuild b/network/chromium/chromium.SlackBuild
index b8d9542a34..28dd4634f0 100644
--- a/network/chromium/chromium.SlackBuild
+++ b/network/chromium/chromium.SlackBuild
@@ -2,17 +2,6 @@
# Slackware build script for Google Chromium
#
-# This is script was inspired on the one used by Arch:
-# (http://repos.archlinux.org/wsvn/packages/chromium/trunk/PKGBUILD)
-#
-# A special thanks to Niels Horn who helped me fixing some errors on
-# the script and for testing it.
-#
-# A very special thanks to Gino Bombino (ginolovesyou AT gmail DOT com), who
-# contributed with the parameters to disable the need for gnome dependencies
-# and PAM, allowing the script to be cleaner and more elegant (no need for a
-# a patch to disable PAM).
-#
# Copyright 2010 Yucatan "Kenjiro" Costa, Alegrete, RS, Brasil
# Copyright 2012 Francisco Ambrozio <francisco.ambrozio@gmail.com>
# All rights reserved.
@@ -35,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=chromium
-VERSION=${VERSION:-18.0.1025.142}
+VERSION=${VERSION:-19.0.1084.52}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,8 +59,8 @@ elif [ "$ARCH" = "x86_64" ]; then
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
- DTARGETARCH=""
- DDSSE=""
+ DTARGETARCH=" -Dtarget_arch=ia32 "
+ DDSSE=" -Ddisable_sse2=1 "
fi
set -e
@@ -80,7 +69,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -90,38 +79,37 @@ find . \
-exec chmod 644 {} \;
# Change "-Dproprietary_codecs" to "0" if you don't want to use proprietary codecs
+
+SLKCFLAGS="${SLKCFLAGS} -fno-ipa-cp"
+export -n CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
build/gyp_chromium -f make build/all.gyp --depth=. \
$DTARGETARCH \
- -Dgcc_version=45 \
- -Duse_gconf=0 \
- -Duse_gnome_keyring=0 \
- -Dlinux_link_gnome_keyring=0 \
- -Dremove_webcore_debug_symbols=1 \
- -Dremoting=0 \
- -Dchromeos=0 \
- -Dwerror=0 \
- -Dno_strict_aliasing=1 \
-Dwerror= \
+ -Dlinux_link_gnome_keyring=0 \
-Dlinux_sandbox_path=/usr/lib${LIBDIRSUFFIX}/chromium/chrome_sandbox \
-Dlinux_strip_binary=1 \
+ -Dlinux_use_gold_binary=0 \
+ -Dlinux_use_gold_flags=0 \
+ -Dno_strict_aliasing=1 \
+ -Dffmpeg_branding=Chrome \
-Dproprietary_codecs=1 \
+ -Duse_gconf=0 \
+ -Duse_gnome_keyring=0 \
+ -Duse_kerberos=0 \
+ -Duse_system_bzip2=1 \
+ -Duse_system_ffmpeg=0 \
+ -Duse_system_libevent=1 \
+ -Duse_system_libpng=0 \
-Duse_system_libjpeg=1 \
-Duse_system_libxslt=1 \
-Duse_system_libxml=1 \
- -Duse_system_bzip2=1 \
+ -Duse_system_ssl=0 \
-Duse_system_zlib=1 \
- -Duse_system_libpng=0 \
-Duse_system_yasm=1 \
- -Duse_system_libevent=1 \
- -Dffmpeg_branding=Chrome \
- -Duse_system_ffmpeg=0 \
- $DDSSE \
-Ddisable_nacl=1 \
- -Duse_kerberos=0 \
- -Duse_system_ssl=0
+ -Drelease_extra_cflags="$CFLAGS" \
+ $DDSSE
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS -fno-ipa-cp" \
make chrome chrome_sandbox BUILDTYPE=Release V=1
# Creating the package
@@ -146,9 +134,7 @@ cd out/Release/
cd ../../
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a AUTHORS LICENSE $PKG/usr/doc/$PRGNAM-$VERSION/ || true
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true