summaryrefslogtreecommitdiffstats
path: root/python/acstore
diff options
context:
space:
mode:
author Barry J. Grundy <bgrundy [AT] linuxleo.com>2023-08-05 08:49:09 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-08-05 08:49:09 +0700
commit41e390c149f41b8aa0d5eb064e3125743e4f13de (patch)
tree67bfce8bb10ca4d346518fca208271e2b24be74f /python/acstore
parent67bcd307a91b1f54eea9f7673687936d5861d55a (diff)
downloadslackbuilds-41e390c149f41b8aa0d5eb064e3125743e4f13de.tar.gz
slackbuilds-41e390c149f41b8aa0d5eb064e3125743e4f13de.tar.xz
python/acstore: Added (Attribute Container storage writer/reader).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/acstore')
-rw-r--r--python/acstore/README5
-rw-r--r--python/acstore/acstore.SlackBuild81
-rw-r--r--python/acstore/acstore.info10
-rw-r--r--python/acstore/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/acstore/README b/python/acstore/README
new file mode 100644
index 0000000000..e73519793f
--- /dev/null
+++ b/python/acstore/README
@@ -0,0 +1,5 @@
+acstore - Attribute Container store reader and writer.
+
+ACStore, or Attribute Container Storage, provides a stand-alone
+implementation to read and write Attribute Container stores,
+such as Plaso storage files.
diff --git a/python/acstore/acstore.SlackBuild b/python/acstore/acstore.SlackBuild
new file mode 100644
index 0000000000..eb1b2a51da
--- /dev/null
+++ b/python/acstore/acstore.SlackBuild
@@ -0,0 +1,81 @@
+#!/bin/bash
+
+# Slackware build script for acstore
+# Copyright 2016-2023 Barry Grundy <bgrundy[at]linuxleo.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Initial Version 20230519, July 2023
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=acstore
+VERSION=${VERSION:-20230519}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
+\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+python3 setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -rf $PKG/usr/share/doc
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/acstore/acstore.info b/python/acstore/acstore.info
new file mode 100644
index 0000000000..dff09ae6c8
--- /dev/null
+++ b/python/acstore/acstore.info
@@ -0,0 +1,10 @@
+PRGNAM="acstore"
+VERSION="20230519"
+HOMEPAGE="https://github.com/log2timeline/acstore"
+DOWNLOAD="https://github.com/log2timeline/acstore/releases/download/20230519/acstore-20230519.tar.gz"
+MD5SUM="819991dd203848554678e8eb1881f9b9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Barry J. Grundy"
+EMAIL="bgrundy<at>linuxleo.com"
diff --git a/python/acstore/slack-desc b/python/acstore/slack-desc
new file mode 100644
index 0000000000..9602a03fb4
--- /dev/null
+++ b/python/acstore/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+acstore: acstore (Attribute Container storage writer/reader)
+acstore:
+acstore: ACStore, or Attribute Container Storage, provides a stand-alone
+acstore: implementation to read and write Attribute Container stores, such as
+acstore: Plaso storage files.
+acstore:
+acstore:
+acstore:
+acstore:
+acstore:
+acstore: