summaryrefslogtreecommitdiffstats
path: root/python/pycassa/pycassa.SlackBuild
diff options
context:
space:
mode:
author Nikolay Korotkiy <sikmir@gmail.com>2016-11-21 22:19:38 +0000
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2016-11-26 11:47:24 +0700
commit82ba59b6c9241d891a8cfd41777968f7c66dd712 (patch)
treee33ed5c6b76738e120cfb3eecdca1ce8558e10de /python/pycassa/pycassa.SlackBuild
parent23756590c2462dcef96d65d3377527f9c52efec8 (diff)
downloadslackbuilds-82ba59b6c9241d891a8cfd41777968f7c66dd712.tar.gz
slackbuilds-82ba59b6c9241d891a8cfd41777968f7c66dd712.tar.xz
python/pycassa: Updated for version 1.11.1.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/pycassa/pycassa.SlackBuild')
-rw-r--r--python/pycassa/pycassa.SlackBuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/python/pycassa/pycassa.SlackBuild b/python/pycassa/pycassa.SlackBuild
index ea09e4b3db..a1792b1d19 100644
--- a/python/pycassa/pycassa.SlackBuild
+++ b/python/pycassa/pycassa.SlackBuild
@@ -2,11 +2,12 @@
# Slackware build script for pycassa
-# Copyright 2012, Nikolay Korotkiy <sikmir@gmail.com>
+# Copyright 2012-2016, Nikolay Korotkiy <sikmir@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
+#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
@@ -22,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pycassa
-VERSION=${VERSION:-1.7.2}
+VERSION=${VERSION:-1.11.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -49,10 +50,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG