summaryrefslogtreecommitdiffstats
path: root/python/pynacl
diff options
context:
space:
mode:
author B. Watson <urchlay@slackware.uk>2023-05-15 21:58:52 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:39 +0700
commitb840dcf32d480fe85515812402978d3eb2c473c7 (patch)
treebebe34e940c9171bb07df273a0882bbd3b0ff20b /python/pynacl
parenta63ae0885cde6bc32542ac1c03a5edd27938d1d5 (diff)
downloadslackbuilds-b840dcf32d480fe85515812402978d3eb2c473c7.tar.gz
slackbuilds-b840dcf32d480fe85515812402978d3eb2c473c7.tar.xz
python/pynacl: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pynacl')
-rw-r--r--python/pynacl/pynacl.SlackBuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/python/pynacl/pynacl.SlackBuild b/python/pynacl/pynacl.SlackBuild
index 6736a2fc73..655f9bc0ca 100644
--- a/python/pynacl/pynacl.SlackBuild
+++ b/python/pynacl/pynacl.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,12 +65,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
- else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG