summaryrefslogtreecommitdiffstats
path: root/python/python-twisted/python-twisted.SlackBuild
diff options
context:
space:
mode:
author Marco Bonetti <sid77@slackware.it>2011-09-21 21:22:47 -0300
committer Niels Horn <niels.horn@slackbuilds.org>2011-09-21 21:22:47 -0300
commit55bc779b11113d2973cb3a39ad2ee364f100af6e (patch)
tree6457056ac8c8f2e2fb05bb4636cc6aa9cfd1094c /python/python-twisted/python-twisted.SlackBuild
parent2b8d1830ce2e0ac8eef83d1b9cad60a0362c0310 (diff)
downloadslackbuilds-55bc779b11113d2973cb3a39ad2ee364f100af6e.tar.gz
slackbuilds-55bc779b11113d2973cb3a39ad2ee364f100af6e.tar.xz
python/python-twisted: Updated for version 11.0.0.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'python/python-twisted/python-twisted.SlackBuild')
-rw-r--r--python/python-twisted/python-twisted.SlackBuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/python/python-twisted/python-twisted.SlackBuild b/python/python-twisted/python-twisted.SlackBuild
index 5e70ceeea6..3b1763df62 100644
--- a/python/python-twisted/python-twisted.SlackBuild
+++ b/python/python-twisted/python-twisted.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-twisted.
-# Copyright 2009 Marco Bonetti <sid77@slackware.it>
+# Copyright 2009-2011 Marco Bonetti <sid77@slackware.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,16 +24,14 @@
PRGNAM=python-twisted
SRCNAM=Twisted
-VERSION=${VERSION:-8.2.0}
+VERSION=${VERSION:-11.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -70,19 +68,13 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
+python setup.py build
-python setup.py install --root=$PKG || exit 1
+python setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/man
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc