summaryrefslogtreecommitdiffstats
path: root/python/python3-celery
diff options
context:
space:
mode:
author Arn0 <yth@ythogtha.org>2022-03-08 20:19:41 +0100
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:36:27 +0700
commit9a9964d19d161cf72df17316790e821f55056884 (patch)
tree1ddc1fe54fd85562934b459f2f291d33c5ba0b67 /python/python3-celery
parent9ce37db212d37691272b60a77554e8d7e9a97a18 (diff)
downloadslackbuilds-9a9964d19d161cf72df17316790e821f55056884.tar.gz
slackbuilds-9a9964d19d161cf72df17316790e821f55056884.tar.xz
python/python3-celery: renamed from celery for python3, updated for version 5.2.3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-celery')
-rw-r--r--python/python3-celery/README14
-rw-r--r--python/python3-celery/python3-celery.SlackBuild79
-rw-r--r--python/python3-celery/python3-celery.info10
-rw-r--r--python/python3-celery/slack-desc19
-rw-r--r--python/python3-celery/versions.patch22
5 files changed, 144 insertions, 0 deletions
diff --git a/python/python3-celery/README b/python/python3-celery/README
new file mode 100644
index 0000000000..6bc0f28112
--- /dev/null
+++ b/python/python3-celery/README
@@ -0,0 +1,14 @@
+Distributed Task Queue
+
+Task queues are used as a mechanism to distribute work across threads or
+machines.
+
+A task queue's input is a unit of work, called a task, dedicated worker
+processes then constantly monitor the queue for new work to perform.
+
+Celery communicates via messages, usually using a broker to mediate
+between clients and workers. To initiate a task a client puts a message
+on the queue, the broker then delivers the message to a worker.
+
+A Celery system can consist of multiple workers and brokers, giving way
+to high availability and horizontal scaling.
diff --git a/python/python3-celery/python3-celery.SlackBuild b/python/python3-celery/python3-celery.SlackBuild
new file mode 100644
index 0000000000..8e46883ad2
--- /dev/null
+++ b/python/python3-celery/python3-celery.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/bash
+
+# SlackBuild script for celery.
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-celery
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-5.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cat $CWD/versions.patch | patch -p1 || exit 1
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-celery/python3-celery.info b/python/python3-celery/python3-celery.info
new file mode 100644
index 0000000000..5e110383b7
--- /dev/null
+++ b/python/python3-celery/python3-celery.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-celery"
+VERSION="5.2.3"
+HOMEPAGE="https://docs.celeryproject.org/"
+DOWNLOAD="https://pypi.python.org/packages/source/c/celery/celery-5.2.3.tar.gz"
+MD5SUM="fe86cb01c4fe26c3b2b6cc9a83939af3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-kombu python3-billiard python3-prompt_toolkit pytz click click-didyoumean click-plugins click-repl"
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-celery/slack-desc b/python/python3-celery/slack-desc
new file mode 100644
index 0000000000..7856408028
--- /dev/null
+++ b/python/python3-celery/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-celery: python3-celery (Distributed Task Queue)
+python3-celery:
+python3-celery: Task queues are used as a mechanism to distribute work across threads
+python3-celery: or machines.
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
+python3-celery:
diff --git a/python/python3-celery/versions.patch b/python/python3-celery/versions.patch
new file mode 100644
index 0000000000..40538f9a0d
--- /dev/null
+++ b/python/python3-celery/versions.patch
@@ -0,0 +1,22 @@
+diff -c a/requirements/default.txt b/requirements/default.txt
+*** a/requirements/default.txt 2022-03-04 23:38:27.302040098 +0100
+--- b/requirements/default.txt 2022-03-04 23:38:51.109040631 +0100
+***************
+*** 2,9 ****
+ billiard>=3.6.4.0,<4.0
+ kombu>=5.2.3,<6.0
+ vine>=5.0.0,<6.0
+! click>=8.0.3,<9.0
+ click-didyoumean>=0.0.3
+! click-repl>=0.2.0
+ click-plugins>=1.1.1
+! setuptools>=59.1.1,<59.7.0
+--- 2,9 ----
+ billiard>=3.6.4.0,<4.0
+ kombu>=5.2.3,<6.0
+ vine>=5.0.0,<6.0
+! click<9.0
+ click-didyoumean>=0.0.3
+! click-repl>=0.1.6
+ click-plugins>=1.1.1
+! setuptools<59.7.0