summaryrefslogtreecommitdiffstats
path: root/python/python3-ply
diff options
context:
space:
mode:
author Lockywolf <for_sbo.python3-ply_2023-07-02@lockywolf.net>2023-07-08 12:22:38 +0900
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-08 16:41:51 +0700
commit643836c6daa4eec1b1461415a7d975a7c86acbdb (patch)
treeb7e62a83c8f1eaad558ebe7b8076f07a8c6d1ef8 /python/python3-ply
parentf514388d3f6ada30d416d628859a8bef34759563 (diff)
downloadslackbuilds-643836c6daa4eec1b1461415a7d975a7c86acbdb.tar.gz
slackbuilds-643836c6daa4eec1b1461415a7d975a7c86acbdb.tar.xz
python/python3-ply: Added (python lex-yacc).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-ply')
-rw-r--r--python/python3-ply/README13
-rw-r--r--python/python3-ply/python3-ply.SlackBuild82
-rw-r--r--python/python3-ply/python3-ply.info10
-rw-r--r--python/python3-ply/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/python/python3-ply/README b/python/python3-ply/README
new file mode 100644
index 0000000000..c3c6b73aa9
--- /dev/null
+++ b/python/python3-ply/README
@@ -0,0 +1,13 @@
+PLY is a zero-dependency Python implementation of the traditional
+parsing tools lex and yacc. It uses the same LALR(1) parsing algorithm
+as yacc and has most of its core features. It is compatible with all
+modern versions of Python.
+
+PLY was originally created in 2001 to support an Introduction to
+Compilers course at the University of Chicago. As such, it has almost
+no features other than the core LALR(1) parsing algorithm. This is by
+design--students should be made to suffer. Well, at least a little
+bit. However, from a more practical point of view, there is a lot
+flexibility in terms of how you decide to use it. You can use PLY to
+build Abstract Syntax Trees (ASTs), simple one-pass compilers,
+protocol decoders, or even a more advanced parsing framework.
diff --git a/python/python3-ply/python3-ply.SlackBuild b/python/python3-ply/python3-ply.SlackBuild
new file mode 100644
index 0000000000..a48fdcbcaf
--- /dev/null
+++ b/python/python3-ply/python3-ply.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/bash
+
+# Slackware build script for python3-ply
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-ply
+TARNAM=ply
+VERSION=${VERSION:-3.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.md ANNOUNCE CHANGES \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-ply/python3-ply.info b/python/python3-ply/python3-ply.info
new file mode 100644
index 0000000000..b7e9b1f8aa
--- /dev/null
+++ b/python/python3-ply/python3-ply.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-ply"
+VERSION="3.11"
+HOMEPAGE="https://github.com/dabeaz/ply"
+DOWNLOAD="https://files.pythonhosted.org/packages/e5/69/882ee5c9d017149285cab114ebeab373308ef0f874fcdac9beb90e0ac4da/ply-3.11.tar.gz"
+MD5SUM="6465f602e656455affcd7c5734c638f8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-ply_2023-07-02@lockywolf.net"
diff --git a/python/python3-ply/slack-desc b/python/python3-ply/slack-desc
new file mode 100644
index 0000000000..06f3cc7b7e
--- /dev/null
+++ b/python/python3-ply/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-ply: python3-ply (Python Lex-Yacc)
+python3-ply:
+python3-ply: PLY is a zero-dependency Python implementation of the traditional
+python3-ply: parsing tools lex and yacc. It uses the same LALR(1) parsing
+python3-ply: algorithm as yacc and has most of its core features.
+python3-ply:
+python3-ply:
+python3-ply:
+python3-ply:
+python3-ply:
+python3-ply: