summaryrefslogtreecommitdiffstats
path: root/python/python3-soupsieve
diff options
context:
space:
mode:
author Giancarlo Dessì <slack@giand.it>2023-06-17 07:13:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-17 07:13:13 +0700
commit77f45acd780eb4a12d70c94bedd8d3aa2dcd9a50 (patch)
tree713af245fd6466a51b2efb71c93f61b5b1d9e037 /python/python3-soupsieve
parentc682d50088f24f6bb47bfc627e234d47b9e02dae (diff)
downloadslackbuilds-77f45acd780eb4a12d70c94bedd8d3aa2dcd9a50.tar.gz
slackbuilds-77f45acd780eb4a12d70c94bedd8d3aa2dcd9a50.tar.xz
python/python3-soupsieve: Updated for version 2.4.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-soupsieve')
-rw-r--r--python/python3-soupsieve/README3
-rw-r--r--python/python3-soupsieve/python3-soupsieve.SlackBuild22
-rw-r--r--python/python3-soupsieve/python3-soupsieve.info12
3 files changed, 14 insertions, 23 deletions
diff --git a/python/python3-soupsieve/README b/python/python3-soupsieve/README
index 907b6b44af..a294930611 100644
--- a/python/python3-soupsieve/README
+++ b/python/python3-soupsieve/README
@@ -4,3 +4,6 @@ filtering using modern CSS selectors.
Soup Sieve >= 2.0.0 has dropped Python 2 support. The
python-soupsieve SlackBuild is available at version 1.9.6.
+
+python3-build, python3-hatchling, python3-installer are
+dependencies required for the build only.
diff --git a/python/python3-soupsieve/python3-soupsieve.SlackBuild b/python/python3-soupsieve/python3-soupsieve.SlackBuild
index febaa8ae05..9fa6a758de 100644
--- a/python/python3-soupsieve/python3-soupsieve.SlackBuild
+++ b/python/python3-soupsieve/python3-soupsieve.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python3-soupsieve
+# Copyright 2023 Giancarlo Dessì, Cagliari, IT, <slack@giand.it>
# Copyright 2020-2022 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
@@ -28,8 +29,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-soupsieve
-VERSION=${VERSION:-2.3.1}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.4.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -52,20 +53,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -81,7 +68,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-soupsieve/python3-soupsieve.info b/python/python3-soupsieve/python3-soupsieve.info
index 94ecabf51b..6cb5d2d27c 100644
--- a/python/python3-soupsieve/python3-soupsieve.info
+++ b/python/python3-soupsieve/python3-soupsieve.info
@@ -1,10 +1,10 @@
PRGNAM="python3-soupsieve"
-VERSION="2.3.1"
+VERSION="2.4.1"
HOMEPAGE="https://github.com/facelessuser/soupsieve"
-DOWNLOAD="https://github.com/facelessuser/soupsieve/archive/2.3.1/soupsieve-2.3.1.tar.gz"
-MD5SUM="fa73aed77dc311dbe10f261a65d86c8d"
+DOWNLOAD="https://github.com/facelessuser/soupsieve/archive/2.4.1/soupsieve-2.4.1.tar.gz"
+MD5SUM="df654fb65ae8a79f5badca7c201ce414"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu@protonmail.com"
+REQUIRES="python3-build python3-hatchling python3-installer"
+MAINTAINER="Giancarlo Dessì"
+EMAIL="slack@giand.it"