summaryrefslogtreecommitdiffstats
path: root/python/python3-soxr
diff options
context:
space:
mode:
author Jeremy Hansen <jebrhansen+github@gmail.com>2023-10-02 17:38:20 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-10-07 00:59:32 +0700
commita4dc2e5d4cd439c5ae5b8d84b77c8b45e1372b09 (patch)
tree6ce6ee1601b7d3afa8f9fecf0a2b13a4be36b835 /python/python3-soxr
parent8a10623e4a9ae546a002c623619fa79fb3b89398 (diff)
downloadslackbuilds-a4dc2e5d4cd439c5ae5b8d84b77c8b45e1372b09.tar.gz
slackbuilds-a4dc2e5d4cd439c5ae5b8d84b77c8b45e1372b09.tar.xz
python/python3-soxr: Version bump to 0.3.6
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-soxr')
-rw-r--r--python/python3-soxr/fix_arm_and_i686.patch59
-rw-r--r--python/python3-soxr/python3-soxr.SlackBuild24
-rw-r--r--python/python3-soxr/python3-soxr.info6
3 files changed, 8 insertions, 81 deletions
diff --git a/python/python3-soxr/fix_arm_and_i686.patch b/python/python3-soxr/fix_arm_and_i686.patch
deleted file mode 100644
index c3aff84b20..0000000000
--- a/python/python3-soxr/fix_arm_and_i686.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 20c26bb5f8402f12f1a2452a7228c258c64d5b95 Mon Sep 17 00:00:00 2001
-From: dofuuz <dofu@nate.com>
-Date: Wed, 14 Jul 2021 19:15:15 +0900
-Subject: [PATCH] Fix ARM, linux_i686 compile
-
----
- .github/workflows/build-dist.yml | 2 +-
- setup.py | 12 +++++++++++-
- 2 files changed, 12 insertions(+), 2 deletions(-)
-
-diff --git a/.github/workflows/build-dist.yml b/.github/workflows/build-dist.yml
-index 1cccbec..3a406a7 100644
---- a/.github/workflows/build-dist.yml
-+++ b/.github/workflows/build-dist.yml
-@@ -33,7 +33,7 @@ jobs:
- uses: joerick/cibuildwheel@v1.11.0
- env:
- # Skip build errors
-- CIBW_SKIP: "*-manylinux_i686 pp*-macosx_x86_64 pp*-win32"
-+ CIBW_SKIP: "pp*-macosx_x86_64 pp*-win32"
-
- - uses: actions/upload-artifact@v2
- with:
-diff --git a/setup.py b/setup.py
-index b7b6a85..66f8ff1 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1,6 +1,8 @@
- from setuptools import find_packages
- from setuptools import setup, Extension
-
-+import distutils.util
-+
-
- class CySoxrExtension(Extension):
- def __init__(self, *args, **kwargs):
-@@ -48,13 +50,21 @@ def include_dirs(self, dirs):
- 'soxr/cysoxr.pyx'
- ]
-
-+compile_args = ['-DSOXR_LIB']
-+platform = distutils.util.get_platform()
-+
-+if '-arm' in platform or '-aarch' in platform:
-+ compile_args.append('-mfpu=neon')
-+elif '-i686' in platform:
-+ compile_args.append('-msse')
-+
- extensions = [
- CySoxrExtension(
- "soxr.cysoxr",
- src,
- include_dirs=['libsoxr/src', 'soxr'],
- language="c",
-- extra_compile_args=['-DSOXR_LIB'])
-+ extra_compile_args=compile_args)
- ]
-
-
diff --git a/python/python3-soxr/python3-soxr.SlackBuild b/python/python3-soxr/python3-soxr.SlackBuild
index f02dd8dd89..6e24371cad 100644
--- a/python/python3-soxr/python3-soxr.SlackBuild
+++ b/python/python3-soxr/python3-soxr.SlackBuild
@@ -24,10 +24,10 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-soxr
-VERSION=${VERSION:-0.2.4}
+VERSION=${VERSION:-0.3.6}
SOXRVER=${SOXRVER:-0.1.3}
SRCNAM=${SRCNAM:-python-soxr}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -82,10 +68,10 @@ find -L . \
export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
-# Fix builds on i686 and possibly arm
+# Fix version importing when using setuptools_scm<7
# Thanks to dofuuz
-# https://github.com/dofuuz/python-soxr/issues/17
-patch -p1 < $CWD/fix_arm_and_i686.patch
+# https://github.com/dofuuz/python-soxr/issues/21
+sed -i 's/import __version__/import version as __version__/' src/soxr/__init__.py
python3 setup.py install --root=$PKG
diff --git a/python/python3-soxr/python3-soxr.info b/python/python3-soxr/python3-soxr.info
index 272657fba1..08272f523f 100644
--- a/python/python3-soxr/python3-soxr.info
+++ b/python/python3-soxr/python3-soxr.info
@@ -1,9 +1,9 @@
PRGNAM="python3-soxr"
-VERSION="0.2.4"
+VERSION="0.3.6"
HOMEPAGE="https://github.com/dofuuz/python-soxr/"
-DOWNLOAD="https://github.com/dofuuz/python-soxr/archive/refs/tags/v0.2.4/python-soxr-0.2.4.tar.gz \
+DOWNLOAD="https://github.com/dofuuz/python-soxr/archive/refs/tags/v0.3.6/python-soxr-0.3.6.tar.gz \
https://github.com/dofuuz/soxr/archive/refs/tags/0.1.3/soxr-0.1.3.tar.gz"
-MD5SUM="b1f9fa85bc189ef914e8ab1471c9ac6d \
+MD5SUM="761c75ac76786e393803aa344c323cd1 \
e5e698e1f08971b6544c3639cd0cda4a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""