summaryrefslogtreecommitdiffstats
path: root/python/python3-tomlkit
diff options
context:
space:
mode:
author Isaac Yu <isaacyu1@isaacyu1.com>2023-03-27 12:48:44 -0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-01 09:14:28 +0700
commite47b321afb16f6d8a54434c0872a1c0970f7c31e (patch)
tree0712249675c57f5e1a2961206806d940c90bef0f /python/python3-tomlkit
parentbe342314127532f09b5c378a519f201bb450fb5c (diff)
downloadslackbuilds-e47b321afb16f6d8a54434c0872a1c0970f7c31e.tar.gz
slackbuilds-e47b321afb16f6d8a54434c0872a1c0970f7c31e.tar.xz
python/python3-tomlkit: Updated for version 0.11.7.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-tomlkit')
-rw-r--r--python/python3-tomlkit/python3-tomlkit.SlackBuild12
-rw-r--r--python/python3-tomlkit/python3-tomlkit.info8
2 files changed, 9 insertions, 11 deletions
diff --git a/python/python3-tomlkit/python3-tomlkit.SlackBuild b/python/python3-tomlkit/python3-tomlkit.SlackBuild
index 30daa4f84f..4595b6a778 100644
--- a/python/python3-tomlkit/python3-tomlkit.SlackBuild
+++ b/python/python3-tomlkit/python3-tomlkit.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-tomlkit
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2023 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-tomlkit
-VERSION=${VERSION:-0.11.6}
+VERSION=${VERSION:-0.11.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -81,13 +78,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-tomlkit/python3-tomlkit.info b/python/python3-tomlkit/python3-tomlkit.info
index 49afa6afba..d38cb4d4b0 100644
--- a/python/python3-tomlkit/python3-tomlkit.info
+++ b/python/python3-tomlkit/python3-tomlkit.info
@@ -1,10 +1,10 @@
PRGNAM="python3-tomlkit"
-VERSION="0.11.6"
+VERSION="0.11.7"
HOMEPAGE="https://github.com/sdispater/tomlkit"
-DOWNLOAD="https://github.com/sdispater/tomlkit/releases/download/0.11.6/tomlkit-0.11.6.tar.gz"
-MD5SUM="ac33a015aa5f3f8e8e0667081b388bb7"
+DOWNLOAD="https://github.com/sdispater/tomlkit/releases/download/0.11.7/tomlkit-0.11.7.tar.gz"
+MD5SUM="8606dffbcb744b1c023f786015ddd8a7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-poetry-core wheel"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu1@isaacyu1.com"