summaryrefslogtreecommitdiffstats
path: root/python/python3-uri_template
diff options
context:
space:
mode:
author isaackwy <isaacyu@protonmail.com>2024-02-17 00:09:42 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2024-02-17 22:25:18 +0700
commit6a3120f2544838540d4b8a1cd50df357771ee637 (patch)
treeb73a1a60ec315fca59608a852ec778289ac662a3 /python/python3-uri_template
parent176b550f83f9cac88810225676180aef8aa86286 (diff)
downloadslackbuilds-6a3120f2544838540d4b8a1cd50df357771ee637.tar.gz
slackbuilds-6a3120f2544838540d4b8a1cd50df357771ee637.tar.xz
python/python3-uri_template: Update for 1.3.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-uri_template')
-rw-r--r--python/python3-uri_template/python3-uri_template.SlackBuild26
-rw-r--r--python/python3-uri_template/python3-uri_template.info8
2 files changed, 12 insertions, 22 deletions
diff --git a/python/python3-uri_template/python3-uri_template.SlackBuild b/python/python3-uri_template/python3-uri_template.SlackBuild
index a2c69534ba..42f583da2b 100644
--- a/python/python3-uri_template/python3-uri_template.SlackBuild
+++ b/python/python3-uri_template/python3-uri_template.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-uri_template
-# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-uri_template
-VERSION=${VERSION:-1.2.0}
+VERSION=${VERSION:-1.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -49,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,13 +64,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+export PYTHONPATH=/opt/python3.9/site-packages/
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/python3-uri_template/python3-uri_template.info b/python/python3-uri_template/python3-uri_template.info
index 09015850f8..31ff4347f9 100644
--- a/python/python3-uri_template/python3-uri_template.info
+++ b/python/python3-uri_template/python3-uri_template.info
@@ -1,10 +1,10 @@
PRGNAM="python3-uri_template"
-VERSION="1.2.0"
+VERSION="1.3.0"
HOMEPAGE="https://github.com/plinss/uri-template"
-DOWNLOAD="https://github.com/plinss/uri-template/archive/v1.2.0/uri-template-1.2.0.tar.gz"
-MD5SUM="c7ffa34f8bbf4632aab2f0b6e0df27fe"
+DOWNLOAD="https://github.com/plinss/uri-template/archive/v1.3.0/uri-template-1.3.0.tar.gz"
+MD5SUM="b65387876aeca2d332d53cc11669ff22"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-scm-opt"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"