summaryrefslogtreecommitdiffstats
path: root/python/python3-uritools
diff options
context:
space:
mode:
author Nikos Giotis <nikos.giotis@gmail.com>2023-11-26 09:36:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2023-11-26 10:11:57 +0700
commit1068c4374dc3f4c31df5310776ccb5624bb79bd1 (patch)
tree316403d4964da114aaba0618cf8afcbec609c86e /python/python3-uritools
parent45f0ace85b67fbf2f36a531a756efbce41b36c76 (diff)
downloadslackbuilds-1068c4374dc3f4c31df5310776ccb5624bb79bd1.tar.gz
slackbuilds-1068c4374dc3f4c31df5310776ccb5624bb79bd1.tar.xz
python/python3-uritools: Added (parsing URI library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-uritools')
-rw-r--r--python/python3-uritools/README15
-rw-r--r--python/python3-uritools/python3-uritools.SlackBuild95
-rw-r--r--python/python3-uritools/python3-uritools.info10
-rw-r--r--python/python3-uritools/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/python/python3-uritools/README b/python/python3-uritools/README
new file mode 100644
index 0000000000..42dc3f8706
--- /dev/null
+++ b/python/python3-uritools/README
@@ -0,0 +1,15 @@
+For various reasons, urllib.parse and its Python 2 predecessor urlparse
+are not compliant with current Internet standards. As stated in
+Lib/urllib/parse.py:
+
+ RFC 3986 is considered the current standard and any future changes to
+ urlparse module should conform with it. The urlparse module is
+ currently not entirely compliant with this RFC due to defacto
+ scenarios for parsing, and for backward compatibility purposes, some
+ parsing quirks from older RFCs are retained.
+
+This module aims to provide fully RFC 3986 compliant replacements for
+the most commonly used functions found in urllib.parse. It also
+includes functions for distinguishing between the different forms of
+URIs and URI references, and for conveniently creating URIs from their
+individual components.
diff --git a/python/python3-uritools/python3-uritools.SlackBuild b/python/python3-uritools/python3-uritools.SlackBuild
new file mode 100644
index 0000000000..5bf4284a6d
--- /dev/null
+++ b/python/python3-uritools/python3-uritools.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/bash
+
+# Slackware build script for python3-uritools
+
+# Copyright 2022-2023 Nikos Giotis, Athens, GR
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+SRCNAM=uritools
+PRGNAM=python3-uritools
+VERSION=${VERSION:-4.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.rst LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-uritools/python3-uritools.info b/python/python3-uritools/python3-uritools.info
new file mode 100644
index 0000000000..71dee0d042
--- /dev/null
+++ b/python/python3-uritools/python3-uritools.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-uritools"
+VERSION="4.0.0"
+HOMEPAGE="https://github.com/tkem/uritools/"
+DOWNLOAD="https://files.pythonhosted.org/packages/32/ed/1f957f5139c15f88469e1446d377da53879eddaf961f1ffc94a392202b40/uritools-4.0.0.tar.gz"
+MD5SUM="35040e6183fa8773fc630c430ce614a0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Nikos Giotis"
+EMAIL="nikos.giotis@gmail.com"
diff --git a/python/python3-uritools/slack-desc b/python/python3-uritools/slack-desc
new file mode 100644
index 0000000000..63ebf6912f
--- /dev/null
+++ b/python/python3-uritools/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-uritools: python3-uritools (Python module that implements RFC 3986)
+python3-uritools:
+python3-uritools: This module provides RFC 3986 compliant functions for parsing,
+python3-uritools: classifying and composing URIs and URI references, largely replacing
+python3-uritools: the Python Standard Library's urllib.parse module.
+python3-uritools:
+python3-uritools:
+python3-uritools:
+python3-uritools:
+python3-uritools:
+python3-uritools: