summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.no-static-library.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2013-12-31 06:47:24 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-01-07 11:13:59 -0600
commit4ffc3b91a594a6848a893560a559346fbd9d3c89 (patch)
treed04b11c2c349fb7264b371d662d27b1f259773d5 /python/python3/patches/python3.no-static-library.diff
parent14ea9bbcbcfa131e7ce6dd0bb8b66041fa0f2cea (diff)
downloadslackbuilds-4ffc3b91a594a6848a893560a559346fbd9d3c89.tar.gz
slackbuilds-4ffc3b91a594a6848a893560a559346fbd9d3c89.tar.xz
python/python3: Updated for version 3.3.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--python/python3/patches/python3.no-static-library.diff16
1 files changed, 8 insertions, 8 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index c0e48bd9fb..fa28c0d615 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
---- Python-3.3.1.orig/Makefile.pre.in 2013-04-06 10:41:48.000000000 +0300
-+++ Python-3.3.1/Makefile.pre.in 2013-04-21 15:43:24.509324568 +0300
-@@ -471,7 +471,7 @@
+diff -uar Python-3.3.3.orig/Makefile.pre.in Python-3.3.3/Makefile.pre.in
+--- Python-3.3.3.orig/Makefile.pre.in 2013-11-17 09:22:55.000000000 +0200
++++ Python-3.3.3/Makefile.pre.in 2013-12-29 13:38:17.787830460 +0200
+@@ -475,7 +475,7 @@
# Build the interpreter
@@ -10,8 +10,8 @@ diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -495,18 +495,6 @@
- $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' \
+@@ -500,18 +500,6 @@
+ _TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
-# Build static library
@@ -29,7 +29,7 @@ diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -596,7 +584,7 @@
+@@ -601,7 +589,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.3.1.orig/Makefile.pre.in Python-3.3.1/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1191,18 +1179,6 @@
+@@ -1197,18 +1185,6 @@
else true; \
fi; \
done