summaryrefslogtreecommitdiffstats
path: root/python/python3/patches/python3.no-static-library.diff
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2014-03-30 02:52:42 -0500
committer Erik Hanson <erik@slackbuilds.org>2014-04-12 13:59:48 -0500
commitd9a8bbf2e1c9302db876e15b3459b59c5f903db4 (patch)
treee65d52307fc6c52a4e0850a99b0f60f7d1320f43 /python/python3/patches/python3.no-static-library.diff
parent10b1a40f6a8b0b59855dc5a8692bd926c5b83e7f (diff)
downloadslackbuilds-d9a8bbf2e1c9302db876e15b3459b59c5f903db4.tar.gz
slackbuilds-d9a8bbf2e1c9302db876e15b3459b59c5f903db4.tar.xz
python/python3: Updated for version 3.4.0.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to '')
-rw-r--r--python/python3/patches/python3.no-static-library.diff16
1 files changed, 8 insertions, 8 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index 2bb1afccf3..bbc0e3a817 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,8 +1,8 @@
-diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
---- Python-3.3.5.orig/Makefile.pre.in 2014-03-09 10:40:23.000000000 +0200
-+++ Python-3.3.5/Makefile.pre.in 2014-03-12 22:42:27.614023691 +0200
-@@ -475,7 +475,7 @@
-
+diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
+--- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
++++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:27:38.788419450 +0200
+@@ -532,7 +532,7 @@
+ $(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
-$(BUILDPYTHON): Modules/python.o $(LIBRARY) $(LDLIBRARY) $(PY3LIBRARY)
@@ -10,7 +10,7 @@ diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -500,18 +500,6 @@
+@@ -557,18 +557,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -601,7 +589,7 @@
+@@ -658,7 +646,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.3.5.orig/Makefile.pre.in Python-3.3.5/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1200,18 +1188,6 @@
+@@ -1309,18 +1297,6 @@
else true; \
fi; \
done